<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    Making A Period Correct Pit Stop For Sunday Service - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Facebook App Code -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '252792185178857',
      cookie     : true,
      xfbml      : true,
      version    : 'v2.8'
    });
    FB.AppEvents.logPageView();   
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- End Facebook App Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Making A Period Correct Pit Stop For Sunday Service - Speedhunters" />
<meta property="og:description" content="A staple of the West Coast scene is events, but in between lockdowns and work commitments I’ve only attended a small number of them in the past 12 months. So having a rare free Sunday morning, I just had to check out the Brekkie Car Club ‘Sunday Service’ at Period Correct. If you’re in Southern California and can &hellip;" />
<meta property="og:url" content="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="Brekkie Car Club" />
<meta property="article:tag" content="California" />
<meta property="article:tag" content="Car Show" />
<meta property="article:tag" content="Cars &amp; Coffee" />
<meta property="article:tag" content="Cars and Coffee" />
<meta property="article:tag" content="Period Correct" />
<meta property="article:tag" content="Period Correct Pit Stop" />
<meta property="article:tag" content="Sunday Service" />
<meta property="article:section" content="Content" />
<meta property="article:section" content="Event Coverage" />
<meta property="article:published_time" content="2021-04-18T22:30:16+00:00" />
<meta property="article:modified_time" content="2021-04-19T05:10:04+00:00" />
<meta property="og:updated_time" content="2021-04-19T05:10:04+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163251/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6366.jpg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Making A Period Correct Pit Stop For Sunday&nbsp;Service Comments Feed" href="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/feed/" />
<link rel='stylesheet' id='decomments-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background:  !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color: !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color: !important; } .decomments-gif:after{ border-left-color: !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background: !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke: !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill: !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke: !important; }
			 </style>
			<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=513348' />

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://speedhunters.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-513348 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Tealium -->
<script type="text/javascript">
var utag_data = {
}
</script>

<!-- Loading script asynchronously -->
<script type="text/javascript">
    (function(a,b,c,d){
    a='//tags.tiqcdn.com/utag/ea/speedhunterscom/prod/utag.js';
    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
    })();
</script>
<!-- End Tealium -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>

        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>

                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                Making A Period Correct Pit Stop For Sunday&nbsp;Service            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-513348" class="post-513348 post type-post status-publish format-standard has-post-thumbnail hentry category-content category-eventcoverage tag-brekkie-car-club tag-california tag-car-show-tag tag-cars-coffee tag-cars-and-coffee tag-period-correct tag-period-correct-pit-stop tag-sunday-service">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			<div class="story-meta large-12 columns">
  <div class="large-10 large-centered columns article-meta">
    <h1 class="entry-title">Making A Period Correct Pit Stop For Sunday&nbsp;Service</h1>
    <hr />
    
<div class="story-label category-eventcoverage">
	<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
    <dl>
                            <dt>By</dt>
                    <dd><a href="http://www.speedhunters.com/author/keironberndt/" title="Posts by Keiron Berndt" class="url fn" rel="author">Keiron Berndt</a></dd>
                    </dl>
          <hr />

          <span class="story-date">18th April 2021</span>
          <span class="story-comments">
            <i class="fi-comments"></i>
            <a class="comments-link" href="#comments">0 Comments</a>
          </span>
        </div>
      </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163251/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6366.jpg" data-attachment-id="513377" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163251/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6366-1200x800.jpg" alt="Making A Period Correct Pit Stop For Sunday&nbsp;Service">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><p class="intro-p">For automotive enthusiasts, there are a lot of things <em>not</em> to love about California. However, it’s hard to knock The Golden State when it comes to car culture, because it’s vibrant with many different facets.</p>
<p>A staple of the West Coast scene is events, but in between lockdowns and work commitments I’ve only attended a small number of them in the past 12 months. So having a rare free Sunday morning, I just had to check out the Brekkie Car Club ‘Sunday Service’ at Period Correct.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163326/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6513.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163326/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6513-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513387" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163326/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6513.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6513/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163326/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6513-1200x800.jpg"></a></figure><p>If you’re in Southern California and can only attend one event, a cars and coffee meet at Period Correct should be it.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163112/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6103-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513349" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163112/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6103.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6103/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163112/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6103-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163116/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6115-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513350" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163116/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6115.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6115/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163116/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6115-1200x800.jpg"></div></li></ul><p>Getting to Period Correct’s altelier in Costa Mesa was my first challenge though. I had recently embarked on a journey home from Sacramento with my Mercedes-Benz 190E, which prior to this had been sitting idle for the past <em>few</em> years (read: almost 10). Before the drive, a couple of days were spent getting it ‘roadworthy.’</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163119/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6134.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163119/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6134-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513351" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163119/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6134.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6134/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163119/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6134-1200x800.jpg"></a></figure><p>While this should have just involved a check of the vitals and a replacement of all the fluids, somehow I ended up dropping the suspension – with a blowtorch (definitely not recommended and something I now regret…) – and fitting some different wheels.</p>
<ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163123/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6144-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513352" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163123/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6144.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6144/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163123/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6144-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163130/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6175-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513354" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163130/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6175.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6175/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163130/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6175-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163133/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6186-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513355" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163133/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6186.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6186/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163133/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6186-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163126/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6164-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513353" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163126/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6164.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6164/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163126/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6164-1200x800.jpg"></figure><p>It was going to be a three-hour round trip to the event, but I wasn’t that confident in the car and definitely didn’t feel like wasting my whole day waiting for a tow if everything went south. So I settled on a 40-minute round trip, which would see me hitching a ride with my friend Jan in his track-ready Porsche 997.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163218/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6292-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513368" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163218/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6292.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6292/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163218/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6292-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163223/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6300-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513369" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163223/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6300.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6300/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163223/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6300-1200x800.jpg"></div></li></ul><p>On the topic of 911s, I stand by my previous statement that the 997 generation is one of the best modern performance cars money can buy right now. Am I wrong?</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163156/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6231.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163156/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6231-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513361" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163156/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6231.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6231/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163156/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6231-1200x800.jpg"></a></figure><p>Usually I’d grab a tea on the way to an event, however Gustavo Menezes – a 24 Hours of Le Mans winner and WEC driver – happens to live in Jan’s neighborhood and had offered up a cup of what’s claimed to be some of the best coffee around.</p>
<p>I could hardly turn that offer down, could I?!</p>
<ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163215/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6272-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513367" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163215/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6272.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6272/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163215/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6272-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163137/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6192-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513356" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163137/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6192.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6192/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163137/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6192-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163152/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6226-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513360" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163152/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6226.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6226/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163152/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6226-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163209/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6250-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513365" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163209/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6250.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6250/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163209/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6250-1200x800.jpg"></figure><p>Armed with perfectly roasted beans from Onyx Coffee Lab<em> </em>and some high-tech espresso shot-pulling tools, Gustavo went to work. I’m no coffee snob, but Jan wasn’t wrong; it was absolutely phenomenal.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163241/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6351-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513374" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163241/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6351.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6351/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163241/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6351-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163230/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6324-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513371" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163230/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6324.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6324/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163230/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6324-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163234/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6331-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513372" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163234/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6331.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6331/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163234/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6331-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163237/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6341-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513373" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163237/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6341.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6341/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163237/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6341-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163244/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6357.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163244/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6357-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513375" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163244/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6357.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6357/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163244/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6357-1200x800.jpg"></a></figure><p>Sunday Service was scheduled to start at 9:00am sharp, but these types of events always tend to kick off far earlier, and this one was no different.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163258/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6387-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513379" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163258/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6387.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6387/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163258/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6387-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163301/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6390-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513380" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163301/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6390.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6390/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163301/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6390-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163248/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6365-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513376" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163248/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6365.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6365/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163248/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6365-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163254/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6379-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513378" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163254/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6379.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6379/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163254/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6379-1200x800.jpg"></div></li></ul><p>The first thing I noticed – and I would have had to be blind to miss them – was a huge number of overland rigs, including a couple of Porsche Cayenne S Transsyberia rarities.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163304/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6411-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513381" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163304/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6411.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6411/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163304/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6411-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163312/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6488-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513383" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163312/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6488.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6488/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163312/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6488-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163523/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6757-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513421" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163523/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6757.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6757/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163523/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6757-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163316/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6491-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513384" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163316/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6491.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6491/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163316/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6491-1200x800.jpg"></figure><p>Any event at Period Correct is sure to bring out an amazing selection of special cars.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163308/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6414-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513382" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163308/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6414.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6414/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163308/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6414-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163319/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6494-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513385" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163319/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6494.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6494/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163319/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6494-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163323/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6502-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513386" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163323/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6502.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6502/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163323/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6502-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163330/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6527-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513388" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163330/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6527.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6527/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163330/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6527-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163333/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6530-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513389" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163333/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6530.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6530/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163333/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6530-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163336/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6537-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513390" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163336/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6537.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6537/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163336/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6537-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163350/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6562-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513394" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163350/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6562.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6562/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163350/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6562-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163346/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6559-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513393" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163346/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6559.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6559/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163346/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6559-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163343/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6545-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513392" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163343/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6545.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6545/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163343/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6545-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163340/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6541-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513391" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163340/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6541.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6541/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163340/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6541-1200x800.jpg"></div></li></ul><p>A quick stroll around the main lot and overflow parking led me to many gems.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163354/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6567-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513395" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163354/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6567.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6567/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163354/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6567-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163357/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6572-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513396" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163357/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6572.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6572/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163357/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6572-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163401/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6581-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513397" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163401/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6581.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6581/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163401/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6581-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163424/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6628-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513404" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163424/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6628.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6628/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163424/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6628-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163420/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6621-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513403" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163420/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6621.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6621/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163420/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6621-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163417/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6614-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513402" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163417/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6614.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6614/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163417/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6614-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163451/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6675-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513412" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163451/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6675.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6675/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163451/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6675-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163516/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6741-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513419" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163516/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6741.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6741/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163516/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6741-1200x800.jpg"></div></li></ul><p>As expected, Porsches were in plentiful supply, but there was so much more – many of which were completed unexpected.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163455/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6678.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163455/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6678-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513413" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163455/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6678.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6678/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163455/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6678-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163458/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6683.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163458/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6683-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be FriendsPeriod Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513414" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163458/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6683.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6683/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163458/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6683-1200x800.jpg"></a></figure><p>Like this Mercedes-Benz W114 with an AMG C36 M104 swap that looks like it came factory. Stay tuned for a full feature on this one…</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163428/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6636.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163428/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6636-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513405" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163428/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6636.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6636/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163428/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6636-1200x800.jpg"></a></figure><p>But as much as I love Mercedes-Benz, this simple-yet-classy BMW 2002 stole the show for me.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163414/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6609-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513401" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163414/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6609.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6609/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163414/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6609-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163445/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6659-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513410" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163445/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6659.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6659/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163445/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6659-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163431/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6639-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513406" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163431/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6639.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6639/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163431/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6639-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163441/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6653-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513409" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163441/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6653.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6653/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163441/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6653-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163448/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6660-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513411" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163448/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6660.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6660/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163448/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6660-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163438/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6649-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513408" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163438/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6649.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6649/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163438/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6649-1200x800.jpg"></figure><p>The balance between style and function was impressive. From R888R-equipped mesh wheels to its meatball patina paint scheme and classed-up interior with wooden wheel, there’s nothing I didn’t love.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163537/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6774.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163537/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6774-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513425" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163537/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6774.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6774/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163537/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6774-1200x800.jpg"></a></figure><p>One bonus of this event was being able to spend time in Period Correct’s showroom.</p>
<ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163533/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6772-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513424" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163533/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6772.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6772/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163533/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6772-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163602/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6806-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513432" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163602/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6806.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6806/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163602/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6806-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163530/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6770-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513423" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163530/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6770.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6770/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163530/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6770-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163526/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6763-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513422" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163526/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6763.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6763/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163526/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6763-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163541/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6777-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513426" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163541/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6777.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6777/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163541/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6777-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163610/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6814-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513434" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163610/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6814.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6814/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163610/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6814-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163544/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6779-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513427" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163544/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6779.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6779/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163544/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6779-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163519/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6754-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513420" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163519/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6754.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6754/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163519/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6754-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163648/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6845-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513443" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163648/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6845.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6845/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163648/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6845-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163631/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6832-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513439" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163631/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6832.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6832/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163631/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6832-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163640/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6837-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513441" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163640/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6837.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6837/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163640/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6837-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163558/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6799.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163558/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6799-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513431" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163558/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6799.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6799/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163558/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6799-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163635/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6835-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513440" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163635/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6835.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6835/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163635/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6835-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163627/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6829-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513438" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163627/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6829.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6829/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163627/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6829-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163614/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6815-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513435" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163614/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6815.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6815/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163614/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6815-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163548/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6781.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163548/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6781-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513428" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163548/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6781.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6781/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163548/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6781-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163618/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6819-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513436" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163618/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6819.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6819/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163618/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6819-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163652/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6847-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513444" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163652/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6847.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6847/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163652/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6847-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163644/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6842-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513442" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163644/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6842.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6842/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163644/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6842-1200x800.jpg"></div></li></ul><p>There’s always historic posters, flyers, literature and cars that never seem to disappoint on display here, and this time was no different.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163623/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6822-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513437" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163623/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6822.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6822/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163623/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6822-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163555/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6796-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513430" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163555/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6796.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6796/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163555/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6796-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163656/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6854-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513445" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163656/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6854.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6854/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163656/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6854-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163700/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6873.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163700/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6873-680x453.jpg" alt="Period Correct Things - Speedhunters - 18 - 4- 2021 - Keiron Berndt - Let's Be Friends" data-attachment-id="513446" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163700/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6873.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/period-correct-things-speedhunters-18-4-2021-keiron-berndt-lets-be-friends-6873/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/18163700/Period-Correct-Things-Speedhunters-18-4-2021-Keiron-Berndt-Lets-Be-Friends-6873-1200x800.jpg"></a></figure><p>A morning spent with friends around quality cars and pleasing aesthetics is a morning well spent in my books. I’ll definitely be back for the next Sunday morning event at Period Correct – perhaps in my Mercedes next time.</p>
<p><strong>Keiron Berndt</strong><br>
Instagram: <a href="https://www.instagram.com/keiron_berndt/" target="_blank">keiron_berndt</a></p>
<aside class="exclude-from-p"><p><strong><a href="http://www.speedhunters.com/tag/california" target="_blank">More stories from California on Speedhunters</a></strong></p>
</aside></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[9376,7858,4295,599],"excerpt":"150","exclude":[513348]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2021/04/tokyo-coffee-and-cars-the-british-edition/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/03/23204909/uk_cars_and_coffee_dino_dalle_carbonare_48-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2021/04/tokyo-coffee-and-cars-the-british-edition/">
		
<div class="card-label category-eventcoverage">
		<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
		<h2>Tokyo Coffee &#038; Cars: The British&nbsp;Edition</h2>
		<span class="date">April 2, 2021</span>
		<span class="divider">/</span>
		<span class="comments">39 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2021/03/behind-the-wheel-of-pete-stouts-porsche-914/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/15164018/2020-Pete-Stout-Porsche-914-Six_Trevor-Ryan-Speedhunters_069_2373-3-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2021/03/behind-the-wheel-of-pete-stouts-porsche-914/">
		
<div class="card-label category-carfeatures">
		<span class="light">CAR </span><span class="potent">FEATURE</span></div>
		<h2>Behind The Wheel Of Pete Stout&#8217;s Porsche&nbsp;914</h2>
		<span class="date">March 24, 2021</span>
		<span class="divider">/</span>
		<span class="comments">24 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2021/03/theres-no-community-quite-like-the-lowrider-community/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/02/13191027/When-Cars-and-Culture-Collide-Speedhunters-Keiron-Berndt-Lets-Be-Friends-0520-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2021/03/theres-no-community-quite-like-the-lowrider-community/">
		
<div class="card-label category-speedhunterscrew">
		<span class="potent">SPECIAL </span><span class="light">FEATURE</span></div>
		<h2>There’s No Community Quite Like The Lowrider&nbsp;Community</h2>
		<span class="date">March 11, 2021</span>
		<span class="divider">/</span>
		<span class="comments">28 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title" id="comments">Comments</h4>
		<div class="de_comments">
			<div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
     data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
     data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
     data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
     data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
     data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
     data-post_id="513348"
     data-user_id="0"
     data-is_need_logged="0"
     data-lang="en"
     data-decom_comment_single_translate=" comment"
     data-decom_comment_twice_translate=" comments"
     data-decom_comment_plural_translate=" comments"
     data-multiple_vote="1"
     data-text_lang_comment_deleted='Comment deleted'
     data-text_lang_edited="Edited at"
     data-text_lang_delete="Delete"
     data-text_lang_not_zero="Field is not null"
     data-text_lang_required="This field is required."
     data-text_lang_checked="Mark one of the points"
     data-text_lang_completed="Operation completed"
     data-text_lang_items_deleted="The items have been deleted"
     data-text_lang_close="Close"
     data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform decomments-avatar-right" data-site-url="http://www.speedhunters.com">

	<div class="decomments-social-login-widget">
		 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<div class="oneall_social_login">
 <div class="oneall_social_login_label" style="margin-bottom: 3px;"><label>Connect with:</label></div>
 <div class="oneall_social_login_providers" id="oneall_social_login_providers_591015"></div>
 <script type="text/javascript">
  var _oneall = _oneall || [];
  _oneall.push(['social_login', 'set_providers', ['facebook','google','instagram','reddit','twitter']]);
  _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&amp;': '?') + "oa_social_login_source=comments"))]);
  _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
  _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_591015']);
 </script>
</div>	</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" action="http://www.speedhunters.com/wp-login.php" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="log" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="pwd" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input id="submit-form" type="hidden" name="submit" />
				<input type="hidden" name="redirect_to" value="" />
				<input type="hidden" id="security" name="security" value="1646390f66" /><input type="hidden" name="_wp_http_referer" value="/2021/04/making-a-period-correct-pit-stop-for-sunday-service/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
				<div class="comment-form" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div></div>
</div>
		</div>
	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-8 small-block-grid-4 text-center"/><li><a href="https://www.kwsuspensions.de"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/15082903/KWautomotive_Logo_180x85px.png"/></a></li><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.gtechniq.com"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/01/05074852/Gtechniq_180x85-copy3.jpg"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="https://uk.jvc.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/04/17043850/JVClogo.png"/></a></li><li><a href="http://www.speedhunters.com"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li><li><a href="http://www.kenwood-electronics.co.uk"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/04/17043409/kenwood-logo3.png"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2021/04/making-a-period-correct-pit-stop-for-sunday-service/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers and drivers with a shared passion for uncovering the world's most exciting car culture stories. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team Speedhunters</h4>			<div class="textwidget">Editorial Director:
<em>Brad Lord</em> <br />

Commercial Director: 
<em>Ben Chandler</em><br />

Creative Director: 
<em>Mark Riccioni</em><br />

Contributing Editor:
<em>Dino Dalle Carbonare</em><br />

Technical Editor: 
<em>Ryan Stewart</em><br />

Concept Artist:
<em>Khyzyl Saleem</em><br />

Contributors: 
<em>Will Beaumont, Keiron Berndt, Jordan Butters, Ron Celestine, Mario Christou, Cian Donnellan, Matthew Everingham, Blake Jones, Stefan Kotze, Vladimir Ljadov, Paddy McGrath, Rick Muda, Sara Ryan, Trevor Yale Ryan, Dave Thomas, Toby Thyer, Simon Woolley, Naveed Yousufzai</em><br />



</div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
<li><a href="http://www.h-c.co.jp/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/11043940/hashimoto.png" /></a></li>
<li><a href="https://sekritbrand.com"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/29111622/File-from-iOS-e1556562006726.gif" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2021 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/legal">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><link rel='stylesheet' id='dashicons-css'  href='http://www.speedhunters.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"http:\/\/www.speedhunters.com\/wp-admin\/admin-ajax.php","redirecturl":"\/2021\/04\/making-a-period-correct-pit-stop-for-sunday-service\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.speedhunters.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 1.355 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-04-19 05:13:01 -->

<!-- super cache -->