<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    Straight From The &#039;80s: The Santini Supra - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Facebook App Code -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '252792185178857',
      cookie     : true,
      xfbml      : true,
      version    : 'v2.8'
    });
    FB.AppEvents.logPageView();   
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- End Facebook App Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="This isn&#039;t the Supra we were looking for, but are we damn glad we found it. Read all about the Santini Supra now..."/>
<link rel="canonical" href="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Straight From The &#039;80s: The Santini Supra - Speedhunters" />
<meta property="og:description" content="This isn&#039;t the Supra we were looking for, but are we damn glad we found it. Read all about the Santini Supra now..." />
<meta property="og:url" content="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="1980s" />
<meta property="article:tag" content="2JZ" />
<meta property="article:tag" content="California" />
<meta property="article:tag" content="celica" />
<meta property="article:tag" content="Engine Swap" />
<meta property="article:tag" content="Los Angeles" />
<meta property="article:tag" content="Pete Santini" />
<meta property="article:tag" content="Retro" />
<meta property="article:tag" content="Supra" />
<meta property="article:tag" content="Toyota" />
<meta property="article:tag" content="USA" />
<meta property="article:section" content="Car Features" />
<meta property="article:section" content="Content" />
<meta property="article:published_time" content="2018-07-28T18:00:49+00:00" />
<meta property="article:modified_time" content="2018-07-27T10:19:36+00:00" />
<meta property="og:updated_time" content="2018-07-27T10:19:36+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101301/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_100.jpg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Straight From The &#8217;80s: The Santini&nbsp;Supra Comments Feed" href="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/feed/" />
<link rel='stylesheet' id='decomments-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background:  !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color: !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color: !important; } .decomments-gif:after{ border-left-color: !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background: !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke: !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill: !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke: !important; }
			 </style>
			<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=389085' />

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://speedhunters.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-389085 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Tealium -->
<script type="text/javascript">
var utag_data = {
}
</script>

<!-- Loading script asynchronously -->
<script type="text/javascript">
    (function(a,b,c,d){
    a='//tags.tiqcdn.com/utag/ea/speedhunterscom/prod/utag.js';
    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
    })();
</script>
<!-- End Tealium -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>
        							<dd><h4 data-section-title class="pointable"><a href"#" class="more-button">More&hellip;</a></h4></dd>
        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>
                                    <i data-section-title class="fi-arrow-down pointable more-button"></i>
                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                Straight From The &#8217;80s: The Santini&nbsp;Supra            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-389085" class="post-389085 post type-post status-publish format-standard has-post-thumbnail hentry category-carfeatures category-content tag-1980s tag-2jz tag-california tag-celica tag-engineswap tag-losangeles tag-pete-santini tag-tag-retro tag-supra tag-toyota tag-usa">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			<div class="story-meta large-12 columns">
  <div class="large-10 large-centered columns article-meta">
    <h1 class="entry-title">Straight From The &#8217;80s: The Santini&nbsp;Supra</h1>
    <hr />
    
<div class="story-label category-carfeatures">
	<span class="light">CAR </span><span class="potent">FEATURE</span></div>
    <dl>
                            <dt>By</dt>
                    <dd><a href="http://www.speedhunters.com/author/trevorryan/" title="Posts by Trevor Yale Ryan" class="url fn" rel="author">Trevor Yale Ryan</a></dd>
                    </dl>
          <hr />

          <span class="story-date">28th July 2018</span>
          <span class="story-comments">
            <i class="fi-comments"></i>
            <a class="comments-link" href="#comments">2 Comments</a>
          </span>
        </div>
      </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101301/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_100.jpg" data-attachment-id="389088" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101301/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_100-1200x800.jpg" alt="Straight From The &#8217;80s: The Santini&nbsp;Supra">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><span id="chapter-pete-santini" class="sh-post-chapter-break">Pete Santini</span>
<p>The name Santini was vaguely familiar to me before I met up with Eddie Perez to take a look at his second generation Toyota Supra. It turns out he snuck along a MkIII and MkIV as well, but I’ll get to those in a bit.</p>
<p>For now I want to focus on Pete Santini, who originally painted this car in 1987. Santini Paint &amp; Body has been alive and well in Westminster, California for over four decades. Santini’s work has been featured on more than 20 SEMA Show builds over the years, and he’s sprayed everything from motorcycles to hot rods to the Supra you see here.</p>
<p>His workshop is still active in Southern California and just months ago he did a bit of touch up work on Eddie’s Supra, along with a matching job on the new engine under the hood.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101306/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_101.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101306/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_101-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_101" data-attachment-id="389089" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101306/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_101.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_101/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101306/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_101-1200x800.jpg"></a></figure><p>Eddie says that when Santini saw the car he was amazed that it was still around. For 30-year-old work, it’s held up phenomenally well too. But what strikes me most about the paint job on this ’85 Supra are all the little personal touches and details that were worked into it.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101309/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_102.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101309/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_102-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_102" data-attachment-id="389090" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101309/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_102.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_102/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101309/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_102-1200x800.jpg"></a></figure><p>It all starts here…</p>
<ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101312/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_103-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_103" data-attachment-id="389091" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101312/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_103.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_103/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101312/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_103-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101316/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_104-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_104" data-attachment-id="389092" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101316/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_104.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_104/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101316/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_104-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101320/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_105-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_105" data-attachment-id="389093" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101320/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_105.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_105/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101320/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_105-1200x800.jpg"></div></li></ul><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101323/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_106-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_106" data-attachment-id="389094" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101323/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_106.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_106/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101323/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_106-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101327/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_107-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_107" data-attachment-id="389095" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101327/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_107.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_107/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101327/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_107-1200x800.jpg"></div></li></ul><p>And continues through the back end and around the entirety of the car. The creative design and color palette is so 1980s, and it works so well. Whoever wanted to do this in the first place definitely had some gonads; it’s a bold statement and something you would expect to see from this era alone.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101330/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_108.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101330/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_108-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_108" data-attachment-id="389096" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101330/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_108.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_108/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101330/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_108-1200x800.jpg"></a></figure><p>The whole package is very tidy and complete, playing nicely with the molded bodywork. An honest car, I wanted to experience it at an honest location, so we met up at Bob’s Big Boy in Burbank, the home of many meets in this area.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101333/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_109.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101333/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_109-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_109" data-attachment-id="389097" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101333/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_109.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_109/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101333/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_109-1200x800.jpg"></a></figure><p>But the Supra is hiding something. As charming as the car is to take in, there’s a big hint up front that a lot more is going on here.</p>
<span id="chapter-rad-industries" class="sh-post-chapter-break">RAD Industries</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101336/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_110.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101336/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_110-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_110" data-attachment-id="389098" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101336/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_110.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_110/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101336/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_110-1200x800.jpg"></a></figure><p>That something is a 2JZ-GTE that’s been swapped in by RAD Industries.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101341/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_111.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101341/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_111-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_111" data-attachment-id="389099" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101341/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_111.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_111/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101341/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_111-1200x800.jpg"></a></figure><p>While certainly not the first time a 2JZ motor has found its way into an older Supra (in fact, a couple of Eddie’s friends showed later, one of whom had also done exactly this), this has to be one of the coolest examples in existence.</p>
<p>I love that Eddie appreciated the original custom paintwork enough to go to the man himself to have the valve cover matched up. Santini’s attention to detail really shows and the quality of his work is as good as ever.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101345/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_112-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_112" data-attachment-id="389100" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101345/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_112.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_112/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101345/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_112-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101348/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_113-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_113" data-attachment-id="389101" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101348/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_113.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_113/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101348/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_113-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101351/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_114.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101351/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_114-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_114" data-attachment-id="389102" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101351/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_114.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_114/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101351/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_114-1200x800.jpg"></a></figure><p>With the fairly straightforward swap, the Supra — or should I say <em>Toyota Celica Supra</em> — has been really livened up by the new twin-turbo powerplant.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101354/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_115.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101354/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_115-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_115" data-attachment-id="389103" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101354/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_115.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_115/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101354/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_115-1200x800.jpg"></a></figure><p>It’s a conventional recipe that’s been applied to a car that is anything but.</p>
<span id="chapter-hello-80s" class="sh-post-chapter-break">Hello ’80s</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101357/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_116.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101357/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_116-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_116" data-attachment-id="389104" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101357/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_116.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_116/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101357/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_116-1200x800.jpg"></a></figure><p>Inside the car you’ll find that almost nothing has changed.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101400/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_117.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101400/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_117-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_117" data-attachment-id="389105" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101400/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_117.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_117/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101400/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_117-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101403/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_118-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_118" data-attachment-id="389106" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101403/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_118.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_118/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101403/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_118-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101407/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_119-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_119" data-attachment-id="389107" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101407/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_119.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_119/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101407/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_119-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101411/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_120.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101411/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_120-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_120" data-attachment-id="389108" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101411/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_120.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_120/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101411/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_120-1200x800.jpg"></a></figure><p>As with the exterior, the interior is surprisingly clean and intact. With the period-correct paintwork on the body there really is no sense updating anything. It’s really quite nice as it is, and certain details, like the stock gauges, really spoke to me for a reason I can’t quite place.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101414/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_121.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101414/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_121-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_121" data-attachment-id="389109" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101414/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_121.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_121/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101414/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_121-1200x800.jpg"></a></figure><p>I’m just stoked that this car ended up in the hands of someone who appreciated it for what it is.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101418/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_122.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101418/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_122-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_122" data-attachment-id="389110" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101418/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_122.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_122/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101418/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_122-1200x800.jpg"></a></figure><p>I really hope that this paint job stays exactly as it is forever.</p>
<span id="chapter-come-one-come-all" class="sh-post-chapter-break">Come One Come All</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101421/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_123.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101421/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_123-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_123" data-attachment-id="389111" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101421/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_123.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_123/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101421/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_123-1200x800.jpg"></a></figure><p>As I mentioned, the singular Celica Supra just wasn’t cutting it for Eddie; with the help of his wife a couple newer generations showed up. It all started when Eddie’s son started driving and the 16-year-old wasn’t so hot for the out-there look of the ’85.</p>
<ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101447/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_131-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_131" data-attachment-id="389119" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101447/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_131.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_131/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101447/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_131-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101450/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_132-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_132" data-attachment-id="389120" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101450/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_132.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_132/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101450/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_132-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101502/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_133-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_133" data-attachment-id="389121" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101502/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_133.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_133/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101502/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_133-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101507/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_134.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101507/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_134-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_134" data-attachment-id="389122" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101507/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_134.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_134/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101507/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_134-1200x800.jpg"></a></figure><p>Being the cool dad he is, Eddie picked up another Supra for his son, and like the MkII, his MkIII is a bit of a time machine. Although, the factory theme is much stronger here with the original motor retained along with the factory interior.</p>
<p>While not exciting from a modification perspective, it’s just nice to see that there are unmolested examples of these cars still around. If you’re wondering about the bra up front, it’s wearing this while some damage to the bumper is sorted by insurance companies.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101424/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_124-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_124" data-attachment-id="389112" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101424/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_124.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_124/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101424/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_124-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101427/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_125-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_125" data-attachment-id="389113" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101427/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_125.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_125/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101427/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_125-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101430/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_126-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_126" data-attachment-id="389114" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101430/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_126.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_126/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101430/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_126-1200x800.jpg"></figure><p>Of course, you might as well complete the set.</p>
<ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101434/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_127-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_127" data-attachment-id="389115" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101434/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_127.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_127/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101434/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_127-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101437/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_128-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_128" data-attachment-id="389116" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101437/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_128.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_128/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101437/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_128-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101440/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_129-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_129" data-attachment-id="389117" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101440/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_129.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_129/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101440/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_129-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101443/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_130.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101443/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_130-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_130" data-attachment-id="389118" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101443/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_130.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_130/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101443/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_130-1200x800.jpg"></a></figure><p>As you might have guessed, not much has been modified on this car either. But even more than the MkIII, the JZA80 Supra is a car that doesn’t need it. With lots of TRD goodies from the factory, and some which appear to have been added later on, Eddie’s is a really good example.</p>
<span id="chapter-bob-s-big-boy" class="sh-post-chapter-break">Bob’s Big Boy</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101624/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_200.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101624/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_200-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_200" data-attachment-id="389144" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101624/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_200.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_200/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101624/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_200-1200x800.jpg"></a></figure><p>Seeing the three cars together in the lot where Supra meets are normally held was one of those simple and yet so satisfying moments. Over 20 years of Toyota’s design work and engineering was on display.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101510/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_135.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101510/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_135-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_135" data-attachment-id="389123" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101510/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_135.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_135/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101510/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_135-1200x800.jpg"></a></figure><p>Being the meet spot for local enthusiasts, what happened next shouldn’t come as a surprise.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101513/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_136.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101513/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_136-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_136" data-attachment-id="389124" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101513/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_136.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_136/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101513/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_136-1200x800.jpg"></a></figure><p>Eddie had invited a few friends and their cars along to hang out and talk about the local scene.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101517/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_137.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101517/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_137-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_137" data-attachment-id="389125" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101517/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_137.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_137/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101517/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_137-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101520/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_138-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_138" data-attachment-id="389126" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101520/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_138.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_138/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101520/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_138-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101523/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_139-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_139" data-attachment-id="389127" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101523/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_139.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_139/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101523/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_139-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101526/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_140.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101526/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_140-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_140" data-attachment-id="389128" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101526/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_140.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_140/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101526/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_140-1200x800.jpg"></a></figure><p>A 1JZ-powered MkIII and an SR20-swapped S13, to be exact. If you stare long enough you’ll notice the hand-painted hood, which has nothing to do with Santini and was found as-is, reads ‘1JZ.’</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101529/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_141.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101529/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_141-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_141" data-attachment-id="389129" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101529/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_141.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_141/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101529/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_141-1200x800.jpg"></a></figure><p>The guys promised that if I give them some notice the next time I’m in town they could fill the expansive Bob’s Big Boy lot with Supras. It certainly sounds like something I’d be interested in, and it just goes to show how unifying car culture is.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101533/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_142.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101533/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_142-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_142" data-attachment-id="389130" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101533/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_142.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_142/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101533/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_142-1200x800.jpg"></a></figure><p>Regardless of what you have or have not done to your car there’s always common ground; it’s really about kicking back with friends and having a good time. And as serious as Eddie looks here, I promise he is having a good time.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101557/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_149.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101557/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_149-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_149" data-attachment-id="389137" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101557/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_149.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_149/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101557/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_149-1200x800.jpg"></a></figure><p>No matter where you go, you’ll always find something different. I just never thought I’d find something like this.</p>
<p><strong>Trevor Yale Ryan</strong><br>
Instagram: <a href="http://www.instagram.com/tyrphoto/" target="_blank">tyrphoto</a><br>
TYRphoto.com</p>
<aside class="exclude-from-p"><p><a href="http://www.speedhunters.com/tag/supra/" target="_blank">Supra related stories on Speedhunters</a></p>
</aside><span id="chapter-mini-meet" class="sh-post-chapter-break">Mini-Meet</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101616/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_153.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101616/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_153-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_153" data-attachment-id="389142" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101616/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_153.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_153/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101616/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_153-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101540/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_144-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_144" data-attachment-id="389132" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101540/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_144.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_144/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101540/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_144-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101543/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_145-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_145" data-attachment-id="389133" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101543/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_145.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_145/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101543/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_145-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101547/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_146-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_146" data-attachment-id="389134" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101547/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_146.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_146/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101547/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_146-1200x800.jpg"></div></li></ul><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101550/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_147-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_147" data-attachment-id="389135" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101550/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_147.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_147/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101550/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_147-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101536/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_143-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_143" data-attachment-id="389131" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101536/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_143.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_143/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101536/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_143-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101554/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_148-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_148" data-attachment-id="389136" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101554/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_148.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_148/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101554/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_148-1200x800.jpg"></div></li></ul><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101604/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_150-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_150" data-attachment-id="389139" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101604/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_150.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_150/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101604/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_150-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101612/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_152-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_152" data-attachment-id="389141" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101612/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_152.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_152/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101612/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_152-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101608/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_151-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_151" data-attachment-id="389140" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101608/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_151.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_151/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101608/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_151-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101620/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_154.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101620/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_154-680x453.jpg" alt="2018-SH-Eddies-Supras-Santini-Trevor-Ryan_154" data-attachment-id="389143" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101620/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_154.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/2018-sh-eddies-supras-santini-trevor-ryan_154/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/26101620/2018-SH-Eddies-Supras-Santini-Trevor-Ryan_154-1200x800.jpg"></a></figure></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[12821,1151,683,2108],"excerpt":"150","exclude":[389085]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2018/07/the-japanese-invasion-at-the-petersen/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/25134533/2018-SH-Petersen-Japanese-Gallery-Trevor-Ryan_001-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2018/07/the-japanese-invasion-at-the-petersen/">
		
<div class="card-label category-speedhunterscrew">
		<span class="potent">SPECIAL </span><span class="light">FEATURE</span></div>
		<h2>The Japanese Invasion At The&nbsp;Petersen</h2>
		<span class="date">July 27, 2018</span>
		<span class="divider">/</span>
		<span class="comments">6 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2018/07/a-prelude-to-the-petersen-the-greatest-automotive-museum-on-earth/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/25134205/2018-SH-Petersen-General-Gallery-Trevor-Ryan_002-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2018/07/a-prelude-to-the-petersen-the-greatest-automotive-museum-on-earth/">
		
<div class="card-label category-speedhunterscrew">
		<span class="potent">SPECIAL </span><span class="light">FEATURE</span></div>
		<h2>A Prelude To The Petersen, The Greatest Automotive Museum on&nbsp;Earth</h2>
		<span class="date">July 26, 2018</span>
		<span class="divider">/</span>
		<span class="comments">13 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2018/07/saving-77-toyota-celica-gt/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/07/05110226/2018-SH-Saving-A-Celica-Trevor-Ryan_001-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2018/07/saving-77-toyota-celica-gt/">
		
<div class="card-label tag-car-spotlight">
		<span class="light">CAR </span><span class="potent">SPOTLIGHT</span></div>
		<h2>Saving A &#8217;77 Toyota Celica&nbsp;GT</h2>
		<span class="date">July 15, 2018</span>
		<span class="divider">/</span>
		<span class="comments">18 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title" id="comments">Comments</h4>
		<div class="de_comments">
			<div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
     data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
     data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
     data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
     data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
     data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
     data-post_id="389085"
     data-user_id="0"
     data-is_need_logged="0"
     data-lang="en"
     data-decom_comment_single_translate=" comment"
     data-decom_comment_twice_translate=" comments"
     data-decom_comment_plural_translate=" comments"
     data-multiple_vote="1"
     data-text_lang_comment_deleted='Comment deleted'
     data-text_lang_edited="Edited at"
     data-text_lang_delete="Delete"
     data-text_lang_not_zero="Field is not null"
     data-text_lang_required="This field is required."
     data-text_lang_checked="Mark one of the points"
     data-text_lang_completed="Operation completed"
     data-text_lang_items_deleted="The items have been deleted"
     data-text_lang_close="Close"
     data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform decomments-avatar-right" data-site-url="http://www.speedhunters.com">

	<div class="decomments-social-login-widget">
		 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<div class="oneall_social_login">
 <div class="oneall_social_login_label" style="margin-bottom: 3px;"><label>Connect with:</label></div>
 <div class="oneall_social_login_providers" id="oneall_social_login_providers_3207932"></div>
 <script type="text/javascript">
  var _oneall = _oneall || [];
  _oneall.push(['social_login', 'set_providers', ['facebook','google','reddit','twitter']]);
  _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&amp;': '?') + "oa_social_login_source=comments"))]);
  _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
  _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_3207932']);
 </script>
</div>	</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" action="http://www.speedhunters.com/wp-login.php" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="log" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="pwd" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input id="submit-form" type="hidden" name="submit" />
				<input type="hidden" name="redirect_to" value="" />
				<input type="hidden" id="security" name="security" value="507a29d867" /><input type="hidden" name="_wp_http_referer" value="/2018/07/straight-from-the-80s-the-santini-supra/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
				<div class="comment-form" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>
		<div class="decomments-head">

			<h3><i><span class="decomments-comments-number decomments-block">2</span><span class="decomments-comment-title"> comments</span></i></h3>			<form class=" decom_comments_sort decomments-comment-sort" action="#comments" method="post" >
				<label>Sort:</label>
				<dl class="de-select de-select-filter">
					<dt>by Oldest</dt>
					<dd name="decom_comments_sort" class="decomments-select">
						<a onclick="decom.sortComments(this)"  href="#" data-sort="rate">
							<i class="decomments-icon-thumb-down"></i> by Best						</a>
						<a onclick="decom.sortComments(this)"  href="#" data-sort="newer">
							<i class="decomments-icon-thumb-down"></i> by Newest						</a>
						<a onclick="decom.sortComments(this)" class="current" href="#" data-sort="older" selected='selected'>
							<i class="decomments-icon-thumb-down"></i> by Oldest						</a>
					</dd>
				</dl>
			</form>
		</div>
		<div class="decomments-comment-list decomments-avatar-right" style="min-height: 250px;">
			<div class="loader-ball-scale lbs-remove">
				<div></div>
				<div></div>
				<div></div>
			</div>
			<div class="comment byuser comment-author-tui-t even thread-even depth-1 decomments-comment-block" id="comment-1592348" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt="" src="https://lh5.googleusercontent.com/-_lt4wVBmwUM/AAAAAAAAAAI/AAAAAAAAP08/GdNKJ7C_caw/photo.jpg" class="avatar avatar-social-login avatar-40 photo" height="40" width="40" /></span>
                     	<figcaption data-cui="401" data-pai="883""><a href="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/#comment-1592348" class="decomments-number"><span>1</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/#comment-1592348" class="decomments-date-link">
				
			<time datetime="6:15 pm July 28, 2018">6:15 pm<i>July 28, 2018</i></time>			</a>
			<span class="decomments-autor-name">Tui T</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1592348"><p>Paint Job is sick !</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1592348"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div><div class="comment odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-1592349" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/b38601a9eea94bf3587042b55edb288a?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="883""><a href="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/#comment-1592349" class="decomments-number"><span>2</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/#comment-1592349" class="decomments-date-link">
				
			<time datetime="6:47 pm July 28, 2018">6:47 pm<i>July 28, 2018</i></time>			</a>
			<span class="decomments-autor-name">sixy</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1592349"><p>...i need a new change of pants.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1592349"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div>		</div><!-- .commentlist -->
		</div>
</div>
		</div>
	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-8 small-block-grid-4 text-center"/><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="http://www.fueloffroad.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041516/fuel.png"/></a></li><li><a href="http://www.kleers.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095015/kleers.png"/></a></li><li><a href="http://www.kwsuspensions.de/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/08053600/KW-Logo.png"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.rotiform.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041517/rotiform.png"/></a></li><li><a href="http://www.takataracingstore.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2018/07/straight-from-the-80s-the-santini-supra/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers & drivers with a shared passion for uncovering the world's most exciting car culture stories. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team Speedhunters</h4>			<div class="textwidget">Editor in Chief:
<em>Paddy McGrath</em> <br />

Managing Editor:
<em>Brad Lord</em> <br />

Editor at Large:
<em>Dino Dalle Carbonare</em><br />

Commercial Director: 
<em>Ben Chandler</em><br />

Community Manager: 
<em>Mark Riccioni</em><br />

Technical Editor: 
<em>Ryan Stewart</em><br />

Senior Contributors: 
<em>Jordan Butters & Larry Chen</em><br />

Contributors: 
<em>Justin Banner, Keiron Berndt, Ron Celestine, Matthew Everingham, Blake Jones, Bryn Musselwhite, Richard Opie, Alok Paleri, Trevor Yale Ryan, Dave Thomas, Louis Yio</em><br />



</div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	<li><a href="http://formulad.com"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/03/26132711/FD-2018-Logo.png" /></a></li>
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.kleerfreight.com/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/23044303/kleerfreight-logo.png" /></a></li>
<li><a href="http://www.h-c.co.jp/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/11043940/hashimoto.png" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://ghostgames.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ghost.jpg" /></a></li>
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="https://www.facebook.com/edward.sandstrom.racing/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/edward.jpg" /></a></li>
	<li><a href="http://motorheadmagazine.jp/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/motorhead.jpg" /></a></li>
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
	<li><a href="http://www.mcnsport.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/mcn.jpg" /></a></li>
	<li><a href="http://www.ponydrift.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ponydrift.jpg" /></a></li>
<li><a href="https://www.facebook.com/JamesDeaneDrifting"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/20005931/JamesDeaneDrifting.jpg" /></a></li>
<li><a href="https://www.facebook.com/piotrwiecekdrift"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/20005934/piotrwiecekdrift.jpg" /></a></li>
<li><a href="https://www.facebook.com/worthousedriftteam"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/20010806/worthouse.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2018 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/1/legal-notices">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><link rel='stylesheet' id='dashicons-css'  href='http://www.speedhunters.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"http:\/\/www.speedhunters.com\/wp-admin\/admin-ajax.php","redirecturl":"\/2018\/07\/straight-from-the-80s-the-santini-supra\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.speedhunters.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 1.416 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2018-07-28 18:47:22 -->

<!-- super cache -->