<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    A MOD Meet At Mitsubishi&#039;s R&amp;D Lab - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Facebook App Code -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '252792185178857',
      cookie     : true,
      xfbml      : true,
      version    : 'v2.8'
    });
    FB.AppEvents.logPageView();   
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- End Facebook App Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A MOD Meet At Mitsubishi&#039;s R&amp;D Lab - Speedhunters" />
<meta property="og:description" content="MOD 2017, held at Mitsubishi Motors R&amp;D of America’s laboratory in Cypress, California on Saturday was 100 years in the making, and fans of the Japanese automaker came out in numbers to celebrate the milestone. Given it was way back in 2011 that Speedhunters last took a look at MOD (Mitsubishi Owners Day), I decided it would be a good idea to &hellip;" />
<meta property="og:url" content="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="California" />
<meta property="article:tag" content="Evo" />
<meta property="article:tag" content="evolution" />
<meta property="article:tag" content="Lancer" />
<meta property="article:tag" content="Mitsubishi" />
<meta property="article:tag" content="Mitsubishi Owners Day" />
<meta property="article:tag" content="MOD" />
<meta property="article:tag" content="MOD 17" />
<meta property="article:section" content="Content" />
<meta property="article:section" content="Event Coverage" />
<meta property="article:published_time" content="2017-07-11T18:05:57+00:00" />
<meta property="article:modified_time" content="2017-07-11T18:09:35+00:00" />
<meta property="og:updated_time" content="2017-07-11T18:09:35+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165423/Speedhunters_MOD_JB-60N.jpg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; A MOD Meet At Mitsubishi&#8217;s R&amp;D&nbsp;Lab Comments Feed" href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/feed/" />
<link rel='stylesheet' id='decomments-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background:  !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color: !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color: !important; } .decomments-gif:after{ border-left-color: !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background: !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke: !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill: !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke: !important; }
			 </style>
			<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=332937' />

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://speedhunters.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-332937 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Tealium -->
<script type="text/javascript">
var utag_data = {
}
</script>

<!-- Loading script asynchronously -->
<script type="text/javascript">
    (function(a,b,c,d){
    a='//tags.tiqcdn.com/utag/ea/speedhunterscom/prod/utag.js';
    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
    })();
</script>
<!-- End Tealium -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>
        							<dd><h4 data-section-title class="pointable"><a href"#" class="more-button">More&hellip;</a></h4></dd>
        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>
                                    <i data-section-title class="fi-arrow-down pointable more-button"></i>
                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                A MOD Meet At Mitsubishi&#8217;s R&#038;D&nbsp;Lab            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-332937" class="post-332937 post type-post status-publish format-standard has-post-thumbnail hentry category-content category-eventcoverage tag-california tag-evo tag-evolution tag-lancer tag-mitsubishi tag-mitsubishi-owners-day tag-mod-tag tag-mod-17">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			<div class="story-meta large-12 columns">
  <div class="large-10 large-centered columns article-meta">
    <h1 class="entry-title">A MOD Meet At Mitsubishi&#8217;s R&#038;D&nbsp;Lab</h1>
    <hr />
    
<div class="story-label category-eventcoverage">
	<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
    <dl>
                            <dt>By</dt>
                    <dd><a href="http://www.speedhunters.com/author/jbanner/" title="Posts by Justin Banner" class="url fn" rel="author">Justin Banner</a></dd>
                    </dl>
          <hr />

          <span class="story-date">11th July 2017</span>
          <span class="story-comments">
            <i class="fi-comments"></i>
            <a class="comments-link" href="#comments">3 Comments</a>
          </span>
        </div>
      </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165423/Speedhunters_MOD_JB-60N.jpg" data-attachment-id="333269" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165423/Speedhunters_MOD_JB-60N-1200x800.jpg" alt="A MOD Meet At Mitsubishi&#8217;s R&#038;D&nbsp;Lab">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><span id="chapter-diamonds-in-the-stars-with-motors" class="sh-post-chapter-break">Diamonds In The Stars With Motors</span>
<p>MOD 2017, held at Mitsubishi Motors R&amp;D of America’s laboratory in Cypress, California on Saturday was 100 years in the making, and fans of the Japanese automaker came out in numbers to celebrate the milestone.</p>
<p>Given it was way back in 2011 that Speedhunters last took a look at MOD (Mitsubishi Owners Day), I decided it would be a good idea to brave the summer heat and check it out. And I’m glad that I did.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/10014408/Speedhunters_MOD_JB-80-680x453.jpg" alt="Speedhunters_MOD_JB-80" data-attachment-id="333016" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/10014408/Speedhunters_MOD_JB-80.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-80/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/10014408/Speedhunters_MOD_JB-80-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164841/Speedhunters_MOD_JB-30N-680x453.jpg" alt="Speedhunters_MOD_JB-30N" data-attachment-id="333246" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164841/Speedhunters_MOD_JB-30N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-30n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164841/Speedhunters_MOD_JB-30N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165045/Speedhunters_MOD_JB-41N-680x453.jpg" alt="Speedhunters_MOD_JB-41N" data-attachment-id="333254" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165045/Speedhunters_MOD_JB-41N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-41n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165045/Speedhunters_MOD_JB-41N-1200x800.jpg"></div></li></ul><p>Although it was a centennial celebration, the history of Mitsubishi is far greater when you look beyond the automotive side. Mitsubishi Group of Companies was founded in 1870 by Yararo Iwasaki and started out as a shipping firm. The logo and name stands for <em>Three Water Caltrop</em>, but the word <em>hishi </em>(which gets changed to <em>bishi</em> when spoken with <em>mitsu</em>) also means diamond. That’s why you see three diamonds over three water chestnuts.</p>
<p>In 1917, the company built the first ever series-production automobile known as the Model A, which was based on the Fiat Tipo 3. In 1934, after discontinuing the rather expensive car, the shipbuilding and aircraft companies merged to form Mitsubishi Heavy Industries and three years later they built the PX33. It could be called the predecessor to the VR-4, GSX, and Evolution models we see today as it was the first Japanese-built passenger car with full-time four-wheel drive.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165214/Speedhunters_MOD_JB-47N-680x453.jpg" alt="Speedhunters_MOD_JB-47N" data-attachment-id="333260" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165214/Speedhunters_MOD_JB-47N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-47n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165214/Speedhunters_MOD_JB-47N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164428/Speedhunters_MOD_JB-6N-680x453.jpg" alt="Speedhunters_MOD_JB-6N" data-attachment-id="333230" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164428/Speedhunters_MOD_JB-6N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-6n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164428/Speedhunters_MOD_JB-6N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164756/Speedhunters_MOD_JB-27M-680x453.jpg" alt="Speedhunters_MOD_JB-27M" data-attachment-id="333243" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164756/Speedhunters_MOD_JB-27M.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-27m/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164756/Speedhunters_MOD_JB-27M-1200x800.jpg"></div></li></ul><p>For many of us that grew up in the 1980s and early 1990s in the USA, we saw Mitsubishi as part of the Diamond Star Motor group. ‘Diamond’ fans lusted over the Mitsubishi Eclipse, 3000GT, and the Mighty Max (if you were into small pickups); the ‘Star’ part was the Chrysler side, so we wanted the Eagle Talon, the Dodge Stealth, and the Ram 50. The reality was, they were the same vehicles.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165305/Speedhunters_MOD_JB-50N-680x453.jpg" alt="Speedhunters_MOD_JB-50N" data-attachment-id="333263" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165305/Speedhunters_MOD_JB-50N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-50n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165305/Speedhunters_MOD_JB-50N-1200x800.jpg"></figure><p>However, even though I know that, the Talon TSI AWD is still the one from that group that I want the most. I liked its body shape more so than the Eclipse, but either version of the AWD cars are still very potent vehicles to own.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165331/Speedhunters_MOD_JB-52N-680x453.jpg" alt="Speedhunters_MOD_JB-52N" data-attachment-id="333265" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165331/Speedhunters_MOD_JB-52N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-52n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165331/Speedhunters_MOD_JB-52N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165318/Speedhunters_MOD_JB-51N-680x453.jpg" alt="Speedhunters_MOD_JB-51N" data-attachment-id="333264" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165318/Speedhunters_MOD_JB-51N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-51n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165318/Speedhunters_MOD_JB-51N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165247/Speedhunters_MOD_JB-49N-680x453.jpg" alt="Speedhunters_MOD_JB-49N" data-attachment-id="333262" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165247/Speedhunters_MOD_JB-49N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-49n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165247/Speedhunters_MOD_JB-49N-1200x800.jpg"></div></li></ul><p>The Eclipse/Talon were also the second largest gathering of vehicles at MOD 2017. It wasn’t hard to understand, though, as these cars aren’t exactly rare or expensive. Of course, if there is going to be an Eclipse showing, you know that the ‘Paul Walker Tribute’ car is going to be here. Even when the <em>Fast and the Furious</em> first came out, the Eclipse was already an ageing car, but there’s just something about that body that still looks good today as it did when it first debuted.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164334/Speedhunters_MOD_JB-1N-680x453.jpg" alt="Speedhunters_MOD_JB-1N" data-attachment-id="333226" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164334/Speedhunters_MOD_JB-1N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-1n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164334/Speedhunters_MOD_JB-1N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164344/Speedhunters_MOD_JB-2N-680x453.jpg" alt="Speedhunters_MOD_JB-2N" data-attachment-id="333227" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164344/Speedhunters_MOD_JB-2N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-2n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164344/Speedhunters_MOD_JB-2N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164357/Speedhunters_MOD_JB-3N-680x453.jpg" alt="Speedhunters_MOD_JB-3N" data-attachment-id="333228" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164357/Speedhunters_MOD_JB-3N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-3n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164357/Speedhunters_MOD_JB-3N-1200x800.jpg"></div></li></ul><p>Those of you that have known me or have read my stuff in the past, you know I’m a, well, I’m a truck and SUV kind of guy. So, when I headed over to the Montero/Pajero section, I was ecstatic to see the Pajero Evolution on display. We’re not familiar with it here in the US, which is a surprise considering we are a truck/SUV nation. This is a Dakar homologation special and it’s a <em>big</em> departure from the standard Pajero. It came out in 1997 as a response to the T3 class requirements of the Paris-Dakar Rally and features a 3.5-liter, 24-valve MIVEC DOHC V6 with a variable intake system (long runner plenum for low RPM, short runner plenum for higher RPM). It also featured a multi-link, independent rear suspension over the solid axle of the normal Pajero/Montero.</p>
<span id="chapter-classics" class="sh-post-chapter-break">Classics</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164443/Speedhunters_MOD_JB-7N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164443/Speedhunters_MOD_JB-7N-680x453.jpg" alt="Speedhunters_MOD_JB-7N" data-attachment-id="333231" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164443/Speedhunters_MOD_JB-7N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-7n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164443/Speedhunters_MOD_JB-7N-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164522/Speedhunters_MOD_JB-10N-680x453.jpg" alt="Speedhunters_MOD_JB-10N" data-attachment-id="333234" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164522/Speedhunters_MOD_JB-10N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-10n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164522/Speedhunters_MOD_JB-10N-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164545/Speedhunters_MOD_JB-11N-680x453.jpg" alt="Speedhunters_MOD_JB-11N" data-attachment-id="333235" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164545/Speedhunters_MOD_JB-11N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-11n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164545/Speedhunters_MOD_JB-11N-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164453/Speedhunters_MOD_JB-8N-680x453.jpg" alt="Speedhunters_MOD_JB-8N" data-attachment-id="333232" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164453/Speedhunters_MOD_JB-8N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-8n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164453/Speedhunters_MOD_JB-8N-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164508/Speedhunters_MOD_JB-9N-680x453.jpg" alt="Speedhunters_MOD_JB-9N" data-attachment-id="333233" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164508/Speedhunters_MOD_JB-9N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-9n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164508/Speedhunters_MOD_JB-9N-1200x800.jpg"></figure><p>Right next to them were some classic Lancers. The first was this Lancer 1800 GSR with a 4G62B engine, a 1.8-liter SOHC four-cylinder with intercooled turbocharger. This particular car sported a set of original Yokohama Advan A3A wheels along with a few other interesting parts.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164629/Speedhunters_MOD_JB-16N-680x453.jpg" alt="Speedhunters_MOD_JB-16N" data-attachment-id="333238" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164629/Speedhunters_MOD_JB-16N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-16n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164629/Speedhunters_MOD_JB-16N-1200x800.jpg"></figure><p>Right beside it, however, was a very impressive looking Mitsubishi Lancer A70, also known as the Dodge Colt here in the US.  Dennis, the owner, also changed the front bumper to Japanese Lancer style, which was shorter than the US bumper. However, that necessitated shortening the plastic portion that goes into the front fenders. In Japan, these cars didn’t come with the low-mounted signal light we see here.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164640/Speedhunters_MOD_JB-18N-680x453.jpg" alt="Speedhunters_MOD_JB-18N" data-attachment-id="333239" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164640/Speedhunters_MOD_JB-18N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-18n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164640/Speedhunters_MOD_JB-18N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164702/Speedhunters_MOD_JB-19N-680x453.jpg" alt="Speedhunters_MOD_JB-19N" data-attachment-id="333240" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164702/Speedhunters_MOD_JB-19N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-19n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164702/Speedhunters_MOD_JB-19N-1200x800.jpg"></div></li></ul><p>These cars came with the 4G32, a 1.6-liter SOHC engine with a single Solex carburetor, though GSR versions of the engines saw dual Solex two-barrel, downdraft carburetors fitted. While the single Solex is working for now, the plans are to change it out for a set of Weber side-draft carburetors, but that will require the relocation of the brake booster and master cylinder to the trunk. Yes, you read that correctly, the description of the setup is very ingenious. A single master cylinder attaches where the old booster and master cylinder were once at, that then sends pressure to a slave cylinder that’s attached to the relocated brake booster. The downside is that there is a lack of feedback – bad for a race car, but not bad enough for a street car.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164736/Speedhunters_MOD_JB-25N-680x453.jpg" alt="Speedhunters_MOD_JB-25N" data-attachment-id="333242" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164736/Speedhunters_MOD_JB-25N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-25n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164736/Speedhunters_MOD_JB-25N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164611/Speedhunters_MOD_JB-15N-680x453.jpg" alt="Speedhunters_MOD_JB-15N" data-attachment-id="333237" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164611/Speedhunters_MOD_JB-15N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-15n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164611/Speedhunters_MOD_JB-15N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164723/Speedhunters_MOD_JB-24N-680x453.jpg" alt="Speedhunters_MOD_JB-24N" data-attachment-id="333241" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164723/Speedhunters_MOD_JB-24N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-24n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164723/Speedhunters_MOD_JB-24N-1200x800.jpg"></div></li></ul><p>There are some neat period touches too, like an original set of SSR Mk3 wheels and a state-of-the-art cassette player.</p>
<span id="chapter-vendor-vendor-give-me-the-news" class="sh-post-chapter-break">Vendor, Vendor, Give Me The News</span>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164935/Speedhunters_MOD_JB-35N-680x453.jpg" alt="Speedhunters_MOD_JB-35N" data-attachment-id="333249" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164935/Speedhunters_MOD_JB-35N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-35n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164935/Speedhunters_MOD_JB-35N-1200x800.jpg"></figure><p>One of the companies who’s been to every single MOD has been Road Race Engineering. They are, quite simply, one of the names you just associate with 4G-engines and the stupid amounts of power they can make. This year was no exception and, once again, they brought out their dyno to see which Mitsubishi had the most on this very hot July day.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164952/Speedhunters_MOD_JB-36N-680x453.jpg" alt="Speedhunters_MOD_JB-36N" data-attachment-id="333250" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164952/Speedhunters_MOD_JB-36N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-36n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164952/Speedhunters_MOD_JB-36N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164902/Speedhunters_MOD_JB-33N-680x453.jpg" alt="Speedhunters_MOD_JB-33N" data-attachment-id="333247" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164902/Speedhunters_MOD_JB-33N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-33n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164902/Speedhunters_MOD_JB-33N-1200x800.jpg"></div></li></ul><p>On display were Dr. Alex Radu’s Evo VI and its Varis bodykit, and also Roy Narvaez’s Hulk Evo VIII, which had the unfortunate fate last year to be on display in pieces after his barrel roll at Pikes Peak. For 2017 however, Roy reached the top before the weather hit to finish 12th out of 22 in his class.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165127/Speedhunters_MOD_JB-44N-680x453.jpg" alt="Speedhunters_MOD_JB-44N" data-attachment-id="333257" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165127/Speedhunters_MOD_JB-44N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-44n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165127/Speedhunters_MOD_JB-44N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165139/Speedhunters_MOD_JB-45N-680x453.jpg" alt="Speedhunters_MOD_JB-45N" data-attachment-id="333258" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165139/Speedhunters_MOD_JB-45N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-45n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165139/Speedhunters_MOD_JB-45N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165111/Speedhunters_MOD_JB-43N-680x453.jpg" alt="Speedhunters_MOD_JB-43N" data-attachment-id="333256" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165111/Speedhunters_MOD_JB-43N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-43n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165111/Speedhunters_MOD_JB-43N-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165058/Speedhunters_MOD_JB-42N-680x453.jpg" alt="Speedhunters_MOD_JB-42N" data-attachment-id="333255" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165058/Speedhunters_MOD_JB-42N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-42n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165058/Speedhunters_MOD_JB-42N-1200x800.jpg"></figure><p>Over at CSF Radiators was this impressive looking Evo IX owned by Sergio Miranda with a custom made, titanium Sheepey Built turbo and wastegate dump that exits out of the hood. The list of parts on it might make it worthy of a future look.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165446/Speedhunters_MOD_JB-61N-680x453.jpg" alt="Speedhunters_MOD_JB-61N" data-attachment-id="333270" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165446/Speedhunters_MOD_JB-61N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-61n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165446/Speedhunters_MOD_JB-61N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165546/Speedhunters_MOD_JB-66N-680x453.jpg" alt="Speedhunters_MOD_JB-66N" data-attachment-id="333274" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165546/Speedhunters_MOD_JB-66N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-66n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165546/Speedhunters_MOD_JB-66N-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165459/Speedhunters_MOD_JB-62N-680x453.jpg" alt="Speedhunters_MOD_JB-62N" data-attachment-id="333271" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165459/Speedhunters_MOD_JB-62N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-62n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165459/Speedhunters_MOD_JB-62N-1200x800.jpg"></div></li></ul><p>Other than the Marlboro schemed cars that have started to pop-up recently, there is another auto trend I don’t quite get: the <em>itasha</em> car. The Evo X wasn’t as extreme as I have seen them and it was going for a Good Smile Racing team replica, but I still don’t really get it. Though, we did have the American equivalent here with this yellow Lancer.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165817/Speedhunters_MOD_JB-77N-680x453.jpg" alt="Speedhunters_MOD_JB-77N" data-attachment-id="333284" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165817/Speedhunters_MOD_JB-77N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-77n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165817/Speedhunters_MOD_JB-77N-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165345/Speedhunters_MOD_JB-55N-680x453.jpg" alt="Speedhunters_MOD_JB-55N" data-attachment-id="333266" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165345/Speedhunters_MOD_JB-55N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-55n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165345/Speedhunters_MOD_JB-55N-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165156/Speedhunters_MOD_JB-46N-680x453.jpg" alt="Speedhunters_MOD_JB-46N" data-attachment-id="333259" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165156/Speedhunters_MOD_JB-46N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-46n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165156/Speedhunters_MOD_JB-46N-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165844/Speedhunters_MOD_JB-79N-680x453.jpg" alt="Speedhunters_MOD_JB-79N" data-attachment-id="333286" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165844/Speedhunters_MOD_JB-79N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-79n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165844/Speedhunters_MOD_JB-79N-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165710/Speedhunters_MOD_JB-72N-680x453.jpg" alt="Speedhunters_MOD_JB-72N" data-attachment-id="333279" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165710/Speedhunters_MOD_JB-72N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-72n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165710/Speedhunters_MOD_JB-72N-1200x800.jpg"></figure><p>With that all said, there is one last thing that must be pointed out about Mitsubishi fans. Despite the challenging times with their favorite brand and the brand getting away from the thing that brought them to it in the first place, they are still a diehard and loyal base.</p>
<p>So much so, that there will be a second MOD on August 19, 2017 that will take place on the east coast at Citizens Bank Park in Philadelphia, Pennsylvania. If you haven’t been able to attend MOD in the past because you were on the opposite coast, this will be your chance to enjoy Mitsubishi with your fellow owners. Even as a non-Mitsubishi owner, you’ll enjoy it because at the end of the day we all enjoy vehicles.</p>
<p>What’s your favorite Mitsubishi vehicle or memory? Tell us in the comments, or even better – show us.</p>
<p>Words and Photos by<strong> Justin Banner</strong><br>
Instagram: <a href="https://www.instagram.com/jb27tt/" target="_blank">jb27tt</a><br>
Facebook: <a href="https://www.facebook.com/racerbanner/" target="_blank">racerbanner</a><br>
Twitter: <a href="https://www.twitter.com/racerbanner" target="_blank">RacerBanner</a></p>
<aside class="exclude-from-p"><p><a href="http://www.speedhunters.com/tag/mitsubishi" target="_blank">More Mitsubishi related stories on Speedhunters</a></p>
</aside><span id="chapter-bonus-images" class="sh-post-chapter-break">Cutting Room Floor</span>
<p><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165004/Speedhunters_MOD_JB-37N-680x453.jpg" alt="Speedhunters_MOD_JB-37N" data-attachment-id="333251" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165004/Speedhunters_MOD_JB-37N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-37n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165004/Speedhunters_MOD_JB-37N-1200x800.jpg"><br><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164812/Speedhunters_MOD_JB-28N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164812/Speedhunters_MOD_JB-28N-680x453.jpg" alt="Speedhunters_MOD_JB-28N" data-attachment-id="333244" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164812/Speedhunters_MOD_JB-28N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-28n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164812/Speedhunters_MOD_JB-28N-1200x800.jpg"></a></p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164825/Speedhunters_MOD_JB-29N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164825/Speedhunters_MOD_JB-29N-680x453.jpg" alt="Speedhunters_MOD_JB-29N" data-attachment-id="333245" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164825/Speedhunters_MOD_JB-29N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-29n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164825/Speedhunters_MOD_JB-29N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165014/Speedhunters_MOD_JB-39N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165014/Speedhunters_MOD_JB-39N-680x453.jpg" alt="Speedhunters_MOD_JB-39N" data-attachment-id="333252" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165014/Speedhunters_MOD_JB-39N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-39n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165014/Speedhunters_MOD_JB-39N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165231/Speedhunters_MOD_JB-48N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165231/Speedhunters_MOD_JB-48N-680x453.jpg" alt="Speedhunters_MOD_JB-48N" data-attachment-id="333261" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165231/Speedhunters_MOD_JB-48N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-48n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165231/Speedhunters_MOD_JB-48N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165356/Speedhunters_MOD_JB-58N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165356/Speedhunters_MOD_JB-58N-680x453.jpg" alt="Speedhunters_MOD_JB-58N" data-attachment-id="333267" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165356/Speedhunters_MOD_JB-58N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-58n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165356/Speedhunters_MOD_JB-58N-1200x800.jpg"></a></figure><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164412/Speedhunters_MOD_JB-5N-680x453.jpg" alt="Speedhunters_MOD_JB-5N" data-attachment-id="333229" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164412/Speedhunters_MOD_JB-5N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-5n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164412/Speedhunters_MOD_JB-5N-1200x800.jpg"></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165411/Speedhunters_MOD_JB-59N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165411/Speedhunters_MOD_JB-59N-680x453.jpg" alt="Speedhunters_MOD_JB-59N" data-attachment-id="333268" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165411/Speedhunters_MOD_JB-59N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-59n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165411/Speedhunters_MOD_JB-59N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165512/Speedhunters_MOD_JB-64N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165512/Speedhunters_MOD_JB-64N-680x453.jpg" alt="Speedhunters_MOD_JB-64N" data-attachment-id="333272" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165512/Speedhunters_MOD_JB-64N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-64n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165512/Speedhunters_MOD_JB-64N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165527/Speedhunters_MOD_JB-65N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165527/Speedhunters_MOD_JB-65N-680x453.jpg" alt="Speedhunters_MOD_JB-65N" data-attachment-id="333273" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165527/Speedhunters_MOD_JB-65N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-65n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165527/Speedhunters_MOD_JB-65N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165605/Speedhunters_MOD_JB-68N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165605/Speedhunters_MOD_JB-68N-680x453.jpg" alt="Speedhunters_MOD_JB-68N" data-attachment-id="333275" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165605/Speedhunters_MOD_JB-68N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-68n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165605/Speedhunters_MOD_JB-68N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165620/Speedhunters_MOD_JB-69N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165620/Speedhunters_MOD_JB-69N-680x453.jpg" alt="Speedhunters_MOD_JB-69N" data-attachment-id="333276" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165620/Speedhunters_MOD_JB-69N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-69n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165620/Speedhunters_MOD_JB-69N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165633/Speedhunters_MOD_JB-70N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165633/Speedhunters_MOD_JB-70N-680x453.jpg" alt="Speedhunters_MOD_JB-70N" data-attachment-id="333277" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165633/Speedhunters_MOD_JB-70N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-70n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165633/Speedhunters_MOD_JB-70N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165647/Speedhunters_MOD_JB-71N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165647/Speedhunters_MOD_JB-71N-680x453.jpg" alt="Speedhunters_MOD_JB-71N" data-attachment-id="333278" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165647/Speedhunters_MOD_JB-71N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-71n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165647/Speedhunters_MOD_JB-71N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165720/Speedhunters_MOD_JB-73N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165720/Speedhunters_MOD_JB-73N-680x453.jpg" alt="Speedhunters_MOD_JB-73N" data-attachment-id="333280" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165720/Speedhunters_MOD_JB-73N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-73n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165720/Speedhunters_MOD_JB-73N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165733/Speedhunters_MOD_JB-74N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165733/Speedhunters_MOD_JB-74N-680x453.jpg" alt="Speedhunters_MOD_JB-74N" data-attachment-id="333281" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165733/Speedhunters_MOD_JB-74N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-74n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165733/Speedhunters_MOD_JB-74N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165743/Speedhunters_MOD_JB-75N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165743/Speedhunters_MOD_JB-75N-680x453.jpg" alt="Speedhunters_MOD_JB-75N" data-attachment-id="333282" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165743/Speedhunters_MOD_JB-75N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-75n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165743/Speedhunters_MOD_JB-75N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165804/Speedhunters_MOD_JB-76N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165804/Speedhunters_MOD_JB-76N-680x453.jpg" alt="Speedhunters_MOD_JB-76N" data-attachment-id="333283" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165804/Speedhunters_MOD_JB-76N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-76n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165804/Speedhunters_MOD_JB-76N-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165828/Speedhunters_MOD_JB-78N.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165828/Speedhunters_MOD_JB-78N-680x453.jpg" alt="Speedhunters_MOD_JB-78N" data-attachment-id="333285" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165828/Speedhunters_MOD_JB-78N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-78n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165828/Speedhunters_MOD_JB-78N-1200x800.jpg"></a></figure><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164922/Speedhunters_MOD_JB-34N-680x453.jpg" alt="Speedhunters_MOD_JB-34N" data-attachment-id="333248" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164922/Speedhunters_MOD_JB-34N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-34n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11164922/Speedhunters_MOD_JB-34N-1200x800.jpg"></figure><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165032/Speedhunters_MOD_JB-40N-680x453.jpg" alt="Speedhunters_MOD_JB-40N" data-attachment-id="333253" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165032/Speedhunters_MOD_JB-40N.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/speedhunters_mod_jb-40n/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/11165032/Speedhunters_MOD_JB-40N-1200x800.jpg"></figure></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[4877,1199,2019,599],"excerpt":"150","exclude":[332937]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2017/07/wekfest-san-jose-going-big-in-the-bay/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/07/06181831/69A3465_SH-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2017/07/wekfest-san-jose-going-big-in-the-bay/">
		
<div class="card-label category-eventcoverage">
		<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
		<h2>Wekfest San Jose: Going Big In The&nbsp;Bay</h2>
		<span class="date">July 7, 2017</span>
		<span class="divider">/</span>
		<span class="comments">13 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2017/06/track-inspired-trackspec/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/06/29145043/Wekfest_SJ_2017_69A2596_SH-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2017/06/track-inspired-trackspec/">
		
<div class="card-label category-eventcoverage">
		<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
		<h2>Track-Inspired Or&nbsp;Trackspec?</h2>
		<span class="date">June 30, 2017</span>
		<span class="divider">/</span>
		<span class="comments">10 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2017/06/introducing-project-nine/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/06/27231142/DSC_8866FIN_SH-520x347.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2017/06/introducing-project-nine/">
		
<div class="card-label tag-projectcar">
		<span class="potent">PROJECT </span><span class="light">CAR</span></div>
		<h2>Introducing Project&nbsp;Nine</h2>
		<span class="date">June 28, 2017</span>
		<span class="divider">/</span>
		<span class="comments">45 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title" id="comments">Comments</h4>
		<div class="de_comments">
			<div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
     data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
     data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
     data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
     data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
     data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
     data-post_id="332937"
     data-user_id="0"
     data-is_need_logged="0"
     data-lang="en"
     data-decom_comment_single_translate=" comment"
     data-decom_comment_twice_translate=" comments"
     data-decom_comment_plural_translate=" comments"
     data-multiple_vote="1"
     data-text_lang_comment_deleted='Comment deleted'
     data-text_lang_edited="Edited at"
     data-text_lang_delete="Delete"
     data-text_lang_not_zero="Field is not null"
     data-text_lang_required="This field is required."
     data-text_lang_checked="Mark one of the points"
     data-text_lang_completed="Operation completed"
     data-text_lang_items_deleted="The items have been deleted"
     data-text_lang_close="Close"
     data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform decomments-avatar-right" data-site-url="http://www.speedhunters.com">

	<div class="decomments-social-login-widget">
		 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<div class="oneall_social_login">
 <div class="oneall_social_login_label" style="margin-bottom: 3px;"><label>Connect with:</label></div>
 <div class="oneall_social_login_providers" id="oneall_social_login_providers_1788964"></div>
 <script type="text/javascript">
  var _oneall = _oneall || [];
  _oneall.push(['social_login', 'set_providers', ['facebook','google','reddit']]);
  _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&amp;': '?') + "oa_social_login_source=comments"))]);
  _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
  _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_1788964']);
 </script>
</div>	</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" action="http://www.speedhunters.com/wp-login.php" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="log" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="pwd" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input id="submit-form" type="hidden" name="submit" />
				<input type="hidden" name="redirect_to" value="" />
				<input type="hidden" id="security" name="security" value="83f7cc6fd2" /><input type="hidden" name="_wp_http_referer" value="/2017/07/mitsubishi-owners-club-mod-17/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
				<div class="comment-form" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>
		<div class="decomments-head">

			<h3><i><span class="decomments-comments-number decomments-block">3</span><span class="decomments-comment-title"> comments</span></i></h3>			<form class=" decom_comments_sort decomments-comment-sort" action="#comments" method="post" >
				<label>Sort:</label>
				<dl class="de-select de-select-filter">
					<dt>by Oldest</dt>
					<dd name="decom_comments_sort" class="decomments-select">
						<a onclick="decom.sortComments(this)"  href="#" data-sort="rate">
							<i class="decomments-icon-thumb-down"></i> by Best						</a>
						<a onclick="decom.sortComments(this)"  href="#" data-sort="newer">
							<i class="decomments-icon-thumb-down"></i> by Newest						</a>
						<a onclick="decom.sortComments(this)" class="current" href="#" data-sort="older" selected='selected'>
							<i class="decomments-icon-thumb-down"></i> by Oldest						</a>
					</dd>
				</dl>
			</form>
		</div>
		<div class="decomments-comment-list decomments-avatar-right" style="min-height: 250px;">
			<div class="loader-ball-scale lbs-remove">
				<div></div>
				<div></div>
				<div></div>
			</div>
			<div class="comment even thread-even depth-1 decomments-comment-block" id="comment-1483859" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/11a868321c721016abe84fb5aa98ea04?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="145""><a href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/#comment-1483859" class="decomments-number"><span>1</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/#comment-1483859" class="decomments-date-link">
				
			<time datetime="6:33 pm July 11, 2017">6:33 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">rvzenki</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1483859"><p>I used to own a 1g talon tsi awd as my winter car and that was just about the most fun winter i have ever had. My friends and I drove the living shit out of that car and it never gave me one trouble. I even two tracked it through the through huge puddles and tons of snow. I am determined to own another someday!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1483859">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div><div class="comment byuser comment-author-nolan-bjorn odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-1483863" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt="" src="https://graph.facebook.com/10212011665561439/picture?type=large" class="avatar avatar-social-login avatar-40 photo" height="40" width="40" /></span>
                     	<figcaption data-cui="1207" data-pai="145""><a href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/#comment-1483863" class="decomments-number"><span>2</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/#comment-1483863" class="decomments-date-link">
				
			<time datetime="6:39 pm July 11, 2017">6:39 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Nolan Christian Lohmann Bjorn</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1483863"><p>I was hoping to see more Starions but great coverage from MOD. One day I will make it out there.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1483863"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div><div class="comment byuser comment-author-airik-keringes even thread-even depth-1 decomments-comment-block" id="comment-1483881" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt="" src="https://graph.facebook.com/416875645318903/picture?type=large" class="avatar avatar-social-login avatar-40 photo" height="40" width="40" /></span>
                     	<figcaption data-cui="240" data-pai="145""><a href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/#comment-1483881" class="decomments-number"><span>3</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/#comment-1483881" class="decomments-date-link">
				
			<time datetime="7:31 pm July 11, 2017">7:31 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Airik Keringes</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1483881"><p>I've gotta admit... Mitsubishi has made some VERY great cars over the years. And I think I'll most miss having a manufacturer that offers such a wide selection of performance levels on a majority of the cars in their lineup. VR-4, GSX, TS-i, GSR, SRT, Evolution, GS-T, RS... all higher performance variants of a base model car. SO MANY options for interior trim level, drivetrain layout, HP level, exterior trim, Turbocharged or NA, 2-door or 4-door, OEM big crazy race wing from the dealer or wingless. Hell, in the 90's you could even pick which Manufacturer badging you wanted (to an extent). Be it Mitsubishi, Dodge, Chrysler, Eagle, Plymouth. I realize they were for the most part just mix and matching bumpers/fenders and sideskirts across the same 3-4 chassis. But most OEM's today do this type of "Badge Engineering" only as an attempt to move a platform upmarket and squeeze a bit more markup out of a buyer. Ahem... Toyota/Lexus... *COUGH* Nissan/Infiniti.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1483881"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div>		</div><!-- .commentlist -->
		</div>
</div>
		</div>
	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-8 small-block-grid-4 text-center"/><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="http://www.fueloffroad.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041516/fuel.png"/></a></li><li><a href="http://www.kleers.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095015/kleers.png"/></a></li><li><a href="http://www.kwsuspensions.de/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/08053600/KW-Logo.png"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.rotiform.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041517/rotiform.png"/></a></li><li><a href="http://www.takataracingstore.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2017/07/mitsubishi-owners-club-mod-17/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers & drivers with a shared passion for uncovering the world's most exciting car culture stories. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team Speedhunters</h4>			<div class="textwidget">Editor in Chief:
<em>Dino Dalle Carbonare</em> <br />

Managing Editor:
<em>Brad Lord</em> <br />

Project Manager:
<em>Annika Goksu</em> <br />

Commercial Director: 
<em>Ben Chandler</em><br />

Product Associate: 
<em>Arslan Golic</em><br />

Commercial Editor:
<em>Paddy McGrath</em><br />

Community Manager: 
<em>Mark Riccioni</em><br />

Senior Contributors: 
<em>Larry Chen, Keith Charvonia</em><br />

Contributors: 
<em>Blake Jones, Richard Opie, Louis Yio, Jordan Butters, Alok Paleri, Matthew Everingham, Ron Celestine, Justin Banner</em><br />

Guest Contributors: 
<em>Aki Itoh, Trevor Yale Ryan</em><br />

Builders-Drivers: 
<em>Peter Pentell, Edward Sandström</em> <br /> </div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	<li><a href="http://formulad.com"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/08/19004845/formula-drift.png" /></a></li>
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.kleerfreight.com/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/23044303/kleerfreight-logo.png" /></a></li>
<li><a href="http://www.h-c.co.jp/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/11043940/hashimoto.png" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://ghostgames.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ghost.jpg" /></a></li>
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="https://www.facebook.com/edward.sandstrom.racing/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/edward.jpg" /></a></li>
	<li><a href="http://motorheadmagazine.jp/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/motorhead.jpg" /></a></li>
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
	<li><a href="http://www.mcnsport.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/mcn.jpg" /></a></li>
	<li><a href="http://www.ponydrift.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ponydrift.jpg" /></a></li>
<li><a href="https://www.facebook.com/JamesDeaneDrifting"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/20005931/JamesDeaneDrifting.jpg" /></a></li>
<li><a href="https://www.facebook.com/piotrwiecekdrift"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/20005934/piotrwiecekdrift.jpg" /></a></li>
<li><a href="https://www.facebook.com/worthousedriftteam"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/20010806/worthouse.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2017 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/1/legal-notices">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><link rel='stylesheet' id='dashicons-css'  href='http://www.speedhunters.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"http:\/\/www.speedhunters.com\/wp-admin\/admin-ajax.php","redirecturl":"\/2017\/07\/mitsubishi-owners-club-mod-17\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.speedhunters.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 1.748 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-07-11 19:32:08 -->

<!-- super cache -->