<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    Meeting A 900hp Porsche 944 At Home In Iceland - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Facebook App Code -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '252792185178857',
      cookie     : true,
      xfbml      : true,
      version    : 'v2.8'
    });
    FB.AppEvents.logPageView();   
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- End Facebook App Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Meeting A 900hp Porsche 944 At Home In Iceland - Speedhunters" />
<meta property="og:description" content="Having said that, at the time I didn’t really think of it as anything special, because it was my home. But now that I’ve moved to Sweden, I have come to realize that I really did take Iceland’s black-sand beaches, snow-covered mountains in the middle of the summer and spontaneous snowstorms in the spring, volcanoes, lagoons and nature’s hot tubs &hellip;" />
<meta property="og:url" content="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="944" />
<meta property="article:tag" content="drift" />
<meta property="article:tag" content="Drifting" />
<meta property="article:tag" content="Iceland" />
<meta property="article:tag" content="ls" />
<meta property="article:tag" content="LS2" />
<meta property="article:tag" content="Porsche" />
<meta property="article:tag" content="V8" />
<meta property="article:section" content="Car Features" />
<meta property="article:section" content="Content" />
<meta property="article:published_time" content="2021-11-18T09:00:12+00:00" />
<meta property="article:modified_time" content="2021-11-18T03:04:59+00:00" />
<meta property="og:updated_time" content="2021-11-18T03:04:59+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/18022947/N35.jpeg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Meeting A 900hp Porsche 944 At Home In&nbsp;Iceland Comments Feed" href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/feed/" />
<link rel='stylesheet' id='decomments-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background:  !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color: !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color: !important; } .decomments-gif:after{ border-left-color: !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background: !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke: !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill: !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke: !important; }
			 </style>
			<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=533285' />

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://speedhunters.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-533285 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>
        							<dd><h4 data-section-title class="pointable"><a href"#" class="more-button">More&hellip;</a></h4></dd>
        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>
                                    <i data-section-title class="fi-arrow-down pointable more-button"></i>
                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                Meeting A 900hp Porsche 944 At Home In&nbsp;Iceland            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-533285" class="post-533285 post type-post status-publish format-standard has-post-thumbnail hentry category-carfeatures category-content tag-944-tag tag-tag-drift tag-drifting tag-iceland tag-ls tag-ls2 tag-porsche tag-v8">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			<div class="story-meta large-12 columns">
  <div class="large-10 large-centered columns article-meta">
    <h1 class="entry-title">Meeting A 900hp Porsche 944 At Home In&nbsp;Iceland</h1>
    <hr />
    
<div class="story-label category-carfeatures">
	<span class="light">CAR </span><span class="potent">FEATURE</span></div>
    <dl>
                            <dt>By</dt>
                    <dd><a href="http://www.speedhunters.com/author/alenhaseta/" title="Posts by Alen Haseta" class="url fn" rel="author">Alen Haseta</a></dd>
                    </dl>
          <hr />

          <span class="story-date">18th November 2021</span>
          <span class="story-comments">
            <i class="fi-comments"></i>
            <a class="comments-link" href="#comments">13 Comments</a>
          </span>
        </div>
      </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/18022947/N35.jpeg" data-attachment-id="538331" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/18022947/N35-1200x800.jpeg" alt="Meeting A 900hp Porsche 944 At Home In&nbsp;Iceland">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><p class="intro-p">If you’ve read any of my other stories or follow me in general, you’ll know that I have lived the majority of my life in Iceland. The Nordic island nation is visually breathtaking, and it truly feels like you’re in a different world. I mean, when I was younger I could see one of Iceland’s many glaciers outside of my bedroom window. Amazing, right?</p>
<p>Having said that, at the time I didn’t really think of it as anything special, because it was my home. But now that I’ve moved to Sweden, I have come to realize that I really did take Iceland’s black-sand beaches, snow-covered mountains in the middle of the summer and spontaneous snowstorms in the spring, volcanoes, lagoons and nature’s hot tubs all for granted. So every year I try to return home to visit my family, and at the same time experience Iceland in a way I have never done before. Each year is unique, but 2021 was something even more special.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224048/151-680x453.jpg" alt="15" data-attachment-id="535475" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224048/151.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/15-35/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224048/151-1200x800.jpg"></figure><p>I met <a href="https://www.instagram.com/f2iceland/" target="_blank">Fannar Þór</a>, the owner of this Porsche 944,<a href="https://www.instagram.com/f2iceland/"> </a>briefly in Sweden during the Discodans event in 2019. At that time, he and a couple of his close friends from Iceland had brought over their drift cars.</p>
<p>A year prior to this, Fannar’s ‘F2′ 944 was <a href="http://www.speedhunters.com/2018/07/spoiler-alert-900hp-turbocharged-ls2-porsche/" target="_blank">featured on Speedhunters</a>, when it was driven in anger at the annual festival of madness that is Gatebil Mantorp. Since then, the Porsche has had some further upgrades made to it, so I figured I could check out those as well as take a look at the garage where the magic happens. Before we do that though, a quick background story on the man himself.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230902/1-Porsche-944-drift-jordanbutters-speedhunters-1-680x454.jpeg" alt="1-Porsche-944-drift-jordanbutters-speedhunters-1" data-attachment-id="538319" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230902/1-Porsche-944-drift-jordanbutters-speedhunters-1.jpeg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-porsche-944-drift-jordanbutters-speedhunters-1/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230902/1-Porsche-944-drift-jordanbutters-speedhunters-1-1200x801.jpeg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230910/1-Porsche-944-drift-jordanbutters-speedhunters-6828-680x454.jpeg" alt="1-Porsche-944-drift-jordanbutters-speedhunters-6828" data-attachment-id="538321" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230910/1-Porsche-944-drift-jordanbutters-speedhunters-6828.jpeg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-porsche-944-drift-jordanbutters-speedhunters-6828/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230910/1-Porsche-944-drift-jordanbutters-speedhunters-6828-1200x801.jpeg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230915/1-Porsche-944-drift-jordanbutters-speedhunters-9163-680x453.jpeg" alt="1-Porsche-944-drift-jordanbutters-speedhunters-9163" data-attachment-id="538322" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230915/1-Porsche-944-drift-jordanbutters-speedhunters-9163.jpeg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-porsche-944-drift-jordanbutters-speedhunters-9163/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230915/1-Porsche-944-drift-jordanbutters-speedhunters-9163-1200x800.jpeg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230906/1-Porsche-944-drift-jordanbutters-speedhunters-3124.jpeg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230906/1-Porsche-944-drift-jordanbutters-speedhunters-3124-680x454.jpeg" alt="1-Porsche-944-drift-jordanbutters-speedhunters-3124" data-attachment-id="538320" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230906/1-Porsche-944-drift-jordanbutters-speedhunters-3124.jpeg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-porsche-944-drift-jordanbutters-speedhunters-3124/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/17230906/1-Porsche-944-drift-jordanbutters-speedhunters-3124-1200x801.jpeg"></a></figure><p>Fannar bought his first Porsche when he was only 16 years old. His uncle and his best friend both drove and raced Porsches, so naturally that had a big impact on Fannar, who just before sitting his drivers license test in 2003 acquired a 1980 924 Turbo. Or at least he though he had. Due to some complications with the sale at the seller’s end, by the time Fannar had his license in hand there was still no 924 in his driveway. So he moved on to this 944.</p>
<p>Any hopes of a life of carefree Porsche motoring were quickly dashed though, when just three days after purchase the 944’s engine died. This may or may not have had something to do with Fannar having a bit too much fun, but regardless of how it happened, the motor blow set in motion Fannar’s mechanical journey with the car, which has resulted in the absolute animal it is today.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223922/181.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223922/181-680x453.jpg" alt="18" data-attachment-id="535472" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223922/181.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/18-34/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223922/181-1200x800.jpg"></a></figure><p>As I mentioned in my <a href="http://www.speedhunters.com/2021/11/a-2jz-swapped-e46-m3-from-iceland/" target="_blank">recent story on a 2JZ-swapped BMW E46 M3</a>, before my latest trip back to Iceland, I had not expected to find any cool builds there. But remembering Fannar’s journey to Scandinavia, I knew I had to at least visit him and see what other automotive gems he might have tucked away in his garage.</p>
<p>The first thing I noticed as we drove up to house where Fannar keeps his 944, is that the garage door was way larger then normal. Fannar only rents this garage space, so in respecting the homeowner’s privacy I can’t show you what the house looks like outside. But I can show you what’s inside the main garage; stick around for that at the end of the story.</p>
<p>We walked around the side of the house, and that’s when I spotted these three Porsche Cayannes. I don’t know if they were awaiting repairs or spending their last days in the sun, but I figure they at least provide Fannar with a supply of parts whenever he needs them.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223954/161.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223954/161-680x453.jpg" alt="16" data-attachment-id="535473" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223954/161.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/16-37/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21223954/161-1200x800.jpg"></a></figure><p>Around the corner another garage came into view, and parked outside was Fannar’s freshly-upgraded 944 drift machine. I wasn’t able to have a good look at this thing when he brought it over to Sweden in 2019, so I made the most of this opportunity. It truly is awesome, and I’ll go into some of the details shortly.</p>
<p>At this point of my visit though, my eyes were firmly fixed on the garage behind as I wondered what might be hiding inside…</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224234/162-680x453.jpg" alt="16" data-attachment-id="535477" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224234/162.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/16-38/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224234/162-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225250/53-680x453.jpg" alt="5" data-attachment-id="535489" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225250/53.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/5-47/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225250/53-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225324/82-680x453.jpg" alt="8" data-attachment-id="535490" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225324/82.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/8-43/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225324/82-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224154/1321-680x453.jpg" alt="13" data-attachment-id="535476" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224154/1321.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/13-36/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224154/1321-1200x800.jpg"></figure><p>As it turns out, Fannar isn’t the only one renting space in this garage; a number of his friends store their projects here too. From what I was told, there are some pretty special builds going on in this space, so I’ll be sure to keep an eye out for them.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224445/171.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224445/171-680x453.jpg" alt="17" data-attachment-id="535479" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224445/171.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/17-34/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224445/171-1200x800.jpg"></a></figure><p>It’s hard to miss the Speed Yellow 964, which Fannar has owned for quite some time. He likes to call this supercharged ’93 Porsche the <em>“Money Pit”.</em></p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224558/111.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224558/111-680x453.jpg" alt="11" data-attachment-id="535480" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224558/111.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/11-38/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224558/111-1200x800.jpg"></a></figure><p>On the car lift sits Fannar’s most challenging project to date – a 1985 Porsche 944. What makes this build so tough is the amount of time he’s having to spend online at night trying to track down some very rare parts. Fannar’s goal is to really bring back the ’80s, and among other things he’s hell-bent on running a Gemballa body kit.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224739/71.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224739/71-680x453.jpg" alt="7" data-attachment-id="535481" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224739/71.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/7-46/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224739/71-1200x800.jpg"></a></figure><p>And then there’s this ’81 924 Turbo on color-coded O.Z. Racing Futura wheels, Fannar’s pride and joy. It’s been in his family for almost 20 years now, and is always last on the list when comes to being worked on. In fact, by this point Fannar has resigned himself to appreciating it as a piece of art rather than a functional car.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225000/101-680x453.jpg" alt="10" data-attachment-id="535485" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225000/101.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/10-39/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225000/101-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224954/152-680x453.jpg" alt="15" data-attachment-id="535484" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224954/152.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/15-36/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224954/152-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224910/182-680x453.jpg" alt="1" data-attachment-id="535483" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224910/182.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-65/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21224910/182-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225351/63-680x453.jpg" alt="6" data-attachment-id="535491" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225351/63.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/6-46/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225351/63-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225113/92.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225113/92-680x453.jpg" alt="9" data-attachment-id="535487" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225113/92.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/9-40/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225113/92-1200x800.jpg"></a></figure><p>As you’d expect with so many Porsche projects on the go, Fannar has acquired a lot of parts along the way, and I’m sure there are so many more treasures in here than what I spotted around the garage.</p>
<p>I could have easily spent hours in this place, but the F2 was calling…</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225620/183.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225620/183-680x453.jpg" alt="1" data-attachment-id="535493" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225620/183.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-66/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225620/183-1200x800.jpg"></a></figure><p>Obviously I wanted to see the car ripping on Icelandic roads – the 944 is street legal after all – but first I wanted to check it out in detail, so Fannar decided to take me somewhere I had never visited before.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225800/25-680x453.jpg" alt="2" data-attachment-id="535495" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225800/25.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/2-62/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225800/25-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225810/54-680x453.jpg" alt="5" data-attachment-id="535496" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225810/54.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/5-48/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225810/54-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225724/184-680x453.jpg" alt="1" data-attachment-id="535494" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225724/184.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-67/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225724/184-1200x800.jpg"></figure><p>A quick drive to the outskirts of Mosfellsbær, itself just 15 minutes from the country’s capital, Reykjavík, we reached the destination. This house, which also features a little shop, was home to Iceland’s only Nobel Prize winner, the late Halldór Laxness. Parked in the driveway was his 1969 MkII Jaguar. Who knew Iceland’s greatest novelist rode in style…</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225926/721.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225926/721-680x453.jpg" alt="7" data-attachment-id="535498" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225926/721.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/7-47/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21225926/721-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230002/112-680x453.jpg" alt="11" data-attachment-id="535499" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230002/112.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/11-39/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230002/112-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230020/102-680x453.jpg" alt="10" data-attachment-id="535500" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230020/102.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/10-40/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230020/102-1200x800.jpg"></div></li></ul><p>Fannar’s 944 was primarily built as a drift machine, but as it evolved it became more of a show car too. That’s not to say that Fannar has ever been scared to use it; come competition time he doesn’t hold back in the slightest.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230315/83.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230315/83-680x453.jpg" alt="8" data-attachment-id="535502" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230315/83.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/8-44/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230315/83-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230405/36-680x453.jpg" alt="3" data-attachment-id="535503" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230405/36.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/3-62/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230405/36-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230427/64-680x453.jpg" alt="6" data-attachment-id="535504" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230427/64.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/6-47/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230427/64-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230442/185-680x453.jpg" alt="1" data-attachment-id="535505" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230442/185.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-68/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230442/185-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230521/261.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230521/261-680x453.jpg" alt="2" data-attachment-id="535506" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230521/261.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/2-63/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230521/261-1200x800.jpg"></a></figure><p>Last time the car was dynoed, the BorgWarner S475 turbo-boosted 6.0L LS2 V8 up front produced 805whp at 1315Nm, but at only around 80% power. It’s safe to say then that Fannar has plenty to play with under his right foot.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230618/113.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230618/113-680x453.jpg" alt="11" data-attachment-id="535507" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230618/113.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/11-40/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230618/113-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230716/722-680x453.jpg" alt="7" data-attachment-id="535508" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230716/722.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/7-48/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230716/722-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230727/931-680x453.jpg" alt="9" data-attachment-id="535509" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230727/931.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/9-41/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230727/931-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230802/172.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230802/172-680x453.jpg" alt="17" data-attachment-id="535510" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230802/172.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/17-35/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230802/172-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230843/932-680x453.jpg" alt="9" data-attachment-id="535511" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230843/932.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/9-42/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230843/932-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230856/37-680x453.jpg" alt="3" data-attachment-id="535512" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230856/37.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/3-63/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21230856/37-1200x800.jpg"></div></li></ul><p>Since Speedhunters’ original feature, the Porsche 944 Turbo S AOR transaxle transmission out back has been replaced with a 6-speed Audi 01E front-wheel drive unit. Fannar says the main reason for this swap was the availability of parts and increased reliability. Since the Audi box is wider than the Porsche unit though, new Driveshaft Shop Level 5 axles were required.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234718/132.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234718/132-680x453.jpg" alt="13" data-attachment-id="535514" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234718/132.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/13-37/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234718/132-1200x800.jpg"></a></figure><p>In the wheel and tire department, the three-piece BW Motorsports/Kinesis wheels now feature slightly more aggressive specs – 18×9-inch up front and 18×12-inch at the rear – and are wrapped in Sava Intensa HP 215/35R18 and 285/30R18 rubber front and rear respectively.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234817/84.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234817/84-680x453.jpg" alt="8" data-attachment-id="535515" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234817/84.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/8-45/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234817/84-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234904/262-680x453.jpg" alt="2" data-attachment-id="535516" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234904/262.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/2-64/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234904/262-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234915/55-680x453.jpg" alt="5" data-attachment-id="535517" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234915/55.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/5-49/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234915/55-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234932/186-680x453.jpg" alt="1" data-attachment-id="535518" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234932/186.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-69/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234932/186-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234953/72.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234953/72-680x453.jpg" alt="7" data-attachment-id="535519" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234953/72.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/7-49/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21234953/72-1200x800.jpg"></a></figure><p>The interior meanwhile has remained the same. Fannar put so much thought into this build the first time around, that changes were only ever going to be minor and more about fine-tuning the setup than anything else.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235211/141.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235211/141-680x453.jpg" alt="14" data-attachment-id="535521" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235211/141.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/14-32/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235211/141-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235612/1211-680x453.jpg" alt="12" data-attachment-id="535522" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235612/1211.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/12-39/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235612/1211-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235626/441-680x453.jpg" alt="4" data-attachment-id="535523" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235626/441.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/4-58/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235626/441-1200x800.jpg"></div></li></ul><p>Exterior-wise, the 944 has gone from white to a triple-color scheme that Fannar saw in a ’90s car magazine.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235739/26.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235739/26-680x453.jpg" alt="2" data-attachment-id="535524" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235739/26.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/2-65/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235739/26-1200x800.jpg"></a></figure><p>The Icelandic drift community is very tight-knit, and everyone is in it to have fun above all else. Track days are the best days of the year for many, but the limited number of circuits in Iceland mean that drivers often take to these desolate hills in the outskirts of Reykjavík for a bit of fun.</p>
<p>I lived 292 miles from Iceland’s capital when I was younger, and despite the landscape remaining pretty much the same since then, driving on Icelandic roads gives me a nostalgic feeling every time I visit. Seeing Fannar’s car on the open road made the experience even better.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235804/442.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235804/442-680x453.jpg" alt="4" data-attachment-id="535525" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235804/442.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/4-59/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/21235804/442-1200x800.jpg"></a></figure><p>Like everyone at Speedhunters, I enjoy taking pictures of wild cars on the road, but this time it was different. Yes, I fired away on the shutter button like I always do, but I wasn’t as fussed about capturing the moment – I just wanted to savor it.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/23125629/A7301683-Edit.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/23125629/A7301683-Edit-680x453.jpg" alt="A7301683-Edit" data-attachment-id="535717" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/23125629/A7301683-Edit.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/a7301683-edit/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/23125629/A7301683-Edit-1200x800.jpg"></a></figure><p>So what’s next for the F2? Fannar plans to fit an SLR E46 angle kit amongst few other things, but the biggest plan is to travel with the car. With more and more countries lifting their Covid restrictions, it’s only a matter of time before Fannar and the 944 are back in Europe ripping it up.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000716/38.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000716/38-680x453.jpg" alt="3" data-attachment-id="535528" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000716/38.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/3-64/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000716/38-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000804/187-680x453.jpg" alt="1" data-attachment-id="535529" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000804/187.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/1-70/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000804/187-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000819/271-680x453.jpg" alt="2" data-attachment-id="535530" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000819/271.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/2-66/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22000819/271-1200x800.jpg"></div></li></ul><p>Remember that big garage door I talked about at the beginning of this story? Well, here is what’s inside. Probably not what you expected, right?</p>
<p>This 1969 Aerospatiale Alouette II 318c belongs to Fannar’s landlord, but unfortunately he’s not going anywhere in it for the time being having been placed on a no-fly list for ‘disturbing the peace’.</p>
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/AeRbqCTDXaY" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<p>If you’re wondering how that happened, check out the clip above.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22001046/44.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22001046/44-680x453.jpg" alt="4" data-attachment-id="535531" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22001046/44.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/4-60/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/10/22001046/44-1200x800.jpg"></a></figure><p>Since March of this year, there has been volcanic activity southeast of Iceland’s capital. A volcano called Fagradalsfjall was very active when I visited, so after wrapping things up with Fannar, I took a nice evening drive to check it out. Of course, I forgot everything you’re supposed to bring with you when it’s cold, and the only piece of fabric shielding the top half of my body was very thin hoodie. But as I gained momentum walking up the mountain, I started to warm – helped in part of course by the glorious lava right in front of me. I’ll leave you with this final image to wrap up a somewhat unplanned, but wonderful day.</p>
<p><strong>Alen Haseta</strong><br>
Instagram: <a href="https://www.instagram.com/hazetaa/">hazetaa</a></p>
<p>Additional Photos by <strong>Jordan Butters</strong><br>
Instagram: <a href="http://www.instagram.com/jordanbutters" target="_blank">jordanbutters</a></p>
<p><strong>Fannar Þór’s 1986 Porsche 944 ‘F2′</strong></p>
<p><strong>Chassis:</strong> TIG-welded FIA specification roll cage with NASCAR-style door bars.</p>
<p><strong>Engine:</strong> 6.0-litre LS2, Wiseco forged pistons 10.9:1, cooling ports in the block filled, Scat rods, ARP bolts, LS9 head gasket, Lil John’s Motorsports Stage II turbo camshaft, Melling high volume oil pump, Accusump, oil scavenge pump, Vibrant Performance catch can, Vibrant vacuum manifolds, Comp timing cover &amp; timing chain double roller, Fast 102 intake &amp; throttle body, Vibrant couplings, BorgWarner S475 turbo with 87mm turbine &amp; 1.10a/r T6 housing, TiAL wastegates, TiAL 50mm blow-off valve, Treadstone intercooler, Holley HP EFI engine management system &amp; harness kit, Holley three-port solenoid valves, Meziere WP366S remote pump, Meziere WE100 &amp; WR100 coolant tanks, rear-mounted radiator, Aeromotive Eliminator, Aeromotive Fuel filters, Aeromotive regulators, E85 fuel, Bosch 2,200cc injectors, AN fittings throughout</p>
<p><strong>Drivetrain: </strong>Audi 01E 6-speed gearbox fitted in rear, Spec Super twin-plate clutch, The Driveshaft Shop Level 5 axles</p>
<p><strong>Wheels/Tires:</strong> 18×9-inch &amp; 18×12-inch 3-piece BW Motorsports/Kinesis wheels, Sava Intensa HP tires</p>
<p><strong>Exterior:</strong> Fibreglass doors from Club Autosport, fibreglass wide-body from IFC Racing, Lexan windows from Plastics 4 Performance, Big Country Labs FC3S 1,850mm wing with custom mounts, Lindsey Racing header panel</p>
<p><strong>Interior:</strong> Recaro seats, Racepak IQ3 Street dash, Racepak GPS module for speedometer, manual latch sunroof from Porsche 924, OMP steering wheel</p>
<aside class="exclude-from-p"><p><strong><a href="http://www.speedhunters.com/tag/iceland" target="_blank">More stories from Iceland on Speedhunters</a></strong></p>
</aside></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[14810,4623,2122,2120],"excerpt":"150","exclude":[533285]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2021/11/a-2jz-swapped-e46-m3-from-iceland/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/11/10032222/M3-17-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2021/11/a-2jz-swapped-e46-m3-from-iceland/">
		
<div class="card-label category-carfeatures">
		<span class="light">CAR </span><span class="potent">FEATURE</span></div>
		<h2>Daily + Drag: A 2JZ-Swapped E46 M3 From&nbsp;Iceland</h2>
		<span class="date">November 10, 2021</span>
		<span class="divider">/</span>
		<span class="comments">13 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2020/10/the-airtimes-porsche-pre-meet/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/10/14211002/Speedhunters_Porsche_Meet_Bastien_Bochmann_DSCF3135-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2020/10/the-airtimes-porsche-pre-meet/">
		
<div class="card-label tag-iamthespeedhunter">
		<span class="potent">I AM THE SPEEDHUNTER</span></div>
		<h2>The Airtimes Porsche&nbsp;Pre-Meet</h2>
		<span class="date">October 20, 2020</span>
		<span class="divider">/</span>
		<span class="comments">12 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2020/07/a-belgium-blast-with-friends/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/07/31231359/N-Speedhunters_Bastien_Bochmann_DSCF2004-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2020/07/a-belgium-blast-with-friends/">
		
<div class="card-label tag-iamthespeedhunter">
		<span class="potent">I AM THE SPEEDHUNTER</span></div>
		<h2>A Belgium Blast With&nbsp;Friends</h2>
		<span class="date">July 31, 2020</span>
		<span class="divider">/</span>
		<span class="comments">11 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title" id="comments">Comments</h4>
		<div class="de_comments">
			<div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
     data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
     data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
     data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
     data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
     data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
     data-post_id="533285"
     data-user_id="0"
     data-is_need_logged="0"
     data-lang="en"
     data-decom_comment_single_translate=" comment"
     data-decom_comment_twice_translate=" comments"
     data-decom_comment_plural_translate=" comments"
     data-multiple_vote="1"
     data-text_lang_comment_deleted='Comment deleted'
     data-text_lang_edited="Edited at"
     data-text_lang_delete="Delete"
     data-text_lang_not_zero="Field is not null"
     data-text_lang_required="This field is required."
     data-text_lang_checked="Mark one of the points"
     data-text_lang_completed="Operation completed"
     data-text_lang_items_deleted="The items have been deleted"
     data-text_lang_close="Close"
     data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform decomments-avatar-right" data-site-url="http://www.speedhunters.com">

	<div class="decomments-social-login-widget">
		 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<div class="oneall_social_login">
 <div class="oneall_social_login_label" style="margin-bottom: 3px;"><label>Connect with:</label></div>
 <div class="oneall_social_login_providers" id="oneall_social_login_providers_339523"></div>
 <script type="text/javascript">
  var _oneall = _oneall || [];
  _oneall.push(['social_login', 'set_providers', ['facebook','google','instagram','reddit','twitter']]);
  _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&amp;': '?') + "oa_social_login_source=comments"))]);
  _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
  _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_339523']);
 </script>
</div>	</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" action="http://www.speedhunters.com/wp-login.php" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="log" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="pwd" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input id="submit-form" type="hidden" name="submit" />
				<input type="hidden" name="redirect_to" value="" />
				<input type="hidden" id="security" name="security" value="4829f64f80" /><input type="hidden" name="_wp_http_referer" value="/2021/11/900hp-porsche-944-iceland/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
				<div class="comment-form" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>
		<div class="decomments-head">

			<h3><i><span class="decomments-comments-number decomments-block">13</span><span class="decomments-comment-title"> comments</span></i></h3>			<form class=" decom_comments_sort decomments-comment-sort" action="#comments" method="post" >
				<label>Sort:</label>
				<dl class="de-select de-select-filter">
					<dt>by Oldest</dt>
					<dd name="decom_comments_sort" class="decomments-select">
						<a onclick="decom.sortComments(this)"  href="#" data-sort="rate">
							<i class="decomments-icon-thumb-down"></i> by Best						</a>
						<a onclick="decom.sortComments(this)"  href="#" data-sort="newer">
							<i class="decomments-icon-thumb-down"></i> by Newest						</a>
						<a onclick="decom.sortComments(this)" class="current" href="#" data-sort="older" selected='selected'>
							<i class="decomments-icon-thumb-down"></i> by Oldest						</a>
					</dd>
				</dl>
			</form>
		</div>
		<div class="decomments-comment-list decomments-avatar-right" style="min-height: 250px;">
			<div class="loader-ball-scale lbs-remove">
				<div></div>
				<div></div>
				<div></div>
			</div>
			<div class="comment even thread-even depth-1 decomments-comment-block" id="comment-1635837" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/537c067e8c3160b5cd644e9093f7f741?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635837" class="decomments-number"><span>1</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635837" class="decomments-date-link">
				
			<time datetime="11:34 am November 18, 2021">11:34 am<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">tt</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635837"><p>haha, pretty funny to see the landlord in cahoots with the guy</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635837"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-right: 55px;"><div class="comment byuser comment-author-alenhaseta bypostauthor odd alt depth-2 decomments-comment-block" id="comment-1635847" parent-id="1635837" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/7593eb563a26726099fb8c61b1bda374?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="4211" data-pai="4211""><span class="decomments-author active">Author</span><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635847" class="decomments-number"><span>2</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635847" class="decomments-date-link">
				
			<time datetime="9:59 pm November 18, 2021">9:59 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">Alen Haseta</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635847"><p>Bad boys for life!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635847"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div></div>
</div><div class="comment even thread-odd thread-alt depth-1 decomments-comment-block" id="comment-1635838" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://0.gravatar.com/avatar/267886ee1b2f463cb064add6407c8307?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635838" class="decomments-number"><span>3</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635838" class="decomments-date-link">
				
			<time datetime="11:41 am November 18, 2021">11:41 am<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">Kitch</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635838"><p>Awesome article, awesome car and awesome pictures. Good effort all round bud</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635838">+1</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-right: 55px;"><div class="comment byuser comment-author-alenhaseta bypostauthor odd alt depth-2 decomments-comment-block" id="comment-1635851" parent-id="1635838" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/7593eb563a26726099fb8c61b1bda374?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="4211" data-pai="4211""><span class="decomments-author active">Author</span><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635851" class="decomments-number"><span>4</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635851" class="decomments-date-link">
				
			<time datetime="2:38 am November 19, 2021">2:38 am<i>November 19, 2021</i></time>			</a>
			<span class="decomments-autor-name">Alen Haseta</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635851"><p>Cheers bud!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635851">+1</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div></div>
</div><div class="comment even thread-even depth-1 decomments-comment-block" id="comment-1635839" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/5e85c5e093d7dfd559851598b4518d11?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635839" class="decomments-number"><span>5</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635839" class="decomments-date-link">
				
			<time datetime="12:58 pm November 18, 2021">12:58 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">Basith P.</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635839"><p>Now that's sick!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635839">+1</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div><div class="comment byuser comment-author-tobythyer odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-1635842" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt="" src="https://lh3.googleusercontent.com/a-/AOh14GgD3YR7Bp3nTMNXzRzNfVSsijZEI7lij4f3QeicbFY=s96-c" class="avatar avatar-social-login avatar-40 photo" height="40" width="40" /></span>
                     	<figcaption data-cui="3706" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635842" class="decomments-number"><span>6</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635842" class="decomments-date-link">
				
			<time datetime="3:45 pm November 18, 2021">3:45 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">Toby Thyer</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635842"><p>It’s always nice to be home, brilliant story mate!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635842"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-right: 55px;"><div class="comment byuser comment-author-alenhaseta bypostauthor even depth-2 decomments-comment-block" id="comment-1635848" parent-id="1635842" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/7593eb563a26726099fb8c61b1bda374?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="4211" data-pai="4211""><span class="decomments-author active">Author</span><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635848" class="decomments-number"><span>7</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635848" class="decomments-date-link">
				
			<time datetime="10:08 pm November 18, 2021">10:08 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">Alen Haseta</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635848"><p>Thanks man!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635848"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-even depth-1 decomments-comment-block" id="comment-1635843" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://0.gravatar.com/avatar/80905d2a734b4d76c184560aaaf5d3f2?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635843" class="decomments-number"><span>8</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635843" class="decomments-date-link">
				
			<time datetime="4:36 pm November 18, 2021">4:36 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">Nate</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635843"><p>Any more info on the 01e? What year? Adapter? We’re the axles custom or are they from a different vehicle?</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635843"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-right: 55px;"><div class="comment even depth-2 decomments-comment-block" id="comment-1635850" parent-id="1635843" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://0.gravatar.com/avatar/ecfc50d5ddb6b984fce2b6e9d304a953?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635850" class="decomments-number"><span>9</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635850" class="decomments-date-link">
				
			<time datetime="2:29 am November 19, 2021">2:29 am<i>November 19, 2021</i></time>			</a>
			<span class="decomments-autor-name">Fannar Þór</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635850"><p>It’s a Diesel box from A4-A6<br>1.9tdi and 2.5tdi<br>The axles are built by driveshaftshop, the coupler is custom as well the mounts for the box.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635850">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-1635844" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/d7dff0fba76d0259216c4342a5ca6ca9?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635844" class="decomments-number"><span>10</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635844" class="decomments-date-link">
				
			<time datetime="5:00 pm November 18, 2021">5:00 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">David</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635844"><p>Finally a story about "non-JDM" stuff@  Love SH to death but the over-kill with the JDM stories gets annoying!  I am a Porschefile for life! Fannar gets it!  That's why he's driving Porsches and not Nissans.  That's alot of hp.  Always appreciate  homegrown builds!  Still don't get drifting but to each his own.  I just live cars period.  GDM for life.  German Domestic Product.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635844"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-right: 55px;"><div class="comment even depth-2 decomments-comment-block" id="comment-1635845" parent-id="1635844" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/d7dff0fba76d0259216c4342a5ca6ca9?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635845" class="decomments-number"><span>11</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635845" class="decomments-date-link">
				
			<time datetime="5:00 pm November 18, 2021">5:00 pm<i>November 18, 2021</i></time>			</a>
			<span class="decomments-autor-name">David</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635845"><p>Love.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635845"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-even depth-1 decomments-comment-block" id="comment-1635855" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://0.gravatar.com/avatar/40de03f9b514e7d78219a77d76503a20?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635855" class="decomments-number"><span>12</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635855" class="decomments-date-link">
				
			<time datetime="3:59 am November 19, 2021">3:59 am<i>November 19, 2021</i></time>			</a>
			<span class="decomments-autor-name">Jay Soh Tsu Chung</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635855"><p>So many things to love in one article! That volcano picture sure is glorious!</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635855"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div><div class="comment even thread-odd thread-alt depth-1 decomments-comment-block" id="comment-1635856" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/1017ed79785f235dc87542bdc6d7b0e9?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="4211""><a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635856" class="decomments-number"><span>13</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/#comment-1635856" class="decomments-date-link">
				
			<time datetime="5:34 am November 19, 2021">5:34 am<i>November 19, 2021</i></time>			</a>
			<span class="decomments-autor-name">Vivizurianty</span><img width="20" title="Trusted" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/02/14233136/badge-verified.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1635856"><p>I just love the twin sky-pointing exhaust pipes.  I cant imagine the sight and sound when the engine is let-loose.<br><br>Thanks for bringing forth this very interesting article.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1635856"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div>		</div><!-- .commentlist -->
		</div>
</div>
		</div>
	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-6 small-block-grid-4 text-center"/><li><a href="https://www.kwsuspensions.de"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/04/15082903/KWautomotive_Logo_180x85px.png"/></a></li><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.gtechniq.com"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2021/01/05074852/Gtechniq_180x85-copy3.jpg"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="http://www.speedhunters.com"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2021/11/900hp-porsche-944-iceland/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers and drivers with a shared passion for uncovering the world's most exciting car culture stories. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team Speedhunters</h4>			<div class="textwidget">Editorial Director:
<em>Brad Lord</em> <br />

Commercial Director: 
<em>Ben Chandler</em><br />

Creative Director: 
<em>Mark Riccioni</em><br />

Contributing Editor:
<em>Dino Dalle Carbonare</em><br />

Technical Editor: 
<em>Ryan Stewart</em><br />

Contributors: 
<em>Will Beaumont, Keiron Berndt, Jordan Butters, Ron Celestine, Mario Christou, Cian Donnellan, Matthew Everingham, Blake Jones, Stefan Kotze, Vladimir Ljadov, Paddy McGrath, Brandon Miller, Rick Muda, Yaheem Murph, Sara Ryan, Trevor Yale Ryan, Dave Thomas, Toby Thyer, Simon Woolley, Naveed Yousufzai</em><br />



</div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
<li><a href="http://www.h-c.co.jp/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/11043940/hashimoto.png" /></a></li>
<li><a href="https://sekritbrand.com"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/29111622/File-from-iOS-e1556562006726.gif" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2021 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/legal">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><link rel='stylesheet' id='dashicons-css'  href='http://www.speedhunters.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"http:\/\/www.speedhunters.com\/wp-admin\/admin-ajax.php","redirecturl":"\/2021\/11\/900hp-porsche-944-iceland\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.speedhunters.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 2.024 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-11-19 08:40:51 -->

<!-- super cache -->