<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    1,800hp For The Strip &amp; Street - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Facebook App Code -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '252792185178857',
      cookie     : true,
      xfbml      : true,
      version    : 'v2.8'
    });
    FB.AppEvents.logPageView();   
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- End Facebook App Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="1,800hp For The Strip &amp; Street - Speedhunters" />
<meta property="og:description" content="It was a cool-looking truck for sure, but in the moment I assumed it was just a support vehicle for a Finnish doorslammer. How wrong I was… The Chevy was parked up, but there wasn’t any dragster nearby. Mikko stepped out from the driver’s seat, removed two huge slicks and some skinny front tires from the trailer, &hellip;" />
<meta property="og:url" content="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="C1500" />
<meta property="article:tag" content="Car Spotlight" />
<meta property="article:tag" content="Chevrolet C1500" />
<meta property="article:tag" content="Dart" />
<meta property="article:tag" content="Drag" />
<meta property="article:tag" content="drag car" />
<meta property="article:tag" content="drag racing" />
<meta property="article:tag" content="Finland" />
<meta property="article:tag" content="Fleetside" />
<meta property="article:tag" content="Haapsalu" />
<meta property="article:tag" content="pick-up" />
<meta property="article:tag" content="pickup" />
<meta property="article:section" content="Car Features" />
<meta property="article:section" content="Car Spotlight" />
<meta property="article:section" content="Content" />
<meta property="article:published_time" content="2020-04-06T18:00:57+00:00" />
<meta property="article:modified_time" content="2020-04-06T18:04:41+00:00" />
<meta property="og:updated_time" content="2020-04-06T18:04:41+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110234/chevrolet-c1500-pikkis-by-wheelsbywovka-29.jpg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; 1,800hp For The Strip &amp;&nbsp;Street Comments Feed" href="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/feed/" />
<link rel='stylesheet' id='decomments-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background:  !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color: !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color: !important; } .decomments-gif:after{ border-left-color: !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background: !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke: !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill: !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke: !important; }
			 </style>
			<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=475135' />

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://speedhunters.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-475135 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Tealium -->
<script type="text/javascript">
var utag_data = {
}
</script>

<!-- Loading script asynchronously -->
<script type="text/javascript">
    (function(a,b,c,d){
    a='//tags.tiqcdn.com/utag/ea/speedhunterscom/prod/utag.js';
    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
    })();
</script>
<!-- End Tealium -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>
        							<dd><h4 data-section-title class="pointable"><a href"#" class="more-button">More&hellip;</a></h4></dd>
        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>
                                    <i data-section-title class="fi-arrow-down pointable more-button"></i>
                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                1,800hp For The Strip &#038;&nbsp;Street            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-475135" class="post-475135 post type-post status-publish format-standard has-post-thumbnail hentry category-carfeatures category-car-spotlight category-content tag-c1500 tag-car-spotlight tag-chevrolet-c1500 tag-dart tag-drag tag-drag-car tag-dragracing tag-finland tag-fleetside tag-haapsalu tag-pick-up tag-pickup">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			<div class="story-meta large-12 columns">
  <div class="large-10 large-centered columns article-meta">
    <h1 class="entry-title">1,800hp For The Strip &#038;&nbsp;Street</h1>
    <hr />
    
<div class="story-label tag-car-spotlight">
	<span class="light">CAR </span><span class="potent">SPOTLIGHT</span></div>
    <dl>
                            <dt>By</dt>
                    <dd><a href="http://www.speedhunters.com/author/vladimir-ljadov/" title="Posts by Vladimir Ljadov" class="url fn" rel="author">Vladimir Ljadov</a></dd>
                    </dl>
          <hr />

          <span class="story-date">6th April 2020</span>
          <span class="story-comments">
            <i class="fi-comments"></i>
            <a class="comments-link" href="#comments">0 Comments</a>
          </span>
        </div>
      </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110234/chevrolet-c1500-pikkis-by-wheelsbywovka-29.jpg" data-attachment-id="475300" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110234/chevrolet-c1500-pikkis-by-wheelsbywovka-29-1200x800.jpg" alt="1,800hp For The Strip &#038;&nbsp;Street">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><p class="intro-p">I met Mikko Wihinen in Kiltsi, Estonia during a drag race event held at a former Soviet military airbase repurposed for speed runs. He had just rolled into the paddock driving his 1990 Chevrolet C1500 Sport Fleetside, with a trailer hitched at the rear. </p>
<p>It was a cool-looking truck for sure, but in the moment I assumed it was just a support vehicle for a Finnish doorslammer. How wrong I was…</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104107/chevrolet-c1500-pikkis-by-wheelsbywovka-3-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-3" data-attachment-id="475244" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104107/chevrolet-c1500-pikkis-by-wheelsbywovka-3.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-3/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104107/chevrolet-c1500-pikkis-by-wheelsbywovka-3-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104110/chevrolet-c1500-pikkis-by-wheelsbywovka-68-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-68" data-attachment-id="475245" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104110/chevrolet-c1500-pikkis-by-wheelsbywovka-68.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-68/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104110/chevrolet-c1500-pikkis-by-wheelsbywovka-68-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104137/chevrolet-c1500-pikkis-by-wheelsbywovka-4.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104137/chevrolet-c1500-pikkis-by-wheelsbywovka-4-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-4" data-attachment-id="475246" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104137/chevrolet-c1500-pikkis-by-wheelsbywovka-4.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-4/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104137/chevrolet-c1500-pikkis-by-wheelsbywovka-4-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104159/chevrolet-c1500-pikkis-by-wheelsbywovka-5-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-5" data-attachment-id="475247" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104159/chevrolet-c1500-pikkis-by-wheelsbywovka-5.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-5/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104159/chevrolet-c1500-pikkis-by-wheelsbywovka-5-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104203/chevrolet-c1500-pikkis-by-wheelsbywovka-6-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-6" data-attachment-id="475248" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104203/chevrolet-c1500-pikkis-by-wheelsbywovka-6.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-6/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104203/chevrolet-c1500-pikkis-by-wheelsbywovka-6-1200x800.jpg"></div></li></ul><p>The Chevy was parked up, but there wasn’t any dragster nearby. Mikko stepped out from the driver’s seat, removed two huge slicks and some skinny front tires from the trailer, and proceeded to jack the truck up and swap them over.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104406/chevrolet-c1500-pikkis-by-wheelsbywovka-25-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-25" data-attachment-id="475252" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104406/chevrolet-c1500-pikkis-by-wheelsbywovka-25.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-25/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104406/chevrolet-c1500-pikkis-by-wheelsbywovka-25-1200x800.jpg"></figure><p>Then it hit me… In typical crazy Finnish fashion, this guy had driven from Finland to Estonia in his race car, while towing his toolbox.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110242/chevrolet-c1500-pikkis-by-wheelsbywovka-33-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-33" data-attachment-id="475302" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110242/chevrolet-c1500-pikkis-by-wheelsbywovka-33.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-33/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110242/chevrolet-c1500-pikkis-by-wheelsbywovka-33-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110222/chevrolet-c1500-pikkis-by-wheelsbywovka-24-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-24" data-attachment-id="475297" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110222/chevrolet-c1500-pikkis-by-wheelsbywovka-24.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-24/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110222/chevrolet-c1500-pikkis-by-wheelsbywovka-24-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104528/chevrolet-c1500-pikkis-by-wheelsbywovka-30-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-30" data-attachment-id="475255" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104528/chevrolet-c1500-pikkis-by-wheelsbywovka-30.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-30/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104528/chevrolet-c1500-pikkis-by-wheelsbywovka-30-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110215/chevrolet-c1500-pikkis-by-wheelsbywovka-21-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-21" data-attachment-id="475295" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110215/chevrolet-c1500-pikkis-by-wheelsbywovka-21.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-21/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110215/chevrolet-c1500-pikkis-by-wheelsbywovka-21-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110136/chevrolet-c1500-pikkis-by-wheelsbywovka-7-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-7" data-attachment-id="475285" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110136/chevrolet-c1500-pikkis-by-wheelsbywovka-7.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-7/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110136/chevrolet-c1500-pikkis-by-wheelsbywovka-7-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110219/chevrolet-c1500-pikkis-by-wheelsbywovka-22-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-22" data-attachment-id="475296" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110219/chevrolet-c1500-pikkis-by-wheelsbywovka-22.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-22/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110219/chevrolet-c1500-pikkis-by-wheelsbywovka-22-1200x800.jpg"></div></li></ul><p>‘Hey mister, how much power do you have under the bonnet?’ I asked, definitely not expecting Mikko’s “1,800hp” reply. We all know people who street drive their race cars, but this is a whole different level altogether.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104742/chevrolet-c1500-pikkis-by-wheelsbywovka-41.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104742/chevrolet-c1500-pikkis-by-wheelsbywovka-41-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-41" data-attachment-id="475260" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104742/chevrolet-c1500-pikkis-by-wheelsbywovka-41.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-41/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104742/chevrolet-c1500-pikkis-by-wheelsbywovka-41-1200x800.jpg"></a></figure><p>Mikko has owned the truck named ‘Pikkis’ for 15 years, and over this time it’s been transformed from a nondescript pickup to a Decepticon powered by a twin-turbo Dart Little M Pro Series Chevy V8 with nitrous.</p>
<p>Eighteen hundred horsepower is no joke, and to achieve that number reliably required the right set of parts and some talent putting it together.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110251/chevrolet-c1500-pikkis-by-wheelsbywovka-39-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-39" data-attachment-id="475304" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110251/chevrolet-c1500-pikkis-by-wheelsbywovka-39.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-39/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110251/chevrolet-c1500-pikkis-by-wheelsbywovka-39-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104657/chevrolet-c1500-pikkis-by-wheelsbywovka-15-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-15" data-attachment-id="475257" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104657/chevrolet-c1500-pikkis-by-wheelsbywovka-15.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-15/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104657/chevrolet-c1500-pikkis-by-wheelsbywovka-15-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110258/chevrolet-c1500-pikkis-by-wheelsbywovka-43-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-43" data-attachment-id="475306" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110258/chevrolet-c1500-pikkis-by-wheelsbywovka-43.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-43/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110258/chevrolet-c1500-pikkis-by-wheelsbywovka-43-1200x800.jpg"></figure><p>The 388ci Dart small block is home to a forged K1 Technologies 3.750-inch crankshaft, forged 6-inch rods and forged pistons, while the heads are Air Flow Research’s Eliminator Competition 235cc race items. There’s a custom-specced cam in the mix, along with custom intake manifold and headers.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104917/chevrolet-c1500-pikkis-by-wheelsbywovka-59-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-59" data-attachment-id="475263" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104917/chevrolet-c1500-pikkis-by-wheelsbywovka-59.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-59/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104917/chevrolet-c1500-pikkis-by-wheelsbywovka-59-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104905/chevrolet-c1500-pikkis-by-wheelsbywovka-37-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-37" data-attachment-id="475261" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104905/chevrolet-c1500-pikkis-by-wheelsbywovka-37.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-37/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104905/chevrolet-c1500-pikkis-by-wheelsbywovka-37-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105450/chevrolet-c1500-pikkis-by-wheelsbywovka-48-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-48" data-attachment-id="475272" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105450/chevrolet-c1500-pikkis-by-wheelsbywovka-48.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-48/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105450/chevrolet-c1500-pikkis-by-wheelsbywovka-48-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104653/chevrolet-c1500-pikkis-by-wheelsbywovka-13-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-13" data-attachment-id="475256" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104653/chevrolet-c1500-pikkis-by-wheelsbywovka-13.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-13/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30104653/chevrolet-c1500-pikkis-by-wheelsbywovka-13-1200x800.jpg"></figure><p>The real power-making part of the equation comes with two <em>big</em> turbos – Holset HX55s – with a Nitrous Outlet 250hp fogger system on top. The whole setup is controlled by an MS3Pro ECU from AMP EFI.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105345/chevrolet-c1500-pikkis-by-wheelsbywovka-44-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-44" data-attachment-id="475268" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105345/chevrolet-c1500-pikkis-by-wheelsbywovka-44.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-44/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105345/chevrolet-c1500-pikkis-by-wheelsbywovka-44-1200x800.jpg"></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105349/chevrolet-c1500-pikkis-by-wheelsbywovka-45-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-45" data-attachment-id="475269" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105349/chevrolet-c1500-pikkis-by-wheelsbywovka-45.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-45/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105349/chevrolet-c1500-pikkis-by-wheelsbywovka-45-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105353/chevrolet-c1500-pikkis-by-wheelsbywovka-46-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-46" data-attachment-id="475270" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105353/chevrolet-c1500-pikkis-by-wheelsbywovka-46.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-46/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105353/chevrolet-c1500-pikkis-by-wheelsbywovka-46-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105422/chevrolet-c1500-pikkis-by-wheelsbywovka-57.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105422/chevrolet-c1500-pikkis-by-wheelsbywovka-57-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-57" data-attachment-id="475271" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105422/chevrolet-c1500-pikkis-by-wheelsbywovka-57.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-57/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105422/chevrolet-c1500-pikkis-by-wheelsbywovka-57-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105455/chevrolet-c1500-pikkis-by-wheelsbywovka-52-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-52" data-attachment-id="475273" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105455/chevrolet-c1500-pikkis-by-wheelsbywovka-52.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-52/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105455/chevrolet-c1500-pikkis-by-wheelsbywovka-52-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105500/chevrolet-c1500-pikkis-by-wheelsbywovka-53-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-53" data-attachment-id="475274" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105500/chevrolet-c1500-pikkis-by-wheelsbywovka-53.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-53/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105500/chevrolet-c1500-pikkis-by-wheelsbywovka-53-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105504/chevrolet-c1500-pikkis-by-wheelsbywovka-56-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-56" data-attachment-id="475275" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105504/chevrolet-c1500-pikkis-by-wheelsbywovka-56.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-56/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105504/chevrolet-c1500-pikkis-by-wheelsbywovka-56-1200x800.jpg"></div></li></ul><p>Given that Mikko drives his pickup on the street quite regularly, the interior retains some sense of comfort, including Sparco Circuit seats with SCHROTH harness belts, and even electric windows. Its true purpose is clear though – the exposed metal, the carbon fiber, the extensive roll cage, and parachute release lever on the roof all point to this.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105605/chevrolet-c1500-pikkis-by-wheelsbywovka-66.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105605/chevrolet-c1500-pikkis-by-wheelsbywovka-66-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-66" data-attachment-id="475276" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105605/chevrolet-c1500-pikkis-by-wheelsbywovka-66.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-66/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105605/chevrolet-c1500-pikkis-by-wheelsbywovka-66-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105632/chevrolet-c1500-pikkis-by-wheelsbywovka-69-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-69" data-attachment-id="475277" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105632/chevrolet-c1500-pikkis-by-wheelsbywovka-69.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-69/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105632/chevrolet-c1500-pikkis-by-wheelsbywovka-69-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105636/chevrolet-c1500-pikkis-by-wheelsbywovka-70-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-70" data-attachment-id="475278" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105636/chevrolet-c1500-pikkis-by-wheelsbywovka-70.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-70/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105636/chevrolet-c1500-pikkis-by-wheelsbywovka-70-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105641/chevrolet-c1500-pikkis-by-wheelsbywovka-71-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-71" data-attachment-id="475279" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105641/chevrolet-c1500-pikkis-by-wheelsbywovka-71.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-71/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105641/chevrolet-c1500-pikkis-by-wheelsbywovka-71-1200x800.jpg"></div></li></ul><p>Like many projects, Mikko’s Chevy build started out a little less serious than it is now. In 2015, he was running 10.1-seconds on the quarter – an impressive time for a heavy street car all the same – but with a single-digit ET so close, he just kept pushing, adding the previously mentioned Holset turbos, the TSI PL-5000 Powerglide transmission, and those fat Hoosier 33×22.5×15 tires out back.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105720/chevrolet-c1500-pikkis-by-wheelsbywovka-74.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105720/chevrolet-c1500-pikkis-by-wheelsbywovka-74-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-74" data-attachment-id="475280" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105720/chevrolet-c1500-pikkis-by-wheelsbywovka-74.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-74/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105720/chevrolet-c1500-pikkis-by-wheelsbywovka-74-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105757/chevrolet-c1500-pikkis-by-wheelsbywovka-67-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-67" data-attachment-id="475281" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105757/chevrolet-c1500-pikkis-by-wheelsbywovka-67.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-67/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105757/chevrolet-c1500-pikkis-by-wheelsbywovka-67-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105802/chevrolet-c1500-pikkis-by-wheelsbywovka-75-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-75" data-attachment-id="475282" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105802/chevrolet-c1500-pikkis-by-wheelsbywovka-75.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-75/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105802/chevrolet-c1500-pikkis-by-wheelsbywovka-75-1200x800.jpg"></div></li><li class="image-row images-3"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105806/chevrolet-c1500-pikkis-by-wheelsbywovka-72-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-72" data-attachment-id="475283" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105806/chevrolet-c1500-pikkis-by-wheelsbywovka-72.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-72/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105806/chevrolet-c1500-pikkis-by-wheelsbywovka-72-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105836/chevrolet-c1500-pikkis-by-wheelsbywovka-73.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105836/chevrolet-c1500-pikkis-by-wheelsbywovka-73-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-73" data-attachment-id="475284" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105836/chevrolet-c1500-pikkis-by-wheelsbywovka-73.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-73/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105836/chevrolet-c1500-pikkis-by-wheelsbywovka-73-1200x800.jpg"></a></figure><p>Just learning about Mikko’s build surprised me, but then he went and did his first run of the day and sent the front wheels into the air. That’s definitely something I wasn’t expecting to see happen on a dilapidated concrete runway with only a bit of PJ1 TrackBite sprayed on top.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110344/chevrolet-c1500-pikkis-by-wheelsbywovka-65-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-65" data-attachment-id="475317" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110344/chevrolet-c1500-pikkis-by-wheelsbywovka-65.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-65/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30110344/chevrolet-c1500-pikkis-by-wheelsbywovka-65-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105152/chevrolet-c1500-pikkis-by-wheelsbywovka-58-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-58" data-attachment-id="475267" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105152/chevrolet-c1500-pikkis-by-wheelsbywovka-58.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-58/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/30105152/chevrolet-c1500-pikkis-by-wheelsbywovka-58-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/29102218/chevrolet-c1500-pikkis-by-wheelsbywovka-1.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/29102218/chevrolet-c1500-pikkis-by-wheelsbywovka-1-680x453.jpg" alt="chevrolet-c1500-pikkis-by-wheelsbywovka-1" data-attachment-id="475139" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/29102218/chevrolet-c1500-pikkis-by-wheelsbywovka-1.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/chevrolet-c1500-pikkis-by-wheelsbywovka-1/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/03/29102218/chevrolet-c1500-pikkis-by-wheelsbywovka-1-1200x800.jpg"></a></figure><p>As it stands, ‘Pikkis’ has made it to the #2 spot in Finland’s domestic ‘Blacklist’ racing series for street cars, something achieved with a 8.06-second ET and a 279km/h trap speed. But Mikko isn’t going to stop here. Being so close to a 7-second time slip, his plan for the future is to make the truck even faster, all while retaining its street nature of course.</p>
<p><strong>Vladimir Ljadov</strong><br>
Instagram: <a href="https://www.instagram.com/wheelsbywovka/" target="_blank">wheelsbywovka</a><br>
because@wheelsbywovka.com<br>
www.wheelsbywovka.com</p>
<aside class="exclude-from-p"><p><a href="http://www.speedhunters.com/tag/dragracing" target="_blank"><strong>Drag Racing related stories on Speedhunters</strong></a></p>
</aside></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[16947,13069,10705,10183],"excerpt":"150","exclude":[475135]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2020/01/valiant-drag-machine-estonian-roads/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2020/01/01043255/plymouth-valiant-berg-vladimir-ljadov-28-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2020/01/valiant-drag-machine-estonian-roads/">
		
<div class="card-label tag-car-spotlight">
		<span class="light">CAR </span><span class="potent">SPOTLIGHT</span></div>
		<h2>A Valiant Drag Machine For Estonian&nbsp;Roads</h2>
		<span class="date">January 4, 2020</span>
		<span class="divider">/</span>
		<span class="comments">8 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2019/07/celebrating-american-car-culture-in-a-post-soviet-land/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/07/17124718/american-beauty-car-show-haapsalu-2019-by-wheelsbywovka-48-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2019/07/celebrating-american-car-culture-in-a-post-soviet-land/">
		
<div class="card-label category-eventcoverage">
		<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
		<h2>Celebrating American Car Culture In A Post-Soviet&nbsp;Land</h2>
		<span class="date">July 24, 2019</span>
		<span class="divider">/</span>
		<span class="comments">16 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2019/07/this-e30-bmw-doesnt-need-no-steering-wheel/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/06/24045505/stefan-kotze-speedhunters-drag-e30-067-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2019/07/this-e30-bmw-doesnt-need-no-steering-wheel/">
		
<div class="card-label category-carfeatures">
		<span class="light">CAR </span><span class="potent">FEATURE</span></div>
		<h2>This E30 BMW Doesn&#8217;t Need A Steering&nbsp;Wheel</h2>
		<span class="date">July 1, 2019</span>
		<span class="divider">/</span>
		<span class="comments">4 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title" id="comments">Comments</h4>
		<div class="de_comments">
			<div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
     data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
     data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
     data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
     data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
     data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
     data-post_id="475135"
     data-user_id="0"
     data-is_need_logged="0"
     data-lang="en"
     data-decom_comment_single_translate=" comment"
     data-decom_comment_twice_translate=" comments"
     data-decom_comment_plural_translate=" comments"
     data-multiple_vote="1"
     data-text_lang_comment_deleted='Comment deleted'
     data-text_lang_edited="Edited at"
     data-text_lang_delete="Delete"
     data-text_lang_not_zero="Field is not null"
     data-text_lang_required="This field is required."
     data-text_lang_checked="Mark one of the points"
     data-text_lang_completed="Operation completed"
     data-text_lang_items_deleted="The items have been deleted"
     data-text_lang_close="Close"
     data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform decomments-avatar-right" data-site-url="http://www.speedhunters.com">

	<div class="decomments-social-login-widget">
		 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<div class="oneall_social_login">
 <div class="oneall_social_login_label" style="margin-bottom: 3px;"><label>Connect with:</label></div>
 <div class="oneall_social_login_providers" id="oneall_social_login_providers_7775453"></div>
 <script type="text/javascript">
  var _oneall = _oneall || [];
  _oneall.push(['social_login', 'set_providers', ['facebook','google','instagram','reddit','twitter']]);
  _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&amp;': '?') + "oa_social_login_source=comments"))]);
  _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
  _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_7775453']);
 </script>
</div>	</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" action="http://www.speedhunters.com/wp-login.php" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="log" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="pwd" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input id="submit-form" type="hidden" name="submit" />
				<input type="hidden" name="redirect_to" value="" />
				<input type="hidden" id="security" name="security" value="0e56ac9c4b" /><input type="hidden" name="_wp_http_referer" value="/2020/04/1800hp-for-the-strip-and-street/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
				<div class="comment-form" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div></div>
</div>
		</div>
	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-6 small-block-grid-4 text-center"/><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="https://www.bilstein.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/09/06132215/bilstein_SH-e1536265895279.png"/></a></li><li><a href="https://uk.jvc.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/06/05102055/jvc_684-e1559755308518.gif"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.takataracingstore.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2020/04/1800hp-for-the-strip-and-street/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers & drivers with a shared passion for uncovering the world's most exciting car culture stories. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team Speedhunters</h4>			<div class="textwidget">Editor:
<em>Brad Lord</em> <br />

Editor at Large:
<em>Dino Dalle Carbonare</em><br />

Commercial Director: 
<em>Ben Chandler</em><br />

Community Manager: 
<em>Mark Riccioni</em><br />

Technical Editor: 
<em>Ryan Stewart</em><br />

Concept Artist:
<em>Khyzyl Saleem</em><br />

Senior Contributors: 
<em>Jordan Butters & Trevor Ryan</em><br />

Contributors: 
<em>Antonio Alvendia, Keiron Berndt, Mark Boxer, Ron Celestine, Cian Donnellan, Matthew Everingham, Blake Jones, Jesse Kiser, Stefan Kotze, Jordan Leist, Vladimir Ljadov, Paddy McGrath, Luke Munnell, Bryn Musselwhite, Richard Opie, Alok Paleri, Sara Ryan, Dave Thomas, Simon Woolley, Naveed Yousufzai</em><br />



</div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
<li><a href="http://www.h-c.co.jp/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/11043940/hashimoto.png" /></a></li>
<li><a href="https://sekritbrand.com"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/29111622/File-from-iOS-e1556562006726.gif" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://ghostgames.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ghost.jpg" /></a></li>
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2020 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/1/legal-notices">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><link rel='stylesheet' id='dashicons-css'  href='http://www.speedhunters.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"http:\/\/www.speedhunters.com\/wp-admin\/admin-ajax.php","redirecturl":"\/2020\/04\/1800hp-for-the-strip-and-street\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.speedhunters.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 0.902 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-04-06 18:07:55 -->

<!-- super cache -->