<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    Play By Play At Formula Drift Long Beach - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Facebook App Code -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '252792185178857',
      cookie     : true,
      xfbml      : true,
      version    : 'v2.8'
    });
    FB.AppEvents.logPageView();   
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- End Facebook App Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="All the action from the season opener at Formula Drift Long Beach"/>
<link rel="canonical" href="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Play By Play At Formula Drift Long Beach - Speedhunters" />
<meta property="og:description" content="All the action from the season opener at Formula Drift Long Beach" />
<meta property="og:url" content="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="2019" />
<meta property="article:tag" content="California" />
<meta property="article:tag" content="Chris Forsberg" />
<meta property="article:tag" content="drift" />
<meta property="article:tag" content="Drifting" />
<meta property="article:tag" content="Event" />
<meta property="article:tag" content="FD" />
<meta property="article:tag" content="FD 19" />
<meta property="article:tag" content="formula d" />
<meta property="article:tag" content="Formula Drift" />
<meta property="article:tag" content="Forrest Wang" />
<meta property="article:tag" content="Long Beach" />
<meta property="article:tag" content="Odi Bakchis" />
<meta property="article:section" content="Content" />
<meta property="article:section" content="Event Coverage" />
<meta property="article:published_time" content="2019-04-15T06:00:35+00:00" />
<meta property="article:modified_time" content="2019-04-15T02:53:58+00:00" />
<meta property="og:updated_time" content="2019-04-15T02:53:58+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191907/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-001_1713.jpg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Play By Play At Formula Drift Long&nbsp;Beach Comments Feed" href="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/feed/" />
<link rel='stylesheet' id='decomments-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background:  !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color: !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color: !important; } .decomments-gif:after{ border-left-color: !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background: !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke: !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill: !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke: !important; }
			 </style>
			<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=428595' />

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://speedhunters.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-428595 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Tealium -->
<script type="text/javascript">
var utag_data = {
}
</script>

<!-- Loading script asynchronously -->
<script type="text/javascript">
    (function(a,b,c,d){
    a='//tags.tiqcdn.com/utag/ea/speedhunterscom/prod/utag.js';
    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
    })();
</script>
<!-- End Tealium -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>
        							<dd><h4 data-section-title class="pointable"><a href"#" class="more-button">More&hellip;</a></h4></dd>
        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>
                                    <i data-section-title class="fi-arrow-down pointable more-button"></i>
                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                Play By Play At Formula Drift Long&nbsp;Beach            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-428595" class="post-428595 post type-post status-publish format-standard has-post-thumbnail hentry category-content category-eventcoverage tag-2019 tag-california tag-chrisforsberg tag-tag-drift tag-drifting tag-event tag-fd tag-fd-19 tag-tag-formulad tag-formuladrift tag-forrestwang tag-longbeach tag-odi-bakchis">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			<div class="story-meta large-12 columns">
  <div class="large-10 large-centered columns article-meta">
    <h1 class="entry-title">Play By Play At Formula Drift Long&nbsp;Beach</h1>
    <hr />
    
<div class="story-label category-eventcoverage">
	<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
    <dl>
                            <dt>By</dt>
                    <dd><a href="http://www.speedhunters.com/author/trevorryan/" title="Posts by Trevor Yale Ryan" class="url fn" rel="author">Trevor Yale Ryan</a></dd>
                    </dl>
          <hr />

          <span class="story-date">15th April 2019</span>
          <span class="story-comments">
            <i class="fi-comments"></i>
            <a class="comments-link" href="#comments">1 Comment</a>
          </span>
        </div>
      </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191907/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-001_1713.jpg" data-attachment-id="428596" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191907/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-001_1713-1200x800.jpg" alt="Play By Play At Formula Drift Long&nbsp;Beach">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><span id="chapter-unforgiving-streets" class="sh-post-chapter-break">Unforgiving Streets</span>
<p>The off season is officially over and round one of Formula Drift 2019 is in the books.</p>
<p>With a solid five months off to rebuild and upgrade, drivers showed up at the Streets of Long Beach with new looks, new cars, and refreshed bodywork sparkling in the warm Southern California sunshine. It’s awesome to see the Formula D paddock in this condition, but the fresh builds don’t last long. The looming walls of the Long Beach street circuit <em>always</em> have different ideas…</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190452/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-204_9762-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Bbaeach-Results_Trevor-Ryan-204_9762" data-attachment-id="428699" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190452/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-204_9762.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-204_9762/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190452/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-204_9762-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190459/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-206_9766-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-206_9766" data-attachment-id="428701" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190459/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-206_9766.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-206_9766/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190459/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-206_9766-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191935/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-007_1077.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191935/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-007_1077-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-007_1077" data-attachment-id="428602" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191935/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-007_1077.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-007_1077/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191935/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-007_1077-1200x800.jpg"></a></figure><p>From the sidelines this course just seems harsh for the first round. New faces, fresh suspension setups and tweaks in power delivery paired with an 80mph entry into the first corner, a sharp, tight and technical right-hander with rock-solid k-walls looming on either side. Even on day one the barriers claimed a few casualties — both major and minor — in Long Beach, a trend that continued throughout the weekend at each clipping zone.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191922/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-004_0903.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191922/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-004_0903-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-004_0903" data-attachment-id="428599" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191922/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-004_0903.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-004_0903/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191922/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-004_0903-1200x800.jpg"></a></figure><p>Ryan Tuerck had a particularly bad wreck during practice before competition on Saturday; it was no real error of his own, but rather a failed power steering pump that sent him straight into the a tire wall at good speed. Ryan was shaken up but ultimately okay, although word is that one of the strut towers in the car is about a foot out of place.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190456/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-205_9706.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190456/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-205_9706-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-205_9706" data-attachment-id="428700" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190456/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-205_9706.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-205_9706/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190456/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-205_9706-1200x800.jpg"></a></figure><p>I don’t have any shots of the damage or details on what the team will do next, but Keiron will be back soon with a story detailing Tuerck’s weekend which started out with a very promising 96 in qualifying.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191912/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-002_0864.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191912/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-002_0864-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-002_0864" data-attachment-id="428597" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191912/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-002_0864.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-002_0864/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191912/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-002_0864-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191954/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-010_1182-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-010_1182" data-attachment-id="428605" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191954/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-010_1182.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-010_1182/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191954/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-010_1182-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192031/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-017_0643-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-017_0643" data-attachment-id="428612" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192031/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-017_0643.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-017_0643/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192031/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-017_0643-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192238/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-043_0271-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-043_0271" data-attachment-id="428638" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192238/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-043_0271.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-043_0271/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192238/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-043_0271-1200x800.jpg"></figure><p>It certainly wasn’t all bad, though, and there was <em>plenty</em> to get excited about over the weekend in Long Beach. Honestly, it’s a bit hard not to be excited with pro-level cars screaming away as they flirt with danger just inches from the walls, so, what actually happened over the course of the main event on Saturday?</p>
<span id="chapter-battle-mode" class="sh-post-chapter-break">Battle Mode</span>
<p>With a full bracket of qualifying drivers there were no planned bye runs in the Top 32 (although Ryan Litteral did end up flying solo after Tuerck wasn’t able to compete), so let’s jump straight into the battles.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192000/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-011_1194-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-011_1194" data-attachment-id="428606" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192000/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-011_1194.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-011_1194/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192000/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-011_1194-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191940/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-008_1152-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-008_1152" data-attachment-id="428603" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191940/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-008_1152.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-008_1152/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191940/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-008_1152-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192242/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-044_0369.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192242/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-044_0369-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-044_0369" data-attachment-id="428639" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192242/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-044_0369.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-044_0369/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192242/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-044_0369-1200x800.jpg"></a></figure><p>It’s notable that in all but two match-ups in the Top 32 the higher seeded driver won, and only one first-time driver to the series made it out of the first round of competition. The biggest upset was when Travis Reeder’s solid lead and follow runs were enough to take down Alex Heilbrunn when Heilbrunn spun out before the last inner zone as he was trailing Reeder. Reeder had qualified 19th, with Heilbrunn just a few places up in 14th.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192103/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-023_0706.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192103/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-023_0706-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-023_0706" data-attachment-id="428618" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192103/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-023_0706.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-023_0706/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192103/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-023_0706-1200x800.jpg"></a></figure><p>Dean Kearney, who bracketed in 18th, also managed to topple Jhonnattan Castro who was seeded 15th. There wasn’t much in the way of an upset, though, and as expected all of the top qualifiers were looking solid and confident in the early rounds.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192042/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-019_0659-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-019_0659" data-attachment-id="428614" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192042/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-019_0659.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-019_0659/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192042/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-019_0659-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192049/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-020_0668-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-020_0668" data-attachment-id="428615" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192049/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-020_0668.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-020_0668/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192049/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-020_0668-1200x800.jpg"></div></li></ul><p>During the Ford Top 16 none of these three drivers who snuck in on upsets or bad luck moved on. Fredric Aasbø handily dispatched Litteral and Piotr Więcek cleanly took down Reeder.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192038/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-018_1592.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192038/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-018_1592-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-018_1592" data-attachment-id="428613" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192038/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-018_1592.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-018_1592/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192038/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-018_1592-1200x800.jpg"></a></figure><p>In the battle of the Irishmen, Dean Kearney fought valiantly with a nearly perfect follow, capitalizing on what seemed to be a rare mistake from James Deane. However, replays showed that Deane’s hesitation in transition was caused by contact from Kearney, which ultimately resulted in Kearney calling a competition timeout. The car was running hot — really hot — but when Kearney made it back to the line a big wall tap allowed Deane to stay right on his door.</p>
<p>Out of the three judges Ryan Lanteigne was the only one who called for a OMT, with Andy Yen and Brian Eggert opting for Deane to continue on.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192021/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-015_0603-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-015_0603" data-attachment-id="428610" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192021/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-015_0603.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-015_0603/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192021/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-015_0603-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192025/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-016_0612-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-016_0612" data-attachment-id="428611" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192025/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-016_0612.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-016_0612/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192025/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-016_0612-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192016/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-014_0586-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-014_0586" data-attachment-id="428609" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192016/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-014_0586.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-014_0586/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192016/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-014_0586-1200x800.jpg"></figure><p>One of the most exciting runs of the Top 16 was when Chelsea DeNofa initiated on the door of Chris Forsberg’s car. It looked incredible, but the judges didn’t seem to favor the technique as much as the fans did and Forsberg moved on.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191917/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-003_0893-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-003_0893" data-attachment-id="428598" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191917/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-003_0893.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-003_0893/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191917/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-003_0893-1200x800.jpg"></figure><p>I’m not sure of the specifics of this rule, but apparently DeNofa would have been better off following Forsberg on his rear bumper rather than higher up on the car. It seems a little counterintuitive to me, especially as door-to-door action is always a bit more exciting to watch and harder to execute. But ultimately the judges seemed to feel that (at least on initiation) an aggressive line like this interferes with the lead driver’s ability to run their own line.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13191851/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-400_3702.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13191851/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-400_3702-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-400_3702" data-attachment-id="428706" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13191851/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-400_3702.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-400_3702/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13191851/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-400_3702-1200x800.jpg"></a></figure><p>While it’s easy to criticize from the sidelines, it’s also important to remember that the fans and media members alike don’t know exactly what’s covered in the daily drivers meetings. The drivers (should) leave knowing exactly what the judges are looking for at each round, and need to tweak their driving to accommodate.</p>
<span id="chapter-eight-men-standing" class="sh-post-chapter-break">Eight Men Standing</span>
<p>Into the Great 8 we went, and I was looking forward to all four match-ups.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192053/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-021_0686.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192053/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-021_0686-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-021_0686" data-attachment-id="428616" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192053/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-021_0686.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-021_0686/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192053/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-021_0686-1200x800.jpg"></a></figure><p>First up was Matt Field against Chris Forsberg, with Forsberg as the chase driver. Forsberg stayed right on Field through the first two outer zones but entering the final hairpin on the course Field was able to put a few car lengths between the pair.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192058/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-022_0687-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-022_0687" data-attachment-id="428617" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192058/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-022_0687.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-022_0687/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192058/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-022_0687-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190443/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-202_0088-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-202_0088" data-attachment-id="428697" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190443/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-202_0088.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-202_0088/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190443/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-202_0088-1200x800.jpg"></div></li></ul><p>A victory seemed inevitable for Matt but, unfortunately for the <a href="http://www.speedhunters.com/2019/04/formula-drift-prep-at-matt-fields-drift-cave/" target="_blank">Drift Cave boys</a>, Field had trouble transitioning between the first and second clipping points, narrowly missing the tire wall that Tuerck tested out earlier in the day. Matt’s mistake wasn’t unlike one that Forsberg made earlier in the weekend, but Forsberg was able to lay down a good line when it mattered.</p>
<p>The pressure on these drivers really is intense — you only have one shot each round and the smallest mistake can cost you the win.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192148/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-032_0743.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192148/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-032_0743-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-032_0743" data-attachment-id="428627" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192148/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-032_0743.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-032_0743/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192148/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-032_0743-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192118/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-026_1619-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-026_1619" data-attachment-id="428621" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192118/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-026_1619.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-026_1619/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192118/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-026_1619-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192108/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-024_1604-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-024_1604" data-attachment-id="428619" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192108/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-024_1604.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-024_1604/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192108/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-024_1604-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192114/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-025_1607.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192114/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-025_1607-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-025_1607" data-attachment-id="428620" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192114/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-025_1607.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-025_1607/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192114/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-025_1607-1200x800.jpg"></a></figure><p>Odi Bakchis and Justin Pawlak had a Falken-Falken showdown which required not one but two additional OMT battles. Finally, after six runs through the streets of Long Beach, Bakchis emerged as the victor after JTP went too deep into the first corner, making contact and losing angle. Bakchis, meanwhile, seemed more and more consistent, smoothly flowing ever closer to the walls of Long Beach as each round progressed.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192005/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-012_1202-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-012_1202" data-attachment-id="428607" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192005/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-012_1202.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-012_1202/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192005/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-012_1202-1200x800.jpg"></figure><p>Another great battle was the S15 versus S15 match-up between Więcek and Forrest Wang. Piotr was leading for the first run but wasn’t able to shake Forrest; switching places Forrest struck back with a much better line on his lead run and looked poised to move on. Indeed, the judges unanimously voted in Forrest’s favor, a decision the crowd seemed to like quite a lot.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192139/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-030_1644.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192139/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-030_1644-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-030_1644" data-attachment-id="428625" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192139/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-030_1644.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-030_1644/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192139/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-030_1644-1200x800.jpg"></a></figure><p>Everyone was excited for the match-up between Fredric Aasbø and James Deane, but unfortunately Deane was struggling with some issues with his nitrous oxide setup which forced the team to run without it altogether.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192143/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-031_1652-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-031_1652" data-attachment-id="428626" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192143/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-031_1652.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-031_1652/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192143/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-031_1652-1200x800.jpg"></figure><p>I wasn’t able to get the details on Worthouse’s rare problem with their car, but Aasbø took the (relatively) easy win, saying after the fact that it hardly counted — “I hope we can have a more square match next time.” I’ll definitely be looking forward to that, too, especially with last year’s championship coming down to a handful of points between these two drivers.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192257/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-047_4599-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-047_4599" data-attachment-id="428642" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192257/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-047_4599.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-047_4599/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192257/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-047_4599-1200x800.jpg"></figure><p>As the field thinned out, the rounds went by more and more quickly and suddenly there were just two match-ups left: Fredric Aasbø and Forrest Wang would go head to head, as would Chris Forsberg and Odi Bakchis.</p>
<p>Any one of these guys was as good of a bet as the next for the top spot on the podium. Coming into the new season, Forsberg has three FD US championship titles and Aasbø has one; Bakchis has three previous wins and nine podiums to his name, and — although he hadn’t yet found himself on the top step of the podium in the series — Forrest Wang is, well, Forrest Wang.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192301/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-048_4638-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-048_4638" data-attachment-id="428643" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192301/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-048_4638.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-048_4638/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192301/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-048_4638-1200x800.jpg"></figure><p>First up was Wang versus Aasbø, and a certain smell lingered in the air after their first run; maybe it was my imagination, or maybe it really was the faint scent of burnt oil. Aasbø and the Papadakis Racing team opted not to continue on, citing bits of a spark plug showing up in the turbo.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192123/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-027_1634-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-027_1634" data-attachment-id="428622" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192123/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-027_1634.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-027_1634/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192123/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-027_1634-1200x800.jpg"></figure><p>Forrest enjoyed going all-out on a bye run and prepared himself for the final.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191926/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-005_0944.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191926/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-005_0944-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-005_0944" data-attachment-id="428600" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191926/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-005_0944.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-005_0944/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191926/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-005_0944-1200x800.jpg"></a></figure><p>When it was time for Bakchis to lead Forsberg, it seemed that Forsberg wasn’t quite able to keep up through the beginning of the course but quickly closed the gap into the last clipping point. Bakchis, on the other hand, stuck right to Forsberg’s door throughout the entire second run and advanced cleanly.</p>
<span id="chapter-the-final-battle" class="sh-post-chapter-break">The Final Battle</span>
<p>Now, it was down to two men: Wang in his S15 and Bakchis his S14. Both S-chassis pulled up to the line for the last battle of the event, with Forrest saying that he hoped “today is the day.”</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192206/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-036_0807.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192206/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-036_0807-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-036_0807" data-attachment-id="428631" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192206/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-036_0807.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-036_0807/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192206/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-036_0807-1200x800.jpg"></a></figure><p>Bakchis laid down a sensational lead run, with Wang getting a little loose in the background. If Wang would want to win the battle, he’d <em>really</em> need to pull out all the stops for his lead run.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192202/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-035_1704.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192202/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-035_1704-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-035_1704" data-attachment-id="428630" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192202/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-035_1704.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-035_1704/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192202/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-035_1704-1200x800.jpg"></a></figure><p>As the pair rolled back to the start and rounded the turns of the Streets of Long Beach I realized that deep down I was pulling for Forrest to get his first win in Formula D.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190422/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-103_0798-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-103_0798" data-attachment-id="428692" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190422/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-103_0798.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-103_0798/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190422/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-103_0798-1200x800.jpg"></figure><p>I generally try to remain unbiased when it comes to looking at what happens during any race weekend, but it’s in these do-or-die moments that you realize where your heart really lies.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190422/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-103_0798.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192310/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-050_4681-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-050_4681" data-attachment-id="428645" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192310/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-050_4681.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-050_4681/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192310/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-050_4681-1200x800.jpg"></a></figure><p>Both runs over, the drivers pulled in front of the crowd for the winner to be announced. But I was already pretty certain it would be Bakchis — as you can see his follow run was tight and tidy.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192210/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-037_1747.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192210/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-037_1747-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-037_1747" data-attachment-id="428632" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192210/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-037_1747.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-037_1747/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192210/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-037_1747-1200x800.jpg"></a></figure><p>I wasn’t wrong and, although Wang couldn’t pull it off, I was completely stoked for Odi, who is <em>also</em> still celebrating from the fact that he and his wife welcomed a new baby to their family just two weeks ago.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192153/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-033_0771.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192153/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-033_0771-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-033_0771" data-attachment-id="428628" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192153/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-033_0771.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-033_0771/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192153/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-033_0771-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192128/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-028_0731-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-028_0731" data-attachment-id="428623" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192128/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-028_0731.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-028_0731/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192128/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-028_0731-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192133/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-029_0736-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-029_0736" data-attachment-id="428624" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192133/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-029_0736.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-029_0736/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192133/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-029_0736-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192220/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-039_1810.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192220/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-039_1810-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-039_1810" data-attachment-id="428634" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192220/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-039_1810.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-039_1810/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192220/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-039_1810-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192225/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-040_1843-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-040_1843" data-attachment-id="428635" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192225/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-040_1843.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-040_1843/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192225/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-040_1843-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192230/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-041_1847-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-041_1847" data-attachment-id="428636" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192230/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-041_1847.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-041_1847/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192230/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-041_1847-1200x800.jpg"></div></li></ul><p>Bakchis’ victory was definitely well deserved as he drove near flawlessly all weekend without any major hiccups. The podium was rounded off with Forrest Wang and Chris Forsberg, and as the champagne sprayed it was time for a bit of reflection.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192157/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-034_1683.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192157/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-034_1683-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-034_1683" data-attachment-id="428629" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192157/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-034_1683.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-034_1683/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192157/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-034_1683-1200x800.jpg"></a></figure><p>From the sidelines — and even from just a few feet away from the burning rubber on track and the chaos in the pits — it’s often hard to see these drivers and teams as ordinary people. What they’re accomplishing in this sport is special, and the lengths they go to achieve it are truly inspiring.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190502/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-300_9720.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190502/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-300_9720-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-300_9720" data-attachment-id="428702" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190502/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-300_9720.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-300_9720/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190502/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-300_9720-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190409/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-100_1448-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-100_1448" data-attachment-id="428689" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190409/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-100_1448.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-100_1448/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190409/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-100_1448-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192010/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-013_4463-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-013_4463" data-attachment-id="428608" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192010/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-013_4463.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-013_4463/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192010/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-013_4463-1200x800.jpg"></div></li></ul><figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192216/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-038_1792-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-038_1792" data-attachment-id="428633" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192216/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-038_1792.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-038_1792/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192216/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-038_1792-1200x800.jpg"></figure><p>As much as Formula Drift is about the wild 1,000hp monsters that lurk around the paddock, at the same time it’s this personal, human element that really makes the sport worth watching over and over. Knowing these guys are doing something you just can’t <em>quite</em> makes it all the more fun.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192252/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-046_0508-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-046_0508" data-attachment-id="428641" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192252/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-046_0508.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-046_0508/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12192252/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-046_0508-1200x800.jpg"></figure><p>With both of the Worthouse boys out early and the points properly mixed up when compared to last year’s results, it’s definitely the start of interesting season.</p>
<p>Who’s to say what’ll happen next — I know I can’t wait for the next round.</p>
<p><strong>Trevor Yale Ryan<br></strong>trevor@speedhunters.com<br>
Instagram: <a href="http://www.instagram.com/tyrphoto/" target="_blank">tyrphoto<br></a>TYRphoto.com</p>
<p>Additional Photos by <strong>Sara Ryan</strong><br>
Instagram: <a href="https://www.instagram.com/pockowokosara/">pockowokosara</a></p>
<aside class="exclude-from-p"><p><a href="http://www.speedhunters.com/tag/formuladrift/" target="_blank"><strong>Formula Drift on Speedhunters</strong></a></p>
</aside><span id="chapter-cutting-room-floor" class="sh-post-chapter-break">Cutting Room Floor</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190413/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-101_4329.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190413/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-101_4329-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-101_4329" data-attachment-id="428690" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190413/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-101_4329.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-101_4329/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190413/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-101_4329-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190417/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-102_1698.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190417/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-102_1698-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-102_1698" data-attachment-id="428691" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190417/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-102_1698.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-102_1698/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190417/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-102_1698-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190426/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-104_0802.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190426/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-104_0802-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-104_0802" data-attachment-id="428693" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190426/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-104_0802.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-104_0802/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190426/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-104_0802-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190431/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-105_0812.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190431/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-105_0812-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-105_0812" data-attachment-id="428694" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190431/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-105_0812.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-105_0812/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190431/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-105_0812-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190434/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-200_0624.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190434/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-200_0624-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-200_0624" data-attachment-id="428695" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190434/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-200_0624.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-200_0624/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190434/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-200_0624-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190439/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-201_1563.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190439/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-201_1563-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-201_1563" data-attachment-id="428696" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190439/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-201_1563.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-201_1563/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190439/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-201_1563-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190447/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-203_0263.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190447/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-203_0263-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-203_0263" data-attachment-id="428698" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190447/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-203_0263.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-203_0263/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190447/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-203_0263-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190506/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-301_9662.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190506/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-301_9662-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-301_9662" data-attachment-id="428703" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190506/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-301_9662.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-301_9662/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13190506/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-301_9662-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191944/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-009_1162.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191944/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-009_1162-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-009_1162" data-attachment-id="428604" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191944/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-009_1162.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-009_1162/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/12191944/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-009_1162-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13192720/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-302_03901.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13192720/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-302_03901-680x453.jpg" alt="2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-302_0390" data-attachment-id="428707" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13192720/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-302_03901.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/2018-speedhunters_formula-drift-long-beach-results_trevor-ryan-302_0390-2/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/13192720/2018-Speedhunters_Formula-Drift-Long-Beach-Results_Trevor-Ryan-302_03901-1200x800.jpg"></a></figure></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[16379,1347,15815,715],"excerpt":"150","exclude":[428595]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2019/04/racewars-human-element/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/03/30061235/Racewars19_Everingham_Speedhunters_-4881-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2019/04/racewars-human-element/">
		
<div class="card-label category-eventcoverage">
		<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
		<h2>Racewars: The Human&nbsp;Element</h2>
		<span class="date">April 9, 2019</span>
		<span class="divider">/</span>
		<span class="comments">26 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2019/04/formula-drift-qualifying-sideways-on-the-streets-of-long-beach/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/04/07220222/2018-Speedhunters_Formula-Drift-Long-Beach-Qualifying_Trevor-Ryan-001_9779-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2019/04/formula-drift-qualifying-sideways-on-the-streets-of-long-beach/">
		
<div class="card-label category-eventcoverage">
		<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
		<h2>Sideways On The Streets Of Long&nbsp;Beach</h2>
		<span class="date">April 8, 2019</span>
		<span class="divider">/</span>
		<span class="comments">9 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2019/04/editorial-are-you-paying-attention/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/03/27160144/2018-Speedhunters_GC-Subaru-Track-Car_Trevor-Ryan-059_6829-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2019/04/editorial-are-you-paying-attention/">
		
<div class="card-label category-news">
		<span class="potent">NEWS</span></div>
		<h2>Editorial: Are You Paying&nbsp;Attention?</h2>
		<span class="date">April 1, 2019</span>
		<span class="divider">/</span>
		<span class="comments">78 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title" id="comments">Comments</h4>
		<div class="de_comments">
			<div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
     data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
     data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
     data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
     data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
     data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
     data-post_id="428595"
     data-user_id="0"
     data-is_need_logged="0"
     data-lang="en"
     data-decom_comment_single_translate=" comment"
     data-decom_comment_twice_translate=" comments"
     data-decom_comment_plural_translate=" comments"
     data-multiple_vote="1"
     data-text_lang_comment_deleted='Comment deleted'
     data-text_lang_edited="Edited at"
     data-text_lang_delete="Delete"
     data-text_lang_not_zero="Field is not null"
     data-text_lang_required="This field is required."
     data-text_lang_checked="Mark one of the points"
     data-text_lang_completed="Operation completed"
     data-text_lang_items_deleted="The items have been deleted"
     data-text_lang_close="Close"
     data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform decomments-avatar-right" data-site-url="http://www.speedhunters.com">

	<div class="decomments-social-login-widget">
		 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<div class="oneall_social_login">
 <div class="oneall_social_login_label" style="margin-bottom: 3px;"><label>Connect with:</label></div>
 <div class="oneall_social_login_providers" id="oneall_social_login_providers_3110489"></div>
 <script type="text/javascript">
  var _oneall = _oneall || [];
  _oneall.push(['social_login', 'set_providers', ['facebook','google','instagram','reddit','twitter']]);
  _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&amp;': '?') + "oa_social_login_source=comments"))]);
  _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
  _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_3110489']);
 </script>
</div>	</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" action="http://www.speedhunters.com/wp-login.php" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="log" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="pwd" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input id="submit-form" type="hidden" name="submit" />
				<input type="hidden" name="redirect_to" value="" />
				<input type="hidden" id="security" name="security" value="3dda05c0e8" /><input type="hidden" name="_wp_http_referer" value="/2019/04/play-by-play-at-formula-drift-long-beach/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
				<div class="comment-form" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>
		<div class="decomments-head">

			<h3><i><span class="decomments-comments-number decomments-block">1</span><span class="decomments-comment-title"> comment</span></i></h3>			<form class=" decom_comments_sort decomments-comment-sort" action="#comments" method="post" >
				<label>Sort:</label>
				<dl class="de-select de-select-filter">
					<dt>by Oldest</dt>
					<dd name="decom_comments_sort" class="decomments-select">
						<a onclick="decom.sortComments(this)"  href="#" data-sort="rate">
							<i class="decomments-icon-thumb-down"></i> by Best						</a>
						<a onclick="decom.sortComments(this)"  href="#" data-sort="newer">
							<i class="decomments-icon-thumb-down"></i> by Newest						</a>
						<a onclick="decom.sortComments(this)" class="current" href="#" data-sort="older" selected='selected'>
							<i class="decomments-icon-thumb-down"></i> by Oldest						</a>
					</dd>
				</dl>
			</form>
		</div>
		<div class="decomments-comment-list decomments-avatar-right" style="min-height: 250px;">
			<div class="loader-ball-scale lbs-remove">
				<div></div>
				<div></div>
				<div></div>
			</div>
			<div class="comment even thread-even depth-1 decomments-comment-block" id="comment-1607353" parent-id="0" >
                 <div  style="padding-left: 55px;" class="decomments-comment-body"> <figure style="width:40px; height:40px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='http://1.gravatar.com/avatar/b500e7c1e7e8024cc74cf18304176f0c?s=40&amp;d=http%3A%2F%2Fspeedhunters-wp-production.s3.amazonaws.com%2Fwp-content%2Fuploads%2F2017%2F02%2F08110535%2Fcharacter-circle1.png%3Fs%3D40&amp;r=R' class='avatar avatar-40 photo' height='40' width='40' /></span>
                     	<figcaption data-cui="0" data-pai="883""><a href="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/#comment-1607353" class="decomments-number"><span>1</span></a></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/#comment-1607353" class="decomments-date-link">
				
			<time datetime="7:30 am April 15, 2019">7:30 am<i>April 15, 2019</i></time>			</a>
			<span class="decomments-autor-name">@__kvnhhn_</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-1607353"><p>Great hero image Trevor <img src="http://www.speedhunters.com/wp-includes/images/smilies/icon_smile.gif" alt=":)" class="wp-smiley" /></p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-1607353"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a>

                                <span class="decomments-share-block decom-share">
                                    <ins><i class="decomments-icon-share"></i>Share</ins>
                                    <span><a href="#" class="decomments-tw-link"><i class="decomments-icon-twitter"></i></a><a href="#" class="decomments-fb-link"><i class="decomments-icon-facebook"></i></a><a href="#" class="decomments-gp-link"><i class="decomments-icon-googleplus"></i></a></span>
                                </span>
                    </nav>
                     </div>
                 </div></div>		</div><!-- .commentlist -->
		</div>
</div>
		</div>
	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-8 small-block-grid-4 text-center"/><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="http://www.fueloffroad.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041516/fuel.png"/></a></li><li><a href="https://www.bilstein.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2018/09/06132215/bilstein_SH-e1536265895279.png"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.rotiform.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041517/rotiform.png"/></a></li><li><a href="http://www.takataracingstore.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li><li><a href="https://www.snapon.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2019/02/19043240/Snap-on_Logo85.gif"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2019/04/play-by-play-at-formula-drift-long-beach/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers & drivers with a shared passion for uncovering the world's most exciting car culture stories. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team Speedhunters</h4>			<div class="textwidget">Editor in Chief:
<em>Paddy McGrath</em> <br />

Senior Editor:
<em>Brad Lord</em> <br />

Editor at Large:
<em>Dino Dalle Carbonare</em><br />

Commercial Director: 
<em>Ben Chandler</em><br />

Community Manager: 
<em>Mark Riccioni</em><br />

Technical Editor: 
<em>Ryan Stewart</em><br />

Concept Artist:
<em>Khyzyl Saleem</em><br />

Senior Contributors: 
<em>Jordan Butters & Trevor Ryan</em><br />

Contributors: 
<em>Antonio Alvendia, Keiron Berndt, Mark Boxer, Ron Celestine, Cian Donnellan, Matthew Everingham, Blake Jones, Jesse Kiser, Stefan Kotze, Jordan Leist, Vladimir Ljadov, Luke Munnell, Bryn Musselwhite, Richard Opie, Alok Paleri, Sara Ryan, Dave Thomas, Simon Woolley, Naveed Yousufzai</em><br />



</div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.kleerfreight.com/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/23044303/kleerfreight-logo.png" /></a></li>
<li><a href="http://www.h-c.co.jp/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/04/11043940/hashimoto.png" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://ghostgames.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ghost.jpg" /></a></li>
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2019 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/1/legal-notices">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><link rel='stylesheet' id='dashicons-css'  href='http://www.speedhunters.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"http:\/\/www.speedhunters.com\/wp-admin\/admin-ajax.php","redirecturl":"\/2019\/04\/play-by-play-at-formula-drift-long-beach\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.speedhunters.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/thickbox/thickbox.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 0.901 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-04-15 07:34:35 -->

<!-- super cache -->