<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1" />
<meta name="apple-mobile-web-app-capable" content="yes">
<title>
    Through My Lens: Race Of Champions Miami - Speedhunters</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.speedhunters.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/javascripts/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="shortcut icon" type="image/ico" href="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/favicon.ico" />

<!-- Doubleclick Ad Management -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/149287551/Sitewide_Leaderboard', [728, 90], 'div-gpt-ad-1352995576035-0').addService(googletag.pubads());
googletag.defineSlot('/149287551/Inline_MPU', [770, 513], 'div-gpt-ad-1401958887607-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1037728282936046');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1037728282936046&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Through My Lens: Race Of Champions Miami - Speedhunters" />
<meta property="og:description" content="Even before I started photographing professional racing I knew about Race Of Champions (ROC); the event was so ahead of its time in terms of media and putting out cool videos in pre-YouTube days. I can specifically remember watching one ROC back in 2006 and being amazed by the way the stadium had been transformed into a &hellip;" />
<meta property="og:url" content="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/" />
<meta property="og:site_name" content="Speedhunters" />
<meta property="article:tag" content="Miami" />
<meta property="article:tag" content="Race Of Champions" />
<meta property="article:tag" content="roc" />
<meta property="article:tag" content="USA" />
<meta property="article:section" content="Content" />
<meta property="article:section" content="Event Coverage" />
<meta property="article:published_time" content="2017-02-02T01:00:47+00:00" />
<meta property="article:modified_time" content="2017-02-02T01:22:08+00:00" />
<meta property="og:updated_time" content="2017-02-02T01:22:08+00:00" />
<meta property="og:image" content="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185429/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_01.jpg" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Feed" href="http://www.speedhunters.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Comments Feed" href="http://www.speedhunters.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Speedhunters &raquo; Through My Lens: Race Of Champions&nbsp;Miami Comments Feed" href="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/feed/" />
<link rel='stylesheet' id='frontend_css-css'  href='http://www.speedhunters.com/wp-content/plugins/simply-polls/css/alex_frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='speedhunters_XIII-style-css'  href='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/style.css' type='text/css' media='all' />
<script type='text/javascript' src='http://zor.livefyre.com/wjs/v3.0/javascripts/livefyre.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='shortlink' href='http://www.speedhunters.com/?p=312852' />

<script
        type="text/javascript"
        src="http://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js">
</script>

</head>

<body class="single single-post postid-312852 single-format-standard">

    <!-- 3rd PARTY APIS -->

<!-- Add Tealium -->
<script type="text/javascript">
var utag_data = {
}
</script>

<!-- Loading script asynchronously -->
<script type="text/javascript">
    (function(a,b,c,d){
    a='//tags.tiqcdn.com/utag/ea/speedhunterscom/prod/utag.js';
    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
    })();
</script>
<!-- End Tealium -->

<!-- Add Facebook JavaScript SDK -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=160417550742798";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- End Facebook JavaScript SDK -->

<!-- END 3rd PARTY APIS -->
    
<div id="fs-story" class="swiper-container">
  <div class="swiper-wrapper">
	    </div>
</div>

		<header id="header" class="row" role="banner">
		<div class="screen-reader-text skip-link hide"><a href="#content" title="Skip to content">Skip to content</a></div>
        <section class="top-nav columns">
        		<div class="section-container">
        			<section>
                		<div class="row branding">
                        	<div class="medium-4 columns logo">
                        		<h1><a href="http://www.speedhunters.com"><img src="http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/images/branding/sh-logo-white.png"></a></h1>
                            <div id="slogan"></div>
                        	</div>
                        	<div class="medium-8 columns leaderboard">
                                <!-- Sitewide_Leaderboard -->
                                <div id="leaderboardBanner">
                                    <div id='div-gpt-ad-1352995576035-0' style='width:728px; height:90px;'>
                                    <script type='text/javascript'>
                                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1352995576035-0'); });
                                    </script>
                                    </div>
                                </div>
                                <!-- END Sitewide_Leaderboard -->
                        	</div>
                        </div>

        				<div class="menu-strip row">
        					<div class="medium-8 columns menu-left">
        						<dl class="sub-nav">
        							<dd class="active"><h4><a href="http://www.speedhunters.com">HOME</a></h4></dd>
        							<dd class="nav-breadcrumbs">/<a rel="v:url" property="v:title" href="http://www.speedhunters.com/category/content/">Content</a></dd>        							<dd><h4><a href="http://store.speedhunters.com" target="_blank">Store</a></h4></dd>
        							<dd><h4 data-section-title class="pointable"><a href"#" class="more-button">More&hellip;</a></h4></dd>
        						</dl>
        					</div>
        					<div class="medium-4 columns menu-right">
                                	<form method="get" id="searchform" class="searchform" action="http://www.speedhunters.com/" role="search">
		<input type="text" name="s" value="" id="s" placeholder="Search?" />
		<i class="fi-magnifying-glass pointable"></i>
		<button type="submit" class="submit button prefix" id="searchsubmit" value="" >Site Search</button>
	</form>
                                <span class="small-nav-icons">
                                    <span class="separator"></span>
                                    <a href="http://store.speedhunters.com" target="_blank"><i class="fi-shopping-cart"></i></a>
                                    <span class="separator"></span>
                                    <i data-section-title class="fi-arrow-down pointable more-button"></i>
                                </span>
                            </div>
        				</div>
					<nav id="site-navigation" class="content row menu-base" role="navigation" data-section-content style="display:none">
	<dl class="top-level large-12 columns">
<dd class="divider"></dd><dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/carfeatures/">Car&nbsp;Features</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-spotlight/">Modified</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag&nbsp;Racing</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retro/">Retro</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/stance/">Stance</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/vip-tag/">VIP</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/racing/">Performance</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/classic/">Classic</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/grandtouring/">Grand&nbsp;Touring</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/hothatch/">Hot&nbsp;Hatch</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-race/">Race</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sportcompact/">Sport&nbsp;Compact</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supercar/">Supercar</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/supersaloon/">Super&nbsp;Saloon</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/hotrodding/">Hot&nbsp;Rodding</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-muscle/">Muscle</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Hot&nbsp;Rod</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-leadsled/">Lead&nbsp;Sled</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-sleeper/">Sleeper</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/low-rider/">Low&nbsp;Rider</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gasser/">Gasser</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragster/">Dragster</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.speedhunters.com/category/eventcoverage/">Event&nbsp;Coverage</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drifting/">Drift</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/formuladrift/">Formula&nbsp;Drift</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-d1gp/">D1GP</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-gatebil/">Gatebil</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-grassroots/">Grass&nbsp;Roots</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/motorsport/">Motorsports</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-formulaone/">Formula&nbsp;One</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/rally/">Rally</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/endurance/">Endurance-GTs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/timeattack/">Time&nbsp;Attack</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/landspeed/">Land&nbsp;Speed</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/touringcar/">Touring&nbsp;Cars</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hillclimb/">Hill&nbsp;Climb</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dragracing/">Drag</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/oval/">Oval</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/car-show-tag/">Shows +&nbsp;Festivals</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tokyoautosalon/">Tokyo Auto&nbsp;Salon</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/sema/">Sema</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-meets/">Meets</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-hotrod/">Rods &#038;&nbsp;Customs</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dubscene/">Dub&nbsp;Scene</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a title="Speedhunters Crew" href="http://www.speedhunters.com/category/speedhunterscrew/">Speedhunters&nbsp;Crew</a>
<dl class="sub-menu dropdown">
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/drivers/">Drivers</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/fredricaasbo/">Fredric&nbsp;Aasbø</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-vaughngittinjr/">Vaughn Gittin&nbsp;Jr</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-edwardsandstrom/">Edward&nbsp;Sandström</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-madmikewhiddett/">Mad Mike&nbsp;Whiddett</a></dd>
	</dl>
</dd>
	<dd class="has-dropdown level-1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">Photojournalists</a>
	<dl class="sub-sub-menu dropdown">
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/alok-paleri/">Alok&nbsp;Paleri</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281434115/">Dino Dalle&nbsp;Carbonare</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2307185532/">Larry&nbsp;Chen</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262174102/">Rod&nbsp;Chong</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2262173266">Mike&nbsp;Garrett</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/sklingelhoefer/">Sean&nbsp;Klingelhoefer</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blord/">Brad&nbsp;Lord</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2279972671/">Paddy&nbsp;McGrath</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/2281433439/">Jonathan&nbsp;Moore</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/bmusselwhite/">Bryn&nbsp;Musselwhite</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/SuzyWallace">Suzy&nbsp;Wallace</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/taryncroucher/">Taryn&nbsp;Croucher</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/peter-kelly/">Peter&nbsp;Kelly</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/ropie/">Richard&nbsp;Opie</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/keithcharvonia/">Keith&nbsp;Charvonia</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/blake-jones/">Blake&nbsp;Jones</a></dd>
		<dd class="no-dropdown  level-2 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/author/matthewjones/">Matthew&nbsp;Jones</a></dd>
	</dl>
</dd>
</dl>
</dd>
<dd class="divider"></dd>
<dd class="has-dropdown level-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://www.speedhunters.com/tag/special-feature/">Special&nbsp;Feature</a>
<dl class="sub-menu dropdown">
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/featurethis/">#FeatureThis</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/iamthespeedhunter/">#IAmTheSpeedhunter</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-carbuilder/">Build</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-collectables/">Collectables</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/dreamdrive/">Dream&nbsp;Drive</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/museum/">Museum</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/tag-retrospective/">Retrospective</a></dd>
	<dd class="no-dropdown  level-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.speedhunters.com/tag/templeofspeed/">Temple Of&nbsp;Speed</a></dd>
</dl>
</dd>
<dd class="divider"></dd>
	</dl>                     
<i data-section-title class="general-icon-minus right"></i>
</nav>
              </section>
            </div>
        </section>
	</header><!-- #header -->
<div class="sticky-nav">
    <div class="sticky-nav-inner row">
        <a href="http://www.speedhunters.com"><i class="sh-logo"></i></a>
                    <span class="sticky-nav-seperator"></span>
            <i class="fi-projection-screen go-presentation-mode" title="Open Presentation Mode"></i>
            <i class="fi-comments go-comments" title="Comment on Story"></i>
                    <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-label">SHARE</span>
            <i class="fi-social-facebook share-facebook" title="Share on Facebook"></i>
            <i class="fi-social-twitter share-twitter" title="Share on Twitter"></i>
            <i class="fi-social-google-plus share-google-plus" title="Share on G+"></i>
            <span class="sticky-nav-seperator"></span>
            <span class="sticky-nav-title">
                Through My Lens: Race Of Champions&nbsp;Miami            </span>
    </div>
</div><div class="row article-start" id="container">
	<div class="large-12 columns" id="primary">
				<article id="post-312852" class="post-312852 post type-post status-publish format-standard has-post-thumbnail hentry category-content category-eventcoverage tag-miami tag-race-of-champions tag-roc-tag tag-usa">
    	<div class="row">
      	<header class="columns story-header">
							<div class="row with-image">
			                <div class="story-meta large-12 columns">
                  <div class="large-10 large-centered columns article-meta">
                	<h1 class="entry-title">Through My Lens: Race Of Champions&nbsp;Miami</h1>
                	<hr />
                  
<div class="story-label category-eventcoverage">
	<span class="potent">EVENT </span><span class="light">COVERAGE</span></div>
                    <dl>
                		                		                		<dt>By</dt>
                		                		<dd><a href="http://www.speedhunters.com/author/2307185532/" title="Posts by Larry Chen" class="url fn" rel="author">Larry Chen</a></dd>
                		                	</dl>
                    <hr />

                	<span class="story-date">2nd February 2017</span>
                	<span class="story-comments">
                      <i class="fi-comments"></i>
                    	<a class="livefyre-commentcount comments-link" href="#livefyre-comments" data-lf-site-id="300779" data-lf-article-id="312852">0 Comments</a>
                	</span>
                </div>
                </div>
			<div class="large-12 go-fullscreen post-feature-image">
				<img data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185429/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_01.jpg" data-attachment-id="312915" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185429/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_01-1200x800.jpg" alt="Through My Lens: Race Of Champions&nbsp;Miami">
			</div>
		</div>
        </header><!-- .entry-header -->
      </div>

      <div class="row">
    		<section class="content columns stick-up">
	<div class="large-10 large-centered columns">
		<nav class="top-bar chapter-nav" style="display:none" role="navigation">
  <ul class="title-area">
    <li class="name">Chapters</li>
    <li class="toggle-topbar">
      <a href="#">
        <span></span>
      </a>
    </li>
  </ul>

  <section class="top-bar-section">
    <ul class="left">

    </ul>
  </section>
</nav>
<div class="large-12 columns pointable chapter-nav-next" style="display:none">
  <h2>
    Next Chapter &gt;
  </h2>
</div>
		<div class="chapter-content">
			<html><head></head><body><span id="chapter-race-of-champions" class="sh-post-chapter-break">Race Of Champions</span>
<p>Even before I started photographing professional racing I knew about Race Of Champions (ROC); the event was so ahead of its time in terms of media and putting out cool videos in pre-YouTube days.</p>
<p>I can specifically remember watching one ROC back in 2006 and being amazed by the way the stadium had been transformed into a temporary race track.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185434/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_02.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185434/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_02-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_02" data-attachment-id="312916" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185434/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_02.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_02/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185434/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_02-1200x800.jpg"></a></figure><p>It’s always been one of those events on my radar to cover, and when I heard that an ROC event was going to be held on US soil for the first time, I knew I had to get along to it.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185438/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_03.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185438/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_03-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_03" data-attachment-id="312917" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185438/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_03.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_03/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185438/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_03-1200x800.jpg"></a></figure><p>Once again the ROC team converted a sports stadium, and it worked perfectly.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185441/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_04.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185441/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_04-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_04" data-attachment-id="312918" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185441/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_04.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_04/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185441/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_04-1200x800.jpg"></a></figure><p>It wasn’t just any venue either, it was the Miami Marlins’ brand new indoor baseball stadium.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185444/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_05.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185444/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_05-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_05" data-attachment-id="312919" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185444/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_05.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_05/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185444/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_05-1200x800.jpg"></a></figure><p>It was beyond cool to see racing in the middle of Miami, and the weather was nice enough to have most of the large doors open.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185447/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_06.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185447/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_06-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_06" data-attachment-id="312920" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185447/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_06.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_06/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185447/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_06-1200x800.jpg"></a></figure><p>Not only that, but the roof was slightly ajar too, letting in beautiful rays of Florida sunshine. More on this later.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185451/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_07.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185451/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_07-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_07" data-attachment-id="312921" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185451/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_07.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_07/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185451/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_07-1200x800.jpg"></a></figure><p>The track itself was short, but it was very technical which made for a great show.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185455/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_08-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_08" data-attachment-id="312922" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185455/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_08.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_08/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185455/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_08-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185114/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_09-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_09" data-attachment-id="312853" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185114/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_09.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_09/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185114/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_09-1200x800.jpg"></div></li></ul><p>And the selection of race cars were second to none.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185116/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_10.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185116/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_10-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_10" data-attachment-id="312854" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185116/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_10.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_10/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185116/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_10-1200x800.jpg"></a></figure><p>There were open-wheel race cars like this Ariel Atom.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185119/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_11.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185119/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_11-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_11" data-attachment-id="312855" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185119/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_11.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_11/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185119/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_11-1200x800.jpg"></a></figure><p>As well as more prototype-like machines like this Radical.</p>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185121/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_12-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_12" data-attachment-id="312856" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185121/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_12.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_12/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185121/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_12-1200x800.jpg"></figure><p><em>Autonation, </em>one of Race Of Champions sponsors,<em> </em>flew me out to Miami, and it was good to be involved as both businesses support <a href="http://racingforcancer.org/" target="_blank">Racing For Cancer</a>. Founded by 2012 IndyCar series champion and Indianapolis 500 winner Ryan Hunter-Reay, this is a great charity that focuses its efforts on beating cancer through education and support services.</p>
<span id="chapter-a-list-drivers" class="sh-post-chapter-break">A-List Drivers</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185124/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_13.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185124/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_13-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_13" data-attachment-id="312857" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185124/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_13.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_13/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185124/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_13-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185127/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_14-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_14" data-attachment-id="312858" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185127/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_14.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_14/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185127/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_14-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185132/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_15-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_15" data-attachment-id="312859" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185132/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_15.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_15/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185132/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_15-1200x800.jpg"></div></li></ul><p>As always, the event drew some big names in motorsport spanning a diverse range of racing disciplines; it was NASCAR drivers like Kurt and Kyle Busch versus F1 stars like Sebastian Vettel and Jenson Button.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185135/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_16.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185135/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_16-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_16" data-attachment-id="312860" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185135/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_16.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_16/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185135/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_16-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185139/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_17-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_17" data-attachment-id="312861" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185139/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_17.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_17/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185139/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_17-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185142/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_18-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_18" data-attachment-id="312862" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185142/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_18.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_18/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185142/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_18-1200x800.jpg"></div></li></ul><p>That is really the magic of ROC: where else do you get to see such high caliber drivers battling it out for bragging rights alone?</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185145/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_19.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185145/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_19-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_19" data-attachment-id="312863" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185145/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_19.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_19/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185145/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_19-1200x800.jpg"></a></figure><p>NASCAR, rally, rallycross, F1 and IndyCar were all represented. All that was missing was a Trophy truck driver and a drifter.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185148/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_20-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_20" data-attachment-id="312864" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185148/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_20.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_20/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185148/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_20-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185151/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_21-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_21" data-attachment-id="312865" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185151/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_21.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_21/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185151/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_21-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185154/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_22.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185154/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_22-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_22" data-attachment-id="312866" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185154/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_22.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_22/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185154/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_22-1200x800.jpg"></a></figure><p>The heads-up racing style was very intense and it made for some really close battles, many of which were decided by thousandths of a second.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185157/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_23.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185157/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_23-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_23" data-attachment-id="312867" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185157/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_23.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_23/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185157/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_23-1200x800.jpg"></a></figure><p>And in many cases, these battles were contested with a passenger riding shotgun in the two-seater vehicles.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185200/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_24-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_24" data-attachment-id="312868" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185200/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_24.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_24/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185200/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_24-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185203/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_25-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_25" data-attachment-id="312869" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185203/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_25.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_25/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185203/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_25-1200x800.jpg"></div></li></ul><p>I don’t know of any other race series that allows this during competition; most of the time this sort of activity is restricted to practice or demonstration sessions. But it was great.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185210/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_27.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185210/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_27-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_27" data-attachment-id="312871" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185210/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_27.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_27/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185210/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_27-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185213/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_28-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_28" data-attachment-id="312872" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185213/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_28.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_28/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185213/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_28-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185216/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_29-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_29" data-attachment-id="312873" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185216/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_29.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_29/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185216/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_29-1200x800.jpg"></div></li></ul><p>It did get a bit scary at one point when one of the three-wheeled vehicles flipped as it approached the finish line.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185219/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_30-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_30" data-attachment-id="312874" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185219/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_30.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_30/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185219/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_30-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185223/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_31-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_31" data-attachment-id="312875" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185223/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_31.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_31/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185223/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_31-1200x800.jpg"></div></li></ul><p>Luckily, neither the driver or passenger were hurt.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185226/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_32.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185226/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_32-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_32" data-attachment-id="312876" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185226/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_32.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_32/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185226/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_32-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185229/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_33-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_33" data-attachment-id="312877" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185229/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_33.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_33/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185229/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_33-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185232/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_34-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_34" data-attachment-id="312878" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185232/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_34.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_34/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185232/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_34-1200x800.jpg"></div></li></ul><p>In between clean up and battles there was always something interesting going on. Terry Grant brought out a number of different vehicles and did some crazy things with them. I watched him work his magic on the set of <a href="http://www.speedhunters.com/2016/02/behind-the-scenes-of-gymkhana-eight/" target="_blank"><em>Gymkhana 8</em></a> when he drove a Ford Raptor for over a mile on two wheels.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185235/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_35.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185235/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_35-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_35" data-attachment-id="312879" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185235/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_35.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_35/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185235/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_35-1200x800.jpg"></a></figure><p>On top of Terry’s contraptions, there were other really cool demo vehicles including an Audi S1 Group B rally car.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185238/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_36-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_36" data-attachment-id="312880" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185238/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_36.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_36/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185238/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_36-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185241/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_37-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_37" data-attachment-id="312881" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185241/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_37.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_37/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185241/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_37-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185244/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_38.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185244/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_38-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_38" data-attachment-id="312882" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185244/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_38.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_38/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185244/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_38-1200x800.jpg"></a></figure><p>The sheer range of vehicles that are raced at ROC make the event a real spectacle.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185247/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_39-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_39" data-attachment-id="312883" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185247/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_39.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_39/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185247/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_39-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185251/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_40-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_40" data-attachment-id="312884" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185251/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_40.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_40/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185251/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_40-1200x800.jpg"></div></li></ul><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185253/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_41.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185253/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_41-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_41" data-attachment-id="312885" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185253/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_41.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_41/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185253/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_41-1200x800.jpg"></a></figure><p>On top of that, the Miami backdrop and shooting right next to the Marlins Park dugout gave me one of those <em>pinch me I must be dreaming</em> moments.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185256/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_42.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185256/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_42-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_42" data-attachment-id="312886" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185256/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_42.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_42/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185256/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_42-1200x800.jpg"></a></figure><p>While the production was focused on a ‘made for TV’ format, it was still exciting to watch in person. Every time cars crossed the finish line, massive flamethrowers shot up.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185259/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_43.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185259/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_43-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_43" data-attachment-id="312887" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185259/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_43.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_43/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185259/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_43-1200x800.jpg"></a></figure><p>And the crowd absolutely loved it.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185302/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_44-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_44" data-attachment-id="312888" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185302/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_44.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_44/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185302/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_44-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185305/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_45-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_45" data-attachment-id="312889" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185305/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_45.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_45/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185305/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_45-1200x800.jpg"></div></li></ul><p>It really was great to see how precise these drivers were tackling the corners. It looks like someone is using the <em>Initial D</em> gutter technique here.</p>
<span id="chapter-photography-nbsp-heaven" class="sh-post-chapter-break">Photography Heaven</span>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185308/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_46.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185308/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_46-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_46" data-attachment-id="312890" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185308/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_46.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_46/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185308/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_46-1200x800.jpg"></a></figure><p>Shooting at Marlins Park was such a treat. It was bright and sunny outside, which allowed for a tiny sliver of light to peak through the massive doors and roof.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185311/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_47.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185311/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_47-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_47" data-attachment-id="312891" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185311/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_47.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_47/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185311/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_47-1200x800.jpg"></a></figure><p>As the day progressed the light shifted and I moved quickly to chase it down.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185314/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_48.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185314/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_48-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_48" data-attachment-id="312892" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185314/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_48.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_48/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185314/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_48-1200x800.jpg"></a></figure><p>The best part of the stadium is that it’s designed for each seat to have a good view of the entire field.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185317/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_49.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185317/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_49-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_49" data-attachment-id="312893" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185317/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_49.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_49/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185317/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_49-1200x800.jpg"></a></figure><p>The truth is, anyone can watch the <a href="https://www.youtube.com/watch?v=bDnafdk19M8" target="_blank">entire race to see all the action</a>. As always, I was just there to capture some of the moments that may have been missed by the live broadcast.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185320/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_50.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185320/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_50-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_50" data-attachment-id="312894" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185320/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_50.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_50/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185320/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_50-1200x800.jpg"></a></figure><p>While there was so much going, one moment truly resonated with me.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185323/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_51.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185323/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_51-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_51" data-attachment-id="312895" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185323/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_51.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_51/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185323/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_51-1200x800.jpg"></a></figure><p>Before Petter Solberg went up against Scott Speed in the final ‘America vs. The Rest of the World’ battle, he was stopped by Sebastian Vettel for a bit of a strategy session.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/31175929/CP0I3384.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/31175929/CP0I3384-680x453.jpg" alt="CP0I3384" data-attachment-id="313106" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/31175929/CP0I3384.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/cp0i3384/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/31175929/CP0I3384-1200x800.jpg"></a></figure><ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185328/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_52-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_52" data-attachment-id="312896" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185328/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_52.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_52/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185328/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_52-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185330/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_53-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_53" data-attachment-id="312897" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185330/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_53.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_53/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185330/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_53-1200x800.jpg"></div></li></ul><p>Whatever they talked about must have worked because Petter took the Super Car Lites machine all the way.</p>
<ul class="image-gallery"><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185334/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_54-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_54" data-attachment-id="312898" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185334/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_54.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_54/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185334/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_54-1200x800.jpg"></div></li><li class="image-row images-2"><div class="gallery-single-image"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185337/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_55-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_55" data-attachment-id="312899" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185337/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_55.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_55/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185337/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_55-1200x800.jpg"></div></li></ul><p>It was awesome to watch everyone including Juan Pablo Montoya hitch a ride to the podium ceremony.</p>
<figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185342/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_56.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185342/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_56-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_56" data-attachment-id="312900" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185342/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_56.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_56/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185342/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_56-1200x800.jpg"></a></figure><p>Having watched Race Of Champions from afar when events were held in Europe and Asia, I’m so glad that it finally made its way to my side of the world. Hopefully ROC will do it again, and perhaps on the West Coast next time.</p>
<p><strong>Larry Chen</strong><br>
Instagram: <a title="Lazza IG" href="http://instagram.com/larry_chen_foto/" target="_blank">larry_chen_foto</a><br>
larry@speedhunters.com</p>
<aside class="exclude-from-p"><p><a href="http://www.speedhunters.com/tag/race-of-champions/" target="_blank">More ROC related stories on Speedhunters</a></p>
</aside><span id="chapter-bonus-images" class="sh-post-chapter-break">Cutting Room Floor</span>
<figure><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185206/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_26-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_26" data-attachment-id="312870" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185206/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_26.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_26/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185206/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_26-1200x800.jpg"></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185346/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_57.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185346/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_57-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_57" data-attachment-id="312901" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185346/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_57.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_57/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185346/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_57-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185349/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_58.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185349/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_58-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_58" data-attachment-id="312902" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185349/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_58.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_58/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185349/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_58-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185353/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_59.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185353/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_59-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_59" data-attachment-id="312903" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185353/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_59.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_59/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185353/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_59-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185355/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_60.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185355/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_60-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_60" data-attachment-id="312904" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185355/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_60.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_60/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185355/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_60-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185359/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_61.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185359/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_61-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_61" data-attachment-id="312905" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185359/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_61.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_61/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185359/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_61-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185401/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_62.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185401/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_62-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_62" data-attachment-id="312906" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185401/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_62.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_62/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185401/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_62-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185404/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_63.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185404/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_63-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_63" data-attachment-id="312907" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185404/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_63.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_63/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185404/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_63-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185407/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_64.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185407/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_64-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_64" data-attachment-id="312908" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185407/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_64.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_64/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185407/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_64-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185411/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_65.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185411/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_65-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_65" data-attachment-id="312909" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185411/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_65.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_65/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185411/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_65-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185413/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_66.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185413/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_66-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_66" data-attachment-id="312910" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185413/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_66.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_66/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185413/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_66-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185416/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_67.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185416/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_67-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_67" data-attachment-id="312911" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185416/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_67.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_67/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185416/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_67-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185420/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_68.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185420/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_68-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_68" data-attachment-id="312912" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185420/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_68.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_68/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185420/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_68-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185423/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_69.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185423/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_69-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_69" data-attachment-id="312913" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185423/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_69.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_69/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185423/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_69-1200x800.jpg"></a></figure><figure><a href="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185426/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_70.jpg"><img class="alignnone" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185426/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_70-680x453.jpg" alt="Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_70" data-attachment-id="312914" data-go-fullscreen="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185426/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_70.jpg" data-can-print="true" data-attachment-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/larry_chen_2017_speedhunters_roc_race_of_champions_miami_70/" data-src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/30185426/Larry_Chen_2017_Speedhunters_roc_Race_of_champions_miami_70-1200x800.jpg"></a></figure></body></html>
		</div>
	</div>
	<div class="row">
		<div class="inline-mpu-container">
  <small>ADVERTISEMENT</small>
  <!-- Inline_MPU -->
  <div class="inline-mpu">
    <div id='div-gpt-ad-1401958887607-0' style='width:770px; height:513px;'>
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1401958887607-0'); });
      </script>
    </div>
  </div>
</div>
	</div>
	<div class="large-10 large-centered columns">
			<section id="secondary" class="stick-measure" role="complementary">
    	<div class="row">
    		    		<aside id="relatedarticles-widget-2" class="large-12 columns widget relatedarticles">    	<div class="sh-ajax-container" data-sh-ajax-args='{"fn":"get_custom_stories","count":"3","columns":3,"tags":[5384,6678,8818,3717],"excerpt":"150","exclude":[312852]}'>
        <div class="row">
        	<div class="large-12 columns">
        		<h4 class="related-stories-title">Related Stories</h4>
        	</div>
        </div>
        <div class="row">
        	<div class="large-12 columns sh-ajax-content">
            <div class="row">
                <div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2017/01/new-york-city-car-life/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2017/01/19014020/prime-streeticons-2017-pravan-kuntmala-speedhunters-013-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2017/01/new-york-city-car-life/">
		
<div class="card-label category-speedhunterscrew">
		<span class="potent">SPECIAL </span><span class="light">FEATURE</span></div>
		<h2>This Is NYC Car&nbsp;Life</h2>
		<span class="date">January 23, 2017</span>
		<span class="divider">/</span>
		<span class="livefyre-commentcount comments" data-lf-site-id="300779"
		data-lf-article-id="311053"> 0 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2016/12/nine-countries-four-continents-one-irishman/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/12/16104021/2016-Paddy-McGrath-Speedhunters-Year-In-Review-COVER-1-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2016/12/nine-countries-four-continents-one-irishman/">
		
<div class="card-label category-speedhunterscrew">
		<span class="potent">SPECIAL </span><span class="light">FEATURE</span></div>
		<h2>Nine Countries, Four Continents, One&nbsp;Irishman</h2>
		<span class="date">December 27, 2016</span>
		<span class="divider">/</span>
		<span class="livefyre-commentcount comments" data-lf-site-id="300779"
		data-lf-article-id="305467"> 0 Comments</span>
	 </a>
</div>

	</div><div class="card medium-4 columns columns">			<a class="content-thumbnail" href="http://www.speedhunters.com/2016/11/moments-time-art-nhra-drag-racing/">
			<img src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/28122137/Larry_Chen_Speedhunters_NHRA_2016_01-520x346.jpg" />
		</a>
		

<div class="meta">
	<a href="http://www.speedhunters.com/2016/11/moments-time-art-nhra-drag-racing/">
		
<div class="card-label category-speedhunterscrew">
		<span class="potent">SPECIAL </span><span class="light">FEATURE</span></div>
		<h2>Moments In Time: The Art Of NHRA Drag&nbsp;Racing</h2>
		<span class="date">November 30, 2016</span>
		<span class="divider">/</span>
		<span class="livefyre-commentcount comments" data-lf-site-id="300779"
		data-lf-article-id="305485"> 0 Comments</span>
	 </a>
</div>

	</div><div class="large-12 columns"><hr class="no-border hide-for-small"></div>            </div>
        	</div>
        </div>
    </div>
    </aside>        </div>
	</section><!-- #secondary -->
		<h4 class="comments-title">Comments</h4>
		<div id="livefyre-comments"><script>
  (function() {
    
   var a=this;var b,c,d,e,f;function g(){return a.navigator?a.navigator.userAgent:null}f=e=d=c=b=!1;var h;if(h=g()){var i=a.navigator;b=0==h.indexOf("Opera");c=!b&&-1!=h.indexOf("MSIE");e=(d=!b&&-1!=h.indexOf("WebKit"))&&-1!=h.indexOf("Mobile");f=!b&&!d&&"Gecko"==i.product}var j=c,k=f,l=d,m=e;var n;if(b&&a.opera){var o=a.opera.version;"function"==typeof o&&o()}else k?n=/rv\:([^\);]+)(\)|;)/:j?n=/MSIE\s+([^\);]+)(\)|;)/:l&&(n=/WebKit\/(\S+)/),n&&n.exec(g());var p=document,q=p.createElement("link");q.rel="stylesheet";q.type="text/css";q.href="http://zor.fyre.co/wjs/v3.0/css/livefyre_"+(m?"mobile":"embed")+".css";q.media="all";p.getElementsByTagName("head")[0].appendChild(q);var r="header hgroup footer article section aside nav figure figcaption embed audio video canvas details summary time mark".split(" "),s=p.createDocumentFragment(),t;for(t=0; t<r.length; t++){s.appendChild(p.createElement(r[t]))};
   })();    
</script>
<div class="fyre fyre-width-large fyre-bootstrap">
  <div class="fyre-widget">
    <div class="fyre-stream-stats">
      <div class="fyre-comment-count">
        <span>0 comments</span>
      </div>

      <div class="fyre-divider"></div>

      <div class="fyre-help">
        <div class="fyre-box-wrapper">
          <a href="http://livefyre.com" target="_blank"><span class="fyre-logo-drop">&nbsp</span>
          <img class="fyre-logo-help" src="http://zor.fyre.co/wjs/v3.0/images/lf-logo.png" alt="Livefyre" /></a>
          
          <ul class="fyre-box-list">
            <li><a href="http://livefyre.com" target="_blank" title="Get Livefyre">Get
            Livefyre</a></li>

            <li><a href="http://support.livefyre.com" target="_blank" title=
            "FAQ">FAQ</a></li>
          </ul>
        </div>
      </div>
    </div>

    <div class="fyre-auth">
      <div class="fyre-login-bar"><a rel="nofollow" href="#" class="fyre-user-loggedout">Sign in</a></div>
    </div>

    <div class="fyre-editor">
      <div class="fyre-editor-container">
        <div class="fyre-editor-editable" style="height: 100px;"></div>

        <div class="fyre-editor-toolbar">
          <div class="goog-toolbar goog-toolbar-horizontal" style=
          "-webkit-user-select: none;" role="toolbar" aria-activedescendant="">
            <div class="goog-inline-block fyre-button-left fyre-format-button" title=""
            role="button" style="-webkit-user-select: none;" id=":0">
              <div class="goog-inline-block fyre-button-left-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-left-inner-box" style=
                "-webkit-user-select: none;"></div>
              </div>
            </div>

            <div class="goog-inline-block fyre-button-left fyre-mention-button" title=""
            role="button" style="-webkit-user-select: none;" id=":1">
              <div class="goog-inline-block fyre-button-left-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-left-inner-box" style=
                "-webkit-user-select: none;"></div>
              </div>
            </div>

            <div class="goog-inline-block fyre-button-left fyre-follow-button" title=""
            role="button" style="-webkit-user-select: none;" id=":2">
              <div class="goog-inline-block fyre-button-left-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-left-inner-box" style=
                "-webkit-user-select: none;">
                  + Follow
                </div>
              </div>
            </div>

            <div class=
            "goog-inline-block fyre-button-right fyre-post-button fyre-post-button-enabled"
            title="" role="button" style="-webkit-user-select: none;" id=":3">
              <div class="goog-inline-block fyre-button-right-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-right-inner-box" style=
                "-webkit-user-select: none;">
                  Post comment
                </div>
              </div>
            </div>

            <div class=
            "goog-inline-block fyre-button-right fyre-post-to fyre-post-to-facebook"
            title="" role="button" style="-webkit-user-select: none;" id=":4">
              <div class="goog-inline-block fyre-button-right-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-right-inner-box" style=
                "-webkit-user-select: none;"></div>
              </div>
            </div>

            <div class=
            "goog-inline-block fyre-button-right fyre-post-to fyre-post-to-twitter"
            title="" role="button" style="-webkit-user-select: none;" id=":5">
              <div class="goog-inline-block fyre-button-right-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-right-inner-box" style=
                "-webkit-user-select: none;"></div>
              </div>
            </div>

            <div class=
            "goog-inline-block fyre-button-right fyre-post-to fyre-post-to-linkedin"
            title="" role="button" style="-webkit-user-select: none;" id=":7">
              <div class="goog-inline-block fyre-button-right-outer-box" style=
              "-webkit-user-select: none;">
                <div class="goog-inline-block fyre-button-right-inner-box" style=
                "-webkit-user-select: none;"></div>
              </div>
            </div>

            <div class="goog-toolbar-separator goog-inline-block" style=
            "-webkit-user-select: none;" role="separator" id=":6">
              &nbsp;
            </div>
          </div>

          <div class="fyre-format-toolbar" style="display: none;">
            <div class="goog-toolbar goog-toolbar-horizontal" style=
            "-webkit-user-select: none;" role="toolbar" tabindex="-1">
              <div class="goog-inline-block goog-toolbar-button" title="Bold"
              aria-pressed="true" role="button" style="-webkit-user-select: none;" id=
              "+bold">
                <div class="goog-inline-block goog-toolbar-button-outer-box" style=
                "-webkit-user-select: none;">
                  <div class="goog-inline-block goog-toolbar-button-inner-box" style=
                  "-webkit-user-select: none;">
                    <div class="tr-icon tr-bold" style="-webkit-user-select: none;">
                    </div>
                  </div>
                </div>
              </div>

              <div class="goog-inline-block goog-toolbar-button" title="Italic"
              aria-pressed="true" role="button" style="-webkit-user-select: none;" id=
              "+italic">
                <div class="goog-inline-block goog-toolbar-button-outer-box" style=
                "-webkit-user-select: none;">
                  <div class="goog-inline-block goog-toolbar-button-inner-box" style=
                  "-webkit-user-select: none;">
                    <div class="tr-icon tr-italic" style="-webkit-user-select: none;">
                    </div>
                  </div>
                </div>
              </div>

              <div class="goog-inline-block goog-toolbar-button" title="Underline"
              aria-pressed="true" role="button" style="-webkit-user-select: none;" id=
              "+underline">
                <div class="goog-inline-block goog-toolbar-button-outer-box" style=
                "-webkit-user-select: none;">
                  <div class="goog-inline-block goog-toolbar-button-inner-box" style=
                  "-webkit-user-select: none;">
                    <div class="tr-icon tr-underline" style="-webkit-user-select: none;">
                    </div>
                  </div>
                </div>
              </div>

              <div class="goog-inline-block goog-toolbar-button" title=
              "Add or remove link" aria-pressed="true" role="button" style=
              "-webkit-user-select: none;" id="+link">
                <div class="goog-inline-block goog-toolbar-button-outer-box" style=
                "-webkit-user-select: none;">
                  <div class="goog-inline-block goog-toolbar-button-inner-box" style=
                  "-webkit-user-select: none;">
                    <div class="tr-link" style="-webkit-user-select: none;">
                      Link
                    </div>
                  </div>
                </div>
              </div>

              <div class="goog-inline-block goog-toolbar-button" title="Numbered list"
              aria-pressed="true" role="button" style="-webkit-user-select: none;" id=
              "+insertOrderedList">
                <div class="goog-inline-block goog-toolbar-button-outer-box" style=
                "-webkit-user-select: none;">
                  <div class="goog-inline-block goog-toolbar-button-inner-box" style=
                  "-webkit-user-select: none;">
                    <div class="tr-icon tr-insertOrderedList" style=
                    "-webkit-user-select: none;"></div>
                  </div>
                </div>
              </div>

              <div class="goog-inline-block goog-toolbar-button" title="Bullet list"
              aria-pressed="true" role="button" style="-webkit-user-select: none;" id=
              "+insertUnorderedList">
                <div class="goog-inline-block goog-toolbar-button-outer-box" style=
                "-webkit-user-select: none;">
                  <div class="goog-inline-block goog-toolbar-button-inner-box" style=
                  "-webkit-user-select: none;">
                    <div class="tr-icon tr-insertUnorderedList" style=
                    "-webkit-user-select: none;"></div>
                  </div>
                </div>
              </div>
            </div>
          </div>
        </div>
      </div>
    </div>

    <div class="fyre-comment-stream" style="">
      <div class="fyre-stream-sort">
        <a class="fyre-stream-sort-newest">Newest</a> | <a class="fyre-stream-sort-oldest">Oldest</a>
      </div>

      <div class="fyre-stream-content">      
        
      </div>
    </div>
  </div>
</div>
</div>	</div>

	<div class="row">
		<div class="large-12 columns official-sh-suppliers">
	<div class="row s-logos">
		<div class="large-12 large-centered columns">
			<h3>OFFICIAL SPEEDHUNTERS SUPPLIERS</h3>
		</div>
		<div class="large-12 columns">
			<ul class="large-block-grid-8 small-block-grid-4 text-center"/><li><a href="https://www.airliftperformance.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095009/airliftcompany.png"/></a></li><li><a href="http://csfrace.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095013/csf-racing.png"/></a></li><li><a href="http://www.fueloffroad.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041516/fuel.png"/></a></li><li><a href="http://www.kleers.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095015/kleers.png"/></a></li><li><a href="http://www.kwsuspensions.de/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/08053600/KW-Logo.png"/></a></li><li><a href="http://www.rayswheels.co.jp/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/05/25095017/rays.png"/></a></li><li><a href="http://www.rotiform.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/07041517/rotiform.png"/></a></li><li><a href="http://www.takataracingstore.com/"><img class="s-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/11/24051331/takata.png"/></a></li></ul>		</div>
	</div>
</div>
	</div>

  <div id="smartImageMenu">
<div id="image-context-menu" class="context-menu" style="display:none">
    <div class="row">
            	   <div data-click-action="go-fullscreen" class="large-3 small-3 columns smart-option">
    		  <i class="fi-projection-screen go-presentation-mode"></i>
    		  <h6>PRESENTATION MODE</h6>
            </div>
                <div data-click-action="download" class="large-3 small-3 columns smart-option">
            <i class="fi-download download-wallpaper"></i>
            <h6>DOWNLOAD WALLPAPER</h6>
        </div>
    	<div data-click-action="order-print" class="large-3 small-3 columns smart-option">
    		<i class="fi-shopping-cart"></i>
    		<h6>ORDER PRINT</h6>
    	</div>
    	<div data-click-action="share-image" class="large-3 small-3 columns smart-option">
    		<i class="fi-heart show-share-buttons"></i>
    		<h6>SHARE</h6>
            <div class="share-buttons">    
    <i data-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/" class="fi-social-facebook share-facebook"></i>
    <span class="separator"></span>
    <i data-url="http://www.speedhunters.com/2017/02/through-my-lens-race-of-champions-miami/" class="fi-social-twitter share-twitter"></i>
</div>    	</div>
    </div>
</div>
</div></section><!-- .content -->
      </div>

		</article><!-- #post-## -->
			</div><!-- #primary -->
</div><!-- #container -->
    
<a href="#top" id="toTop"></a>
<div class="row">
	<footer class="site-footer end-bloc columns stick-stop">
		<!-- FOOTER META -->
		<div class="row">
    		<div id="text-2" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>Speedhunters is an international collective of photographers, writers & drivers with a shared passion for digging up the most exciting stories surrounding Car Culture happening anywhere in the world. </p>
</div>
		</div></div><div id="text-3" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Contact Us</h4>			<div class="textwidget">We're always very interested to hear your own stories as well as to receive your feedback. Please <a href="http://www.speedhunters.com/frequently-asked-questions-faq/">take a look at our FAQ</a> first but if you don't find what you are looking for then you are welcome to <a href="mailto:enquiries@speedhunters.com?Subject=Enquiry">contact us via email</a>, thank you.</div>
		</div></div><div id="text-4" class="medium-4 widget columns widget_text"><div class="widget-inner"><h4 class="widget-title">Speedhunters Social</h4>			<div class="textwidget"><dl>
	<dd><i class="fi-social-instagram"></i> - <a href="http://instagram.com/thespeedhunters">&#64;TheSpeedhunters</a></dd>
	<dd><i class="fi-social-twitter"></i> - <a href="https://twitter.com/speedhunters">&#64;Speedhunters</a></dd>
	<dd><i class="fi-social-facebook"></i> - <a href="https://www.facebook.com/Speedhunters">Speedhunters</a></dd>
	<dd><i class="fi-rss"></i> - <a href="http://feeds.feedburner.com/speedhunters">RSS</a></dd>
</dl></div>
		</div></div>		</div>
		<div class="row">
		<!-- THE TEAM -->
        	<div class="large-4 columns credits">
        		<h4 class="widget-title">Team</h4>			<div class="textwidget">Editor in Chief:
<em>Dino Dalle Carbonare</em> <br />

Editorial Manager:
<em>Brad Lord</em> <br />

Project Manager:
<em>Annika Goksu</em> <br />

Commercial Director: 
<em>Ben Chandler</em><br />

Product Associate: 
<em>Arslan Golic</em><br />

Commercial Editor:
<em>Paddy McGrath</em><br />

Community Manager: 
<em>Mark Riccioni</em><br />

Senior Contributors: 
<em>Larry Chen, Keith Charvonia, Mike Garrett</em><br />

Contributors: 
<em>Blake Jones, Richard Opie, Louis Yio, Jordan Butters, Alok Paleri, Matthew Everingham</em><br />

Builders-Drivers: 
<em>Daniel Covarrubias, Peter Pentell, Edward Sandström</em> <br /> 

This month's IAmTheSpeedhunter: <em>Florian Grout, Corey Whitson, Stefan Kotze, Edwin Reyes, Edwin Reyes, Pravan Kuntmala, Brian Chin, Saliou Omar Khoule, Yuri Zabavchik</em><br />
</div>
		            </div>
		<!-- PARTNERS -->
			<div class="large-8 columns">
	    		<div class="footer-partners widget"><h4 class="widget-title">Event Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.fatlace.com"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/fatlace.jpg" /></a></li>	
	<li><a href="http://formulad.com"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/08/19004845/formula-drift.png" /></a></li>
	<li><a href="http://gatebil.no"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/gatebil.jpg" /></a></li>
	<li><a href="http://fatlace.com/offsetkings/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/offsetkings.jpg" /></a></li>	
	<li><a href="http://www.players-show.com/index.html"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/players.jpg" /></a></li>
<li><a href="http://www.retrokings.co.uk"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/retrokings.jpg" /></a></li>
<li><a href="http://www.tunerfest.co.uk"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/tunerfest.jpg" /></a></li>
</ul>
</div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Merchandise Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.boltgraphics.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/boltgraphics.jpg" /></a></li>
	<li><a href="http://stanceandspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/stancespeed.jpg" /></a></li>
	<li><a href="http://www.kleerfreight.com/"><img class="th p-logo" src="http://speedhunters-wp-production.s3.amazonaws.com/wp-content/uploads/2016/06/23044303/kleerfreight-logo.png" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Entertainment Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://ghostgames.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ghost.jpg" /></a></li>
	<li><a href="http://needforspeed.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/needforspeed.jpg" /></a></li>
</ul></div>
		</div><div class="footer-partners widget"><h4 class="widget-title">Automotive Partners</h4>			<div class="textwidget"><ul class="large-block-grid-5 small-block-grid-2">
	<li><a href="http://www.charlesngracing.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/charlesng.jpg" /></a></li>
	<li><a href="http://www.edward.nu/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/edward.jpg" /></a></li>
	<li><a href="http://motorheadmagazine.jp/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/motorhead.jpg" /></a></li>
	<li><a href="http://www.stephanpapadakis.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/papadakis.jpg" /></a></li>
	<li><a href="http://www.tra-kyoto.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/rocketbunny.jpg" /></a></li>
	<li><a href="http://www.mcnsport.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/mcn.jpg" /></a></li>
	<li><a href="http://www.ponydrift.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ponydrift.jpg" /></a></li>
	<li><a href="http://www.r-garage.de/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/ring-garage.jpg" /></a></li>
<li><a href="http://www.vaughngittin.com/"><img class="th p-logo" src="/wp-content/themes/speedhunters_xiii/images/affiliates/logos/vaughn.jpg" /></a></li>
</ul></div>
		</div>			</div>
		</div>
		<!-- COPYRIGHT -->
		<div class="row">
			<div class="medium-12 columns">
	    		<h6 class="subheader">			<div class="textwidget"><div class="copyright-branding">
<div>
<img src="/wp-content/themes/speedhunters_xiii/images/branding/ea-logo.png" />
</div>
<div>
© 2016 ELECTRONIC ARTS INC.<br />TRADEMARKS BELONG TO THEIR RESPECTIVE OWNERS. ALL RIGHTS RESERVED
</div>
</div></div>
		</h6><h6 class="subheader">			<div class="textwidget"><a href="http://www.ea.com/terms-of-service">TERMS OF SERVICE</a> // 
<a href="http://www.ea.com/privacy-policy">PRIVACY & COOKIE POLICY</a> // 
<a href="http://www.ea.com/1/legal-notices">LEGAL NOTICES</a> // 
<a href="http://www.speedhunters.com/advertising-opportunities/">ADVERTISING OPPORTUNITIES</a></div>
		</h6>			</div>
		</div>
	</footer>
</div>

<script type="text/javascript">var lf_config = [{"collectionMeta":"eyJ0eXAiOiJqd3QiLCJhbGciOiJIUzI1NiJ9.eyJ0aXRsZSI6IlRocm91Z2ggTXkgTGVuczogUmFjZSBPZiBDaGFtcGlvbnMmbmJzcDtNaWFtaSIsInVybCI6Imh0dHA6XC9cL3d3dy5zcGVlZGh1bnRlcnMuY29tXC8yMDE3XC8wMlwvdGhyb3VnaC1teS1sZW5zLXJhY2Utb2YtY2hhbXBpb25zLW1pYW1pXC8iLCJ0YWdzIjpbIk1pYW1pIiwiUmFjZSBPZiBDaGFtcGlvbnMiLCJyb2MiLCJVU0EiXSwiY2hlY2tzdW0iOiJiN2QwYzVmYmE1YjhkM2RhMDkzYzBiOTEzN2U2MDJjNCIsImFydGljbGVJZCI6MzEyODUyfQ.RPhsZqV6qn2WJXfDUitNAAimFSg8NsJFoAE-kX12kQM","checksum":"b7d0c5fba5b8d3da093c0b9137e602c4","siteId":"300779","articleId":312852,"strings":"","el":"livefyre-comments"}];var conv = fyre.conv.load({}, lf_config);</script>
            <!-- LF DEBUG
            site-id: 300779
            article-id: 312852
            post-type: post
            comments-open: true
            is-single: true
            display-posts: true
            display-pages: false
            -->
        	<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-42876210-1', 'auto');
	  ga('require', 'displayfeatures');

	</script>
	<script type='text/javascript'>var tracking_campaign_tags = []</script><script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/custom.modernizr.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/idangerous.swiper-2.1.min.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/vendor/jquery.unveil.sh.js'></script>
<script type='text/javascript' src='http://www.speedhunters.com/wp-content/themes/speedhunters_xiii/js/foundation.js'></script>

<script>
	jQuery(document).foundation();
</script>
</body>
</html>
<!-- Dynamic page generated in 1.213 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-02-02 01:22:37 -->

<!-- super cache -->